Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 14:18

Как обратиться к реквизитам динамического списка на форме списка?

Автор Yamuna, 07 июн 2019, 17:42

0 Пользователей и 2 гостей просматривают эту тему.

Yamuna

Добрый день! Нужно получить значение реквизита динамического списка на форме списка  из модуля формы списка,что бы потом его анализировать, пожалуйста подскажите как это сделать?

bsn-chita

У динамического списка можно получить данные только у выбранного элемента.

&НаКлиенте
Процедура ПолучитьТекущиеДанные(Команда)
ТекущиеДанные = Элементы.Список.ТекущиеДанные;
ТекущаяСтрока = Элементы.Список.ТекущаяСтрока;
КонецПроцедуры

Yamuna

Цитата: bsn-chita от 08 июн 2019, 01:43
У динамического списка можно получить данные только у выбранного элемента.

&НаКлиенте
Процедура ПолучитьТекущиеДанные(Команда)
ТекущиеДанные = Элементы.Список.ТекущиеДанные;
ТекущаяСтрока = Элементы.Список.ТекущаяСтрока;
КонецПроцедуры

На форме списка есть реквизит Статус, который рассчитывается в динамическом списке и у меня не получается получить значение реквизита формы списка , подскажите почему не так?
ошибка:{Справочник.КабинетНачинающихКлиентов.Форма.ФормаСписка.Форма(6)}: Значение не является значением объектного типа (Статус)
   Сообщить(стДанные.Статус);
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    стДанные = Элементы.Список.ТекущиеДанные;
Сообщить(стДанные.Статус);

КонецПроцедуры


Yamuna

Цитата: bsn-chita от 08 июн 2019, 06:40
http://forum-1c.ru/index.php?topic=64060.0

А где тогда можно получить еще ТекущиеДанные(), в каком событии , если менять их мне не надо, а надо просто анализировать? другими словами как получить значение этого реквизита, что бы потом с ним работать?

bsn-chita


Yamuna

Цитата: bsn-chita от 08 июн 2019, 08:15
Я бы делал в СписокПриАктивизацииСтроки.

А у меня в модуле формы списка нет такого события? как быть?

bsn-chita


Yamuna

Цитата: bsn-chita от 08 июн 2019, 09:14
У Список событие смотри а не у формы.
у меня не получается найти это событие, поподробней объяснить сможете?

а .. нашел сори!
Добавлено: 08 июн 2019, 10:07


Цитата: bsn-chita от 08 июн 2019, 08:15
Я бы делал в СписокПриАктивизацииСтроки.
и все равно пишет поле Формы а как значение получить?
&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
ТекДан = Элементы.Список.ТекущиеДанные;
Сообщить(ТекДан.Статус);
КонецПроцедуры

AIFrame

Цитата: Yamuna от 07 июн 2019, 17:42
Добрый день! Нужно получить значение реквизита динамического списка на форме списка  из модуля формы списка,что бы потом его анализировать, пожалуйста подскажите как это сделать?
Если без привязки к курсору типа "ТекущиеДанные" (Например, для условного оформления на форме) - то только повторением запроса со всеми отборами и параметрами.
На самом деле, ничего сложного.


// Эмулируем запрос, чтобы получить его данные таблицей
Запрос = Новый Запрос;
Запрос.Текст = СвойстваКомплектующего.ТекстЗапроса;
Запрос.УстановитьПараметр("Ссылка", Объект.БазовоеУстройство);

ТЧ = Запрос.Выполнить().Выгрузить();

Для Каждого СтрокаТЧ ИЗ ТЧ Цикл
            // /// /// / // 
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск