Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Авг 2019, 18:32
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как обратиться к реквизитам динамического списка на форме списка?  (Прочитано 469 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yamuna

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! Нужно получить значение реквизита динамического списка на форме списка  из модуля формы списка,что бы потом его анализировать, пожалуйста подскажите как это сделать?


Оффлайн bsn-chita

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 28
  • КПД: 31%
  • Регистрация: 2017-03-06
  • Сайт: 
  • Профессия: Ученик 1С
У динамического списка можно получить данные только у выбранного элемента.
&НаКлиенте
Процедура ПолучитьТекущиеДанные(Команда)
ТекущиеДанные = Элементы.Список.ТекущиеДанные;
ТекущаяСтрока = Элементы.Список.ТекущаяСтрока;
КонецПроцедуры

Оффлайн Yamuna

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
У динамического списка можно получить данные только у выбранного элемента.
&НаКлиенте
Процедура ПолучитьТекущиеДанные(Команда)
ТекущиеДанные = Элементы.Список.ТекущиеДанные;
ТекущаяСтрока = Элементы.Список.ТекущаяСтрока;
КонецПроцедуры
На форме списка есть реквизит Статус, который рассчитывается в динамическом списке и у меня не получается получить значение реквизита формы списка , подскажите почему не так?
ошибка:{Справочник.КабинетНачинающихКлиентов.Форма.ФормаСписка.Форма(6)}: Значение не является значением объектного типа (Статус)
   Сообщить(стДанные.Статус);
&НаКлиенте
Процедура ПриОткрытии(Отказ)
    стДанные = Элементы.Список.ТекущиеДанные;
Сообщить(стДанные.Статус);

КонецПроцедуры

Оффлайн bsn-chita

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 28
  • КПД: 31%
  • Регистрация: 2017-03-06
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн Yamuna

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
http://forum-1c.ru/index.php?topic=64060.0

А где тогда можно получить еще ТекущиеДанные(), в каком событии , если менять их мне не надо, а надо просто анализировать? другими словами как получить значение этого реквизита, что бы потом с ним работать?

Оффлайн bsn-chita

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 28
  • КПД: 31%
  • Регистрация: 2017-03-06
  • Сайт: 
  • Профессия: Ученик 1С
Я бы делал в СписокПриАктивизацииСтроки.

Оффлайн Yamuna

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
Я бы делал в СписокПриАктивизацииСтроки.

А у меня в модуле формы списка нет такого события? как быть?

Оффлайн bsn-chita

  • **
  • Сообщений: 91
  • РЕПУТАЦИЯ: 28
  • КПД: 31%
  • Регистрация: 2017-03-06
  • Сайт: 
  • Профессия: Ученик 1С
У Список событие смотри а не у формы.

Оффлайн Yamuna

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-04-19
  • Сайт: 
  • Профессия: Ученик 1С
У Список событие смотри а не у формы.
у меня не получается найти это событие, поподробней объяснить сможете?

а .. нашел сори!
Добавлено: 08 Июн 2019, 10:07

Я бы делал в СписокПриАктивизацииСтроки.
и все равно пишет поле Формы а как значение получить?
&НаКлиенте
Процедура СписокПриАктивизацииСтроки(Элемент)
ТекДан = Элементы.Список.ТекущиеДанные;
Сообщить(ТекДан.Статус);
КонецПроцедуры

Последний раз редактировалось: Yamuna; 08 Июн 2019, 10:07. Причина: Объединение сообщений

Оффлайн AIFrame

  • *****
  • Сообщений: 1396
  • РЕПУТАЦИЯ: 182
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
Добрый день! Нужно получить значение реквизита динамического списка на форме списка  из модуля формы списка,что бы потом его анализировать, пожалуйста подскажите как это сделать?
Если без привязки к курсору типа "ТекущиеДанные" (Например, для условного оформления на форме) - то только повторением запроса со всеми отборами и параметрами.
На самом деле, ничего сложного.


	// Эмулируем запрос, чтобы получить его данные таблицей
Запрос = Новый Запрос;
Запрос.Текст = СвойстваКомплектующего.ТекстЗапроса;
Запрос.УстановитьПараметр("Ссылка", Объект.БазовоеУстройство);

ТЧ = Запрос.Выполнить().Выгрузить();

Для Каждого СтрокаТЧ ИЗ ТЧ Цикл
            // /// /// / // 
КонецЦикла;


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2657
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2854
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1828
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3666
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Модуль к форме "Настройка заполнения"

Автор oyufedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5270
Последний ответ 17 Янв 2014, 16:35
от oyufed

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
116 Сообщений
alexandr_ll
59 Сообщений
alex0402 alex0402
45 Сообщений
LexaK
45 Сообщений
DmitriyF DmitriyF
31 Сообщений
BuhRust
27 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений
Stanislav Gareev
19 Сообщений
Funt432286
16 Сообщений
Андрей_gen_D
16 Сообщений

* Кто онлайн

  • Точка Гостей: 225
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal