Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Авг 2019, 16:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод значений в табличную часть из другого документа  (Прочитано 122 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lecowi

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-03-19
  • Сайт: 
  • Профессия: Программист 1С
Помогите разобраться с вопросом.
Есть два документа:
Отпуск материалов с табличной частью ОтгружаемыеТовары
ИнвентаризацияМатериалов с табличной частью Материалы
В документе ОтпускМатериалов создан реквизит Инвентаризация, который имеет тип ДокументСсылка.ИнвентаризацияМатериалов, также на форме документа создана кнопка ЗаполнитьПоИнвентаризации.
Необходимо при выборе значений в поле Инвентаризация, по нажатию кнопки заполнялась табличная часть документа ОтпускМатериалов из документа ИнвентаризацияМатериалов.
Вот исходный код:

&НаКлиенте
Процедура ЗаполнитьПоИнвентаризации(Команда)
Если Объект.Инвентаризация.Пустая() Тогда
Возврат;
КонецЕсли;
ЗаполнитьПоИнвентаризацииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьПоИнвентаризацииНаСервере()
Массив = Инвентаризация.Выгрузить();
Объект.ОтгружаемыеТовары.Загрузить(Массив);
КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 07 Июн 2019, 11:56


Онлайн LexaK

  • *****
  • Сообщений: 1767
  • РЕПУТАЦИЯ: 509
  • КПД: 29%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте так
&НаСервере
Процедура ЗаполнитьПоИнвентаризацииНаСервере()
   ОтгружаемыеТовары.Загрузить(Инвентаризация.Материалы.Выгрузить());
КонецПроцедуры
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5320
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5600
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2389
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8961
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6976
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
118 Сообщений
alexandr_ll
62 Сообщений
alex0402 alex0402
45 Сообщений
LexaK
44 Сообщений
DmitriyF DmitriyF
29 Сообщений
BuhRust
28 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
Stanislav Gareev
19 Сообщений
Funt432286
18 Сообщений
aleon1
16 Сообщений

* Кто онлайн

  • Точка Гостей: 641
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal