Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Авг 2019, 18:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка при открытии формы  (Прочитано 101 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ab30ru

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-06-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. При выполнении операции система пишет Интерактивные функции недоступны. Помогите пожалуйста с проблемой.
&НаСервере
Процедура ОбработатьНаСервере(Идентификатор)
ТекДанные = Объект.СписокДокументов.НайтиПоИдентификатору(Идентификатор);
ТекущийФайл=ТекДанные.Файл;
ТекущийДокумент=ТекДанные.Документ;
Выборка = Справочники.Файлы.Выбрать();
Пока Выборка.Следующий() Цикл

Если Выборка.Наименование = Строка(ТекущийФайл) И Строка(Выборка.СсылкаНаВладельца)=Строка(ТекущийДокумент) Тогда //Ура нашли , но мало ли продолжаем искать )))
КодФайла=Выборка.Код;
КонецЕсли;
КонецЦикла;
Файл=Справочники.Файлы.НайтиПоКоду(КодФайла);
Файл.ПолучитьФорму("ФормаЭлемента").Открыть();
КонецПроцедуры

&НаКлиенте
Процедура ПерейтиКФайлу(Команда)
СтрТЧ=Элементы.СписокДокументов.ТекущиеДанные;
ОбработатьНаСервере(СтрТЧ.ПолучитьИдентификатор());
КонецПроцедуры


Оффлайн LexaK

  • *****
  • Сообщений: 1772
  • РЕПУТАЦИЯ: 509
  • КПД: 29%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
:D :D
&НаСервере
Процедура ОбработатьНаСервере(Идентификатор)
Сообщить(Файл);
    ...
    Файл.ПолучитьФорму("ФормаЭлемента").Открыть();
КонецПроцедуры
Какое открытие формы на Сервере? Перенесите на Клиента
Помогло? - Нажми СПАСИБО!!!
                       :)


Теги:
 

Ошибка "Неправильный псевдоним "Т.Ссылка" <<?>> Т.Ссылка как номенклатура"

Автор Андрей БулановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 982
Последний ответ 13 Окт 2018, 21:51
от Андрей Буланов
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7521
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5540
Последний ответ 28 Апр 2014, 15:53
от maskito
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 391
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 12074
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
116 Сообщений
alexandr_ll
59 Сообщений
LexaK
45 Сообщений
alex0402 alex0402
45 Сообщений
DmitriyF DmitriyF
31 Сообщений
BuhRust
27 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений
Stanislav Gareev
19 Сообщений
Funt432286
16 Сообщений
Андрей_gen_D
16 Сообщений

* Кто онлайн

  • Точка Гостей: 228
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal