Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 сен 2021, 18:38

Ошибка при открытии формы

Автор ab30ru, 06 июн 2019, 12:48

0 Пользователей и 1 гость просматривают эту тему.

ab30ru

Здравствуйте. При выполнении операции система пишет Интерактивные функции недоступны. Помогите пожалуйста с проблемой.
&НаСервере
Процедура ОбработатьНаСервере(Идентификатор)
ТекДанные = Объект.СписокДокументов.НайтиПоИдентификатору(Идентификатор);
ТекущийФайл=ТекДанные.Файл;
ТекущийДокумент=ТекДанные.Документ;
Выборка = Справочники.Файлы.Выбрать();
Пока Выборка.Следующий() Цикл

Если Выборка.Наименование = Строка(ТекущийФайл) И Строка(Выборка.СсылкаНаВладельца)=Строка(ТекущийДокумент) Тогда //Ура нашли , но мало ли продолжаем искать )))
КодФайла=Выборка.Код;
КонецЕсли;
КонецЦикла;
Файл=Справочники.Файлы.НайтиПоКоду(КодФайла);
Файл.ПолучитьФорму("ФормаЭлемента").Открыть();
КонецПроцедуры

&НаКлиенте
Процедура ПерейтиКФайлу(Команда)
СтрТЧ=Элементы.СписокДокументов.ТекущиеДанные;
ОбработатьНаСервере(СтрТЧ.ПолучитьИдентификатор());
КонецПроцедуры

LexaK

:D :D

&НаСервере
Процедура ОбработатьНаСервере(Идентификатор)
Сообщить(Файл);
    ...
    Файл.ПолучитьФорму("ФормаЭлемента").Открыть();
КонецПроцедуры

Какое открытие формы на Сервере? Перенесите на Клиента
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск