Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 23:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Не выдает номер ГТД в Счет-фактуре  (Прочитано 13872 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ximec

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. Подскажите пожалуйста в чем причина моей проблемы. При оформлении расходной накладной добавляю товар (иностранного завода изготовителя). В счет-фактуре выдает товар страну и тп но поле ГТД остается пустым. хотя оно должно заполняться как я понимаю на основе выбранного товара. В сведениях о номенклатуре  ГТД выбранного товара прописано. Приходиться каждый раз в счет-фактуре вставлять вручную номер ГТД. Помогите пожалуйста решить проблему :dfbbdrfb:



Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
ГТД  = Справочники.Номенклатура.ГТД;
Это самый простой способ в Вашем случае. Я думаю, что Вы догадаетесь, где это надо дописать?

Оффлайн ximec

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Ученик 1С
в конфигураторе модуль документа Документ.Счет_фактура? Очень хороший вопрос, ибо мои знания в 1С на уровне чайника, хотя дружу с PHP и object pascal.

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Тут примерно так:
В печатной форме ГТД - есть -
МнЧ.НомерГТД  - его родил - РаспредГТД.Номер -
его родил - ТаблицаГТД.ГТД - а эта тз
пополняется если есть по этой
номенклатуре движения
в  регистре РегПартии,
причем  - если в партии - идентифицируется, плюс
в "расход" - учитывается в этом движении -
в общем он нормально в движениях должен актуальным быть
(ну это если совсем просто - на русском)

Оффлайн ximec

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Ученик 1С
О_о честно я не понял. Где находится печатная форма ГТД? Может действительно нужно куда-то воткнуть
ГТД  = Справочники.Номенклатура.ГТД;? На форме "Корректировка остатков по ГТД" когда я выбираю товар - ГТД прописывается само.
А вот на форме счет-фактуры нету( я уже тыркал этот код где "по сути" он мог бы быть, но ничего не изменялось. Подскажите пожалуйста куда именно прописать

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
имеется ввиду печатная форма Счет Фактуры в ней - ГТД - это МнЧ.НомерГТД... дальше по тексту

Оффлайн ximec

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-18
  • Сайт: 
  • Профессия: Ученик 1С
Тут либо я дурак либо там что-то нахимичено(((
Просто приходил человек (якобы программист 1С), что-то там начудил(вроде как обновил), а ГТД настроить не смог.
Вот код формы Счет-фактуры:

   Таб.ВывестиСекцию("Шапка");
   ВыбратьСтроки();
   Ном=0;
   ИтогСумма=0;
   ПовторТовара = ПолучитьПустоеЗначение("Справочник.Номенклатура");
   ВывелиСтроку = Нет;
   Пока ПолучитьСтроку() = 1 Цикл
      Ном=Ном+1;
      Если Товар.Выбран()=0 Тогда
         Продолжить;
      КонецЕсли;
      Ном=Ном+1;
      Если (ПовторТовара = Товар) И ((Цена+Сумма+НДС)=0) Тогда
         // если товар тот же, то идет разбивка товара в разрезе ГТД
         ПечЦена=" ----- ";
         ПечСумма=" ----- ";
         ПечСтавкаНДС=" -- ";
         ПечСуммаНДС=" -- ";
         ПечСуммаНП=" -- ";
         ПечВсегоСНДС=" ----- ";
         //СтранаН=" ----- ";
         Если ВывелиСтроку = Нет Тогда
            // Еще не напечатали строку "в том числе", то печатаем ее
            ВывелиСтроку = Да;
             ПечТовар="      в том числе:";
            СтранаН=" ----- ";
            НомерГТД_Н=" ----- ";
            ПечЕдиниц=" ----- ";
            ПечКолич=" ----- ";
            ПечАкцизЦена=" -- ";
            ПечАкцизСумма=" -- ";
      
            Таб.ВывестиСекцию("Строка");
         КонецЕсли;
         // Если несколько строк с одним товаром, то в повторяющихся строках выводим
         // только количество и номер ГТД
         НомерГТД=ГТД;
      Иначе
         // Новый товар
         ВывелиСтроку = Нет;
         
         Если (ДатаДок>Дата("31.12.2000")) и (Товар=Константа.АвансовыйПлатеж) Тогда
            // СФ на авансовые платежи печатаем с указанием суммы с НДС (базы налога)
            // в графе "Стоимость без налога"
            ПечСумма=глФРМ(Сумма,Рубли,0);                               
            ИтогСумма=ИтогСумма+Сумма;
            ПечЦена   =глФРМ(Цена,Рубли,0);
            ПроцентНДС=глПроцентНДС(СтавкаНДС);
            ПечПроцентНДС=Окр(ПроцентНДС/(100+ПроцентНДС)*100,2,1);
            ПечСтавкаНДС=?(СтавкаНДС=Перечисление.ЗначенияНДС.безНДС," -- ",""+ПечПроцентНДС+"%");
         Иначе
            ПечСумма=глФРМ(Сумма-НДС,Рубли,0);
            ИтогСумма=ИтогСумма+Сумма-НДС;
            ПечЦена   =?(Количество=0,0,глФРМ(Цена-НДС/Количество,Рубли,0));
            ПечСтавкаНДС=?(СтавкаНДС=Перечисление.ЗначенияНДС.безНДС," -- ",Строка(СтавкаНДС));
         КонецЕсли;
         
         ПечСуммаНДС=?(СтавкаНДС=Перечисление.ЗначенияНДС.безНДС," -- ",глФРМ(НДС,Рубли,0));
         ПечВсегоСНДС=глФРМ(Сумма,Рубли,0);                                                 
         ПечСуммаНП=глФРМ(СуммаНП,Рубли,0);                                                 
      КонецЕсли;           
      ПечТовар=СокрП(Товар.ПолнНаименование);
      ПечЕдиниц=Единица.ТипЕдиницы;
      ПечКолич=Формат(Количество, ФорматКоличества);
      
      ПечАкцизЦена=" -- ";
      ПечАкцизСумма=" -- ";
      
      Если ПустаяСтрока(СтранаПроисхождения)=1 Тогда
         Если ДатаДок<=Дата("31.12.2000") Тогда
            СтранаН="Россия";
         Иначе
            СтранаН="";
         КонецЕсли;
         
         
         //Если не указал страну, и указал Номер ГТД, то зачем-то это было нужно
         Если ПустаяСтрока(ГТД)=1 Тогда       
            Если ДатаДок<=Дата("31.12.2000") Тогда
               НомерГТД=" ----- ";
            Иначе     
               НомерГТД = Товар.ГТД
            КонецЕсли;
         Иначе
            ;
         КонецЕсли;
      Иначе
         СтранаН=СтранаПроисхождения;
         
         // Если номер пустой, и указана страна, то позволяем потом вписать номер ГТД
         // в напечатанном документе руками
         ГТД  = Номенклатура.ГТД;
      КонецЕсли;
      Таб.ВывестиСекцию("Строка");
      // Запоминаем текущий товар
      ПовторТовара = Товар;
   КонецЦикла;

   ПечИтогСумма=глФРМ(ИтогСумма,Рубли,0);
   ПечИтогАкцизСумма=" -- ";
   ПечИтогСуммаНДС=глФРМ(Итог("НДС"),Рубли,0);
   ПечИтогВсегоСНДС=глФРМ(Итог("Сумма"),Рубли,0);
   ПечИтогСуммаНП=глФРМ(Итог("СуммаНП"),Рубли,0);

   Если УчитыватьНП=1 Тогда
      ПечВсегоНП=?(Итог("СуммаНП")=0,"","Сумма налога с продаж:            "+глФРМ(Итог("СуммаНП"),Рубли,0));
   Иначе
      ПечВсегоНП="";
   КонецЕсли;

Дальше пошла подвальная часть....

Что тут может быть не так? пожалуйста подскажите


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Автоподбор ГТД

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 190
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal