Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 сен 2021, 14:22

Макет печати

Автор ab30ru, 04 июн 2019, 15:36

0 Пользователей и 1 гость просматривают эту тему.

ab30ru

Здравствуйте. Я создал макет печати формы.
Процедура Печать(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
Макет = Документы.ЗаписьНаКурс.ПолучитьМакет("ПечатьВедомости");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаписьНаКурс.БесплатноеОбучение КАК БесплатноеОбучение,
| ЗаписьНаКурс.ПродолжительностьКурса КАК ПродолжительностьКурса,
| ЗаписьНаКурс.СлушателиКурса.(
| НомерСтроки КАК НомерСтроки,
| ФиоСлушателя КАК ФиоСлушателя,
| Удостоверение КАК Удостоверение,
| ПоименныйНомер КАК ПоименныйНомер
| ) КАК СлушателиКурса,
| ЗаписьНаКурс.ПриказОЗачислении КАК ПриказОЗачислении
|ИЗ
| Документ.ЗаписьНаКурс КАК ЗаписьНаКурс
|ГДЕ
| ЗаписьНаКурс.Ссылка В(&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьСлушателиКурсаШапка = Макет.ПолучитьОбласть("СлушателиКурсаШапка");
ОбластьСлушателиКурса = Макет.ПолучитьОбласть("СлушателиКурса");
Подвал = Макет.ПолучитьОбласть("Подвал");

ТабДок.Очистить();

ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;


ТабДок.Вывести(ОбластьСлушателиКурсаШапка);
ВыборкаСлушателиКурса = Выборка.СлушателиКурса.Выбрать();
Пока ВыборкаСлушателиКурса.Следующий() Цикл
ОбластьСлушателиКурса.Параметры.Заполнить(ВыборкаСлушателиКурса);
ТабДок.Вывести(ОбластьСлушателиКурса, ВыборкаСлушателиКурса.Уровень());
КонецЦикла;

Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры

Подскажите пожалуйста, как сделать так? чтобы строка
ЗаписьНаКурс.ПриказОЗачислении КАК ПриказОЗачислении
также выводилась в цикле в таблице КАК СлушателиКурса

alex0402

Цитата: ab30ru от 04 июн 2019, 15:36ОбластьСлушателиКурса.Параметры.Заполнить(ВыборкаСлушателиКурса)

Добавить строку:

ОбластьСлушателиКурса.Параметры.ИмяПараметра = ВыборкаСлушателиКурса.ПриказОЗачислении;
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск