Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 10:25

Не выводятся параметры в макете

Автор Yamuna, 17 мая 2019, 07:30

0 Пользователей и 1 гость просматривают эту тему.

Yamuna

Добрый день! выходит ошибка при выводе параметров в макете модуля формы , параметры получаем из реквизитов в шапке справочника
Процедура ДействияФормыПечатьСправочника(Кнопка)
ТабДок = Новый ТабличныйДокумент;
Макет = Справочники.Контрагенты.ПолучитьМакет("МакетСписка");

Макет.Параметры.Сотрудник = Ссылка;
Макет.Параметры.ДатаРегистрации = ДатаРегистрации;

ТабДок.Вывести(Макет);

    ТабДок.Показать("Список контрагентов");
КонецПроцедуры


{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(7,36)}: Переменная не определена (ДатаРегистрации)
   Макет.Параметры.ДатаРегистрации = <<?>>ДатаРегистрации; (Проверка: Толстый клиент (обычное приложение))
подскажите в чем ошибка

alexandr_ll

Цитата: Yamuna от 17 мая 2019, 07:30
Добрый день! выходит ошибка при выводе параметров в макете модуля формы , параметры получаем из реквизитов в шапке справочника
Процедура ДействияФормыПечатьСправочника(Кнопка)
ТабДок = Новый ТабличныйДокумент;
Макет = Справочники.Контрагенты.ПолучитьМакет("МакетСписка");

Макет.Параметры.Сотрудник = Ссылка;
Макет.Параметры.ДатаРегистрации = ДатаРегистрации;

ТабДок.Вывести(Макет);

    ТабДок.Показать("Список контрагентов");
КонецПроцедуры


{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(7,36)}: Переменная не определена (ДатаРегистрации)
   Макет.Параметры.ДатаРегистрации = <<?>>ДатаРегистрации; (Проверка: Толстый клиент (обычное приложение))
подскажите в чем ошибка
Возможно
Макет.Параметры.ДатаРегистрации = Ссылка.ДатаРегистрации;

Yamuna

Цитата: alexandr_ll от 17 мая 2019, 07:52
Цитата: Yamuna от 17 мая 2019, 07:30
Добрый день! выходит ошибка при выводе параметров в макете модуля формы , параметры получаем из реквизитов в шапке справочника
Процедура ДействияФормыПечатьСправочника(Кнопка)
ТабДок = Новый ТабличныйДокумент;
Макет = Справочники.Контрагенты.ПолучитьМакет("МакетСписка");

Макет.Параметры.Сотрудник = Ссылка;
Макет.Параметры.ДатаРегистрации = ДатаРегистрации;

ТабДок.Вывести(Макет);

    ТабДок.Показать("Список контрагентов");
КонецПроцедуры


{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(7,36)}: Переменная не определена (ДатаРегистрации)
   Макет.Параметры.ДатаРегистрации = <<?>>ДатаРегистрации; (Проверка: Толстый клиент (обычное приложение))
подскажите в чем ошибка
Возможно
Макет.Параметры.ДатаРегистрации = Ссылка.ДатаРегистрации;

да нет похоже, на ссылку тоже ругается
{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(6,30)}: Переменная не определена (Ссылка)
   Макет.Параметры.Сотрудник = <<?>>Ссылка; (Проверка: Толстый клиент (обычное приложение))
{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(7,36)}: Переменная не определена (ДатаРегистрации)
   Макет.Параметры.ДатаРегистрации = <<?>>ДатаРегистрации; (Проверка: Толстый клиент (обычное приложение))
как правильно обратиться с модуля формы списка к реквизитам Справочника?

alexandr_ll

Цитата: Yamuna от 17 мая 2019, 10:28
Цитата: alexandr_ll от 17 мая 2019, 07:52
Цитата: Yamuna от 17 мая 2019, 07:30
Добрый день! выходит ошибка при выводе параметров в макете модуля формы , параметры получаем из реквизитов в шапке справочника
Процедура ДействияФормыПечатьСправочника(Кнопка)
ТабДок = Новый ТабличныйДокумент;
Макет = Справочники.Контрагенты.ПолучитьМакет("МакетСписка");

Макет.Параметры.Сотрудник = Ссылка;
Макет.Параметры.ДатаРегистрации = ДатаРегистрации;

ТабДок.Вывести(Макет);

    ТабДок.Показать("Список контрагентов");
КонецПроцедуры


{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(7,36)}: Переменная не определена (ДатаРегистрации)
   Макет.Параметры.ДатаРегистрации = <<?>>ДатаРегистрации; (Проверка: Толстый клиент (обычное приложение))
подскажите в чем ошибка
Возможно
Макет.Параметры.ДатаРегистрации = Ссылка.ДатаРегистрации;

да нет похоже, на ссылку тоже ругается
{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(6,30)}: Переменная не определена (Ссылка)
   Макет.Параметры.Сотрудник = <<?>>Ссылка; (Проверка: Толстый клиент (обычное приложение))
{Справочник.Контрагенты.Форма.ФормаСпискаОбычная.Форма(7,36)}: Переменная не определена (ДатаРегистрации)
   Макет.Параметры.ДатаРегистрации = <<?>>ДатаРегистрации; (Проверка: Толстый клиент (обычное приложение))
как правильно обратиться с модуля формы списка к реквизитам Справочника?
Выборка = Справочники.Контрагенты.Выбрать();
Пока выборка.Следующий() = 1 Цикл
Макет.Параметры.ДатаРегистрации = Выборка.ДатаРегистрации;
Макет.Параметры.Сотрудник= Выборка.Наименование;


КонецЦикла;


Yamuna

Выборка = Справочники.Контрагенты.Выбрать();
Пока выборка.Следующий() = 1 Цикл
Макет.Параметры.ДатаРегистрации = Выборка.ДатаРегистрации;
Макет.Параметры.Сотрудник= Выборка.Наименование;


КонецЦикла;


Да все получилось)) Спасибо! но выводит только одного последнего сотрудника, а можете еще подсказать как вывести весь список справочника Контрагетов в иерархией элементов?

alexandr_ll

Цитата: Yamuna от 17 мая 2019, 11:21
Выборка = Справочники.Контрагенты.Выбрать();
Пока выборка.Следующий() = 1 Цикл
Макет.Параметры.ДатаРегистрации = Выборка.ДатаРегистрации;
Макет.Параметры.Сотрудник= Выборка.Наименование;


КонецЦикла;


Да все получилось)) Спасибо! но выводит только одного последнего сотрудника, а можете еще подсказать как вывести весь список справочника Контрагетов в иерархией элементов?
Макет нужно разбить на поименованные области, Например, "Шапка" и "Строка".
Шапку вывести перед циклом, а строку выводить в цикле.
Типа того
Секция = Макет.ПолучитьОбласть("Шапка");
Секция.Параметры.Организация=Склад ;
Секция.Параметры.ВидНоменклатуры=ВидНоменклатуры ;

ТабДок.Вывести(Секция);


Yamuna

Цитата: alexandr_ll от 17 мая 2019, 12:00
Цитата: Yamuna от 17 мая 2019, 11:21
Выборка = Справочники.Контрагенты.Выбрать();
Пока выборка.Следующий() = 1 Цикл
Макет.Параметры.ДатаРегистрации = Выборка.ДатаРегистрации;
Макет.Параметры.Сотрудник= Выборка.Наименование;


КонецЦикла;


Да все получилось)) Спасибо! но выводит только одного последнего сотрудника, а можете еще подсказать как вывести весь список справочника Контрагетов в иерархией элементов?
Макет нужно разбить на поименованные области, Например, "Шапка" и "Строка".
Шапку вывести перед циклом, а строку выводить в цикле.
Типа того
Секция = Макет.ПолучитьОбласть("Шапка");
Секция.Параметры.Организация=Склад ;
Секция.Параметры.ВидНоменклатуры=ВидНоменклатуры ;

ТабДок.Вывести(Секция);


ага я вот сделал
Процедура ДействияФормыПечатьСправочника(Кнопка)
ТабДок = Новый ТабличныйДокумент;
Макет = Справочники.Контрагенты.ПолучитьМакет("МакетСписка");

Область=Макет.ПолучитьОбласть("Заголовок");
ТабДок.Вывести(Область); 

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Контрагенты.Ссылка КАК Ссылка,
| Контрагенты.Родитель КАК Родитель,
| Контрагенты.Код КАК Код,
| Контрагенты.Наименование КАК Наименование,
| Контрагенты.НомерКарты КАК НомерКарты,
| Контрагенты.Телефон КАК Телефон,
| Контрагенты.ДатаРегистрации КАК ДатаРегистрации
|ИЗ
| Справочник.Контрагенты КАК Контрагенты";

РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
Элемент = Макет.ПолучитьОбласть("Элемент");
Пока Выборка.Следующий() Цикл
Элемент.Параметры.Заполнить(Выборка);

ТабДок.Вывести(Элемент);
КонецЦикла;
ТабДок.Показать("Список контрагентов");
КонецПроцедуры

но у меня все вывелось без иерархии, просто каждая сточка отдельно

Теги: Параметры 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск