Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июл 2019, 01:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Разница в получении файла ЗУП 2.5 и ЗУП 3.1  (Прочитано 144 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн skillful

  • **
  • Сообщений: 55
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2010-05-07
  • Сайт: 
В ЗУП 2.5 есть код который копирует вордовский файл из Справочник.ХранилищеДополнительнойИнформации во временнй каталог с именем 1.doc

Функция МакетПолучить(Отказ = Ложь)

ПутьВремКат = "";

ЗапросФайл = Новый Запрос;
ЗапросФайл.Текст = "ВЫБРАТЬ
| ХранилищеДополнительнойИнформации.Ссылка,
| ХранилищеДополнительнойИнформации.Хранилище
|ИЗ
| Справочник.ХранилищеДополнительнойИнформации КАК ХранилищеДополнительнойИнформации
|ГДЕ
| ХранилищеДополнительнойИнформации.Наименование = &Наименование";



ЗапросФайл.УстановитьПараметр("Наименование", "СпрСотрудникиТрудДоговор");



Выборка = ЗапросФайл.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
Файл = Выборка.Хранилище.Получить();
КонецЕсли;

Попытка
Если ЗначениеЗаполнено(Файл) Тогда
ПутьВремКат = ПолучитьИмяВременногоФайла("1.doc");
КонецЕсли;
Файл.Записать(ПутьВремКат);
Исключение
Сообщить("Макет не найден. Проверьте имеется ли в справочнике ""Дополнительная информация"" файл с наименованием ""СпрСотрудникиТрудДоговор.doc"" и описанием ""СпрСотрудникиТрудДоговор""");
КонецПопытки;

Возврат ПутьВремКат;

КонецФункции

Сейчас переходим на ЗУП 3.1. В ней вообще нет справочника "ХранилищеДополнительнойИнформации", но есть справочник "Файлы". Если загрузить файл в этот справочник, то видимо запрос будет таким

ЗапросФайл.Текст = "ВЫБРАТЬ
| Файлы.Ссылка,
| Файлы.ФайлХранилище
| ИЗ
| Справочник.Файлы КАК Файлы
|ГДЕ
| Файлы.Наименование = &Наименование";


ЗапросФайл.УстановитьПараметр("Наименование", Строка("СпрСотрудникиТрудДоговор"));

Выборка = ЗапросФайл.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
Файл = Выборка.ФайлХранилище.Получить();
КонецЕсли;


Но файл таким образом не находит, хотя в запроснике есть данная строка, но не срабатывает
Попытка
Если ЗначениеЗаполнено(Файл) Тогда
ПутьВремКат = ПолучитьИмяВременногоФайла("1.doc");
КонецЕсли;
Файл.Записать(ПутьВремКат);
Исключение
Сообщить("Макет не найден. Проверьте имеется ли в справочнике ""Дополнительная информация"" файл с наименованием ""СпрСотрудникиТрудДоговор.doc"" и описанием ""СпрСотрудникиТрудДоговор""");
КонецПопытки;


Оффлайн skillful

  • **
  • Сообщений: 55
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2010-05-07
  • Сайт: 
Или напишу проще. Как из справочника Файлы скопировать файл в компьютер.

ЗапросФайл.Текст = "ВЫБРАТЬ
    |    Файлы.Ссылка,
    |    Файлы.ФайлХранилище
    |        ИЗ
    |    Справочник.Файлы КАК Файлы
    |ГДЕ
    |    Файлы.Наименование = &Наименование";
   
   
    ЗапросФайл.УстановитьПараметр("Наименование", Строка("СпрСотрудникиТрудДоговор"));
   
    Выборка = ЗапросФайл.Выполнить().Выбрать();
   
    Если Выборка.Следующий() Тогда
        //Файл = Выборка.ФайлХранилище.Получить();   
    КонецЕсли;




Добавлено: 17 Май 2019, 18:45

Если Выборка.Следующий() Тогда
        ДанныеФайлаИДвоичныеДанные = РаботаСФайламиСлужебныйВызовСервера.ДанныеФайлаИДвоичныеДанные(Выборка.Ссылка);   
КонецЕсли;

Так сделал

Последний раз редактировалось: skillful; 17 Май 2019, 18:45. Причина: Объединение сообщений


Теги:
 

Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 12969
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
при чтении из .xls файла в 1с предприятие 8.3 не удаётся выполнить заполнение формы из столбца со странами происхождения Соединенные Штаты, Япония, тогда как Тайвань заполняется правильно. Как исправить заполнение формы?

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 356
Последний ответ 11 Янв 2019, 15:20
от Etherial
Ошибка КД "Файла не существует"

Автор arkanruРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 31 Авг 2015, 11:19
от arkanru
Cоздание Excel afqkf по оформлению из другого файла Excel

Автор bugsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3573
Последний ответ 23 Авг 2011, 14:26
от bugs
Задание типа файла при сохранении таб.документа "Сохранить копию" во внешний фа

Автор Marta_LiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5776
Последний ответ 22 Дек 2011, 15:34
от sergeevds

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
66 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
60 Сообщений
LexaK
23 Сообщений
DmitriyF DmitriyF
17 Сообщений
wise wise
15 Сообщений
Александр Мун Александр Мун
14 Сообщений
alex0402 alex0402
11 Сообщений
Мария112689
11 Сообщений
BuhRust
10 Сообщений
alexandr_ll
8 Сообщений

* Кто онлайн

  • Точка Гостей: 203
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal