Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июл 2019, 01:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Контроль табличной части при проведении  (Прочитано 310 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн jyurik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
Нужно запретить проведение документа, если в наименовании номенклатуры есть нижнее подчеркивание в начале или в конце.
Может, у кого есть пример кода?


Оффлайн wise

  • *****
  • Сообщений: 899
  • РЕПУТАЦИЯ: 131
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) МОЖЕТ при подборе ЛУЧШЕ контролировать.??
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн jyurik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
(0) МОЖЕТ при подборе ЛУЧШЕ контролировать.??

Можно и при подборе

Оффлайн wise

  • *****
  • Сообщений: 899
  • РЕПУТАЦИЯ: 131
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(2)
Если СтрНачинаетсяС(Номенклатура.Наименование, "_") ИЛИ СтрЗаканчиваетсяНа(Номенклатура.Наименование, "_") Тогда 
    Сообщить(Номенклатура.Наименование+"запрещена к продаже.!");
КонецЕсли;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн jyurik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
(2)
Если СтрНачинаетсяС(Номенклатура.Наименование, "_") ИЛИ СтрЗаканчиваетсяНа(Номенклатура.Наименование, "_") Тогда 
    Сообщить(Номенклатура.Наименование+"запрещена к продаже.!");
КонецЕсли;
Спасибо большое. Буду пробовать
Добавлено: 06 Май 2019, 12:19

(2)
Если СтрНачинаетсяС(Номенклатура.Наименование, "_") ИЛИ СтрЗаканчиваетсяНа(Номенклатура.Наименование, "_") Тогда 
    Сообщить(Номенклатура.Наименование+"запрещена к продаже.!");
КонецЕсли;
С наименованием все отлично. Спасибо
А вот при таком условии сообщения нет:

      Если СтрНачинаетсяС(СтрокаТаблицы.Номенклатура.Код, "_") ИЛИ СтрокаЗаканчиваетсяНа(СтрокаТаблицы.Номенклатура.Код, "_") Тогда
         Сообщить(СтрокаТаблицы.Номенклатура+"запрещена к продаже.!");
      КонецЕсли;

Последний раз редактировалось: jyurik; 06 Май 2019, 12:19. Причина: Объединение сообщений

Оффлайн wise

  • *****
  • Сообщений: 899
  • РЕПУТАЦИЯ: 131
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(4) :o
"СтрокаТаблицы.Номенклатура.Код" это НЕ наименование.!! :P
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн jyurik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
(4) :o
"СтрокаТаблицы.Номенклатура.Код" это НЕ наименование.!! :P
а как тогда быть с кодом номенклатуры?
Добавлено: 06 Май 2019, 13:08

Оказалось, что есть коды номенклатуры, у которой, то же есть подчеркивание в начале и конце кода

Оффлайн wise

  • *****
  • Сообщений: 899
  • РЕПУТАЦИЯ: 131
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(6) сначала НАДО:
ТекКод = СокрЛП(СтрокаТаблицы.Номенклатура.Код);

а потом

Если СтрНачинаетсяС(ТекКод, "_") ИЛИ СтрокаЗаканчиваетсяНа(ТекКод, "_") Тогда
         Сообщить(СтрокаТаблицы.Номенклатура+"запрещена к продаже.!");
КонецЕсли;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн jyurik

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-07
  • Сайт: 
  • Профессия: Программист 1С
(6) сначала НАДО:
ТекКод = СокрЛП(СтрокаТаблицы.Номенклатура.Код);

а потом

Если СтрНачинаетсяС(ТекКод, "_") ИЛИ СтрокаЗаканчиваетсяНа(ТекКод, "_") Тогда
         Сообщить(СтрокаТаблицы.Номенклатура+"запрещена к продаже.!");
КонецЕсли;

Огромное спасибо Вам, очень помогли
Не догадался, что надо было так перевести код в наименование


Теги:
 

Ошибка "Поле объекта не обнаружено" при записи табл.части документа "ОперацияБух"

Автор Q37Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 814
Последний ответ 18 Авг 2018, 20:18
от Q37
"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2822
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3718
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3826
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 928
Последний ответ 23 Июн 2015, 14:25
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
66 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
60 Сообщений
LexaK
23 Сообщений
DmitriyF DmitriyF
17 Сообщений
wise wise
15 Сообщений
Александр Мун Александр Мун
14 Сообщений
alex0402 alex0402
11 Сообщений
Мария112689
11 Сообщений
BuhRust
10 Сообщений
alexandr_ll
8 Сообщений

* Кто онлайн

  • Точка Гостей: 229
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal