Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Отчет ничего не выводит...  (Прочитано 1782 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Доброго дня всем!
Подскажите, в чем загвоздка в коде - формирует шапку таблицы, но не заполняет ничего.....

Процедура ДействияФормыОтчетСформировать(Кнопка)
ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;
Отчет(ТабДок, ВыбДата,ВыбСклад, ВыбТипЦен);
КонецПроцедуры

функция РознЦена(Номенклатура,ВыбДата,ВыбТипЦен)
Отбор = Новый Структура("Номенклатура,ТипЦен",Номенклатура,ВыбТипЦен);
ЗначенияРесурсов = РегистрыСведений.ЦеныНоменклатуры.ПолучитьПоследнее(ВыбДата,Отбор);
Возврат  ЗначенияРесурсов.Цена;

КонецФункции

Процедура Отчет(ТабДок, ВыбДата,ВыбСклад, ВыбТипЦен) Экспорт

Макет = ВнешнийОтчетОбъект.ПолучитьМакет("Отчет");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатурыСрезПоследних.Номенклатура.Код КАК Код,
| ХозрасчетныйОстатки.Счет,
| ЦеныНоменклатурыСрезПоследних.Номенклатура КАК Номенклатура,
| ЦеныНоменклатурыСрезПоследних.Номенклатура.БазоваяЕдиницаИзмерения КАК ЕдИзм,
| ЦеныНоменклатурыСрезПоследних.Цена КАК Цена,
| ХозрасчетныйОстатки.КоличествоОстаток КАК КоличествоОстаток,
| ХозрасчетныйОстатки.СуммаОстаток КАК Сумма
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(&ВыбДата, Счет = &ВыбСчет, , ) КАК ХозрасчетныйОстатки
| ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&ВыбДата, ) КАК ЦеныНоменклатурыСрезПоследних
| ПО ХозрасчетныйОстатки.Субконто1 = ЦеныНоменклатурыСрезПоследних.Номенклатура
|ГДЕ
| ХозрасчетныйОстатки.Субконто1 = &ВыбСклад
| И ХозрасчетныйОстатки.Счет = &ВыбСчет
| И ЦеныНоменклатурыСрезПоследних.ТипЦен = &ВыбТипЦен
|
|УПОРЯДОЧИТЬ ПО
| Номенклатура
|ИТОГИ
| СУММА(КоличествоОстаток),
| СУММА(Сумма)
|ПО
| Номенклатура ИЕРАРХИЯ";
Запрос.УстановитьПараметр("ВыбСклад", ВыбСклад);
Запрос.УстановитьПараметр("ВыбСчет", ПланыСчетов.Хозрасчетный.ТоварыНаСкладах);
Запрос.УстановитьПараметр("ВыбТипЦен", ВыбТипЦен);
    Запрос.УстановитьПараметр("ВыбДата", КонецДня(ВыбДата));

Результат = Запрос.Выполнить();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
ОбластьНоменклатураИерархия = Макет.ПолучитьОбласть("НоменклатураИерархия");
ОбластьНоменклатура = Макет.ПолучитьОбласть("Номенклатура");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ОбластьЗаголовок.Параметры.ВыбДата = Формат(ВыбДата,"ДФ='дд ММММ гггг'") + " г.";
ТабДок.Вывести(ОбластьЗаголовок);
ТабДок.Вывести(ОбластьШапкаТаблицы);
ТабДок.НачатьАвтогруппировкуСтрок();

ВыборкаНоменклатура = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

Пока ВыборкаНоменклатура.Следующий() Цикл
Если ВыборкаНоменклатура.ТипЗаписи() = ТипЗаписиЗапроса.ИтогПоИерархии Тогда
Область = ОбластьНоменклатураИерархия;
Область.Параметры.Заполнить(ВыборкаНоменклатура);
ТабДок.Вывести(Область);
Иначе
Область = ОбластьНоменклатура;
КонецЕсли;

Если ВыборкаНоменклатура.Номенклатура.ЭтоГруппа = Ложь Тогда
Цена = РознЦена(ВыборкаНоменклатура.Номенклатура,ВыбТипЦен,);
КонецЕсли;


ТабДок.Вывести(Область, ВыборкаНоменклатура.Уровень());


ВыборкаДетальныеЗаписи = ВыборкаНоменклатура.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетальныеЗаписи);
ОбластьДетальныхЗаписей.Параметры.Номенклатура = СокрЛП(ВыборкаДетальныеЗаписи.Номенклатура.НаименованиеПолное);
ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетальныеЗаписи.Уровень());
ТабДок.Вывести(ОбластьДетальныхЗаписей);
КонецЦикла;
КонецЦикла;

ТабДок.ЗакончитьАвтогруппировкуСтрок();
ТабДок.Вывести(ОбластьПодвалТаблицы);
ТабДок.Вывести(ОбластьПодвал);

//}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ
КонецПроцедуры


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Ну, первым делом ставим точку останова и проверяем, вернул ли нам запрос хоть какие-то данные
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Спасибо, все готово.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Хаха, всегда бы так вопросы решались ;)
Впрочем, тогда не нужен был бы форум.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 270
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal