Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Июн 2019, 15:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: сравнение значений в строках после отбора  (Прочитано 209 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ЕвгенийЗерно

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-06-08
  • Сайт: 
  • Профессия: Программист 1С
Добрый день! Подскажите, можно ли после того как заполнил ТЗ и сделал свертку и отбор, сравнить полученные строки между собой по значению(определенному столбцу) и записать цифру в переменную по количеству равную одинаковым значениям в этих строках?

Код отбора после свертки:
Таб.ВыбратьСтроки();
   Пока Таб.ПолучитьСтроку()=1 Цикл 
      
      Если ПустоеЗначение(Водитель)=0 Тогда
          Если Таб.ФИО<>Водитель Тогда
              Продолжить;
         КонецЕсли;
   
      КонецЕсли;
      Если ПустоеЗначение(Марка)=0 Тогда
          Если Таб.Марка<>Марка Тогда
              Продолжить;
          КонецЕсли;
      КонецЕсли;
сравнить как то строки
      Если  Таб.ДатаРаботы=Таб.ДатаРаботы тогда   //сравнивать по этому значению строки
            Коллл=Коллл+1;
         КонецЕсли;
   КонецЦикла;

Но у меня не работает этот код, подскажите правильное решение?


Оффлайн wise

  • *****
  • Сообщений: 884
  • РЕПУТАЦИЯ: 130
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) добавьте в ТЗ колонку "КолВоСтрок" с цифрой 1
а потом сверните ТЗ по "ДатаРаботы" и суммируйте КолВоСтрок
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
62 Сообщений
Yamuna
46 Сообщений
LexaK
42 Сообщений
MuI_I_Ika MuI_I_Ika
28 Сообщений
AIFrame AIFrame
18 Сообщений
wise wise
16 Сообщений
alex0402 alex0402
15 Сообщений
lmlg114@bk.ru
13 Сообщений
alexandr_ll
12 Сообщений
ab30ru
11 Сообщений

* Кто онлайн

  • Точка Гостей: 502
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal