Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Июл 2019, 09:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Окошко поиска  (Прочитано 245 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Мася Осипова

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-04-15
  • Сайт: 
Добрый вечер. Нужно реализовать окошко поиска для динамического списка, подскажите, как это реализовать на форме элемента в документе?


Оффлайн alex0402

  • *****
  • Сообщений: 1872
  • РЕПУТАЦИЯ: 337
  • КПД: 18%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Re: Окошко поиска
« Ответ #1: 16 Апр 2019, 09:54 »
Добрый вечер. Нужно реализовать окошко поиска для динамического списка, подскажите, как это реализовать на форме элемента в документе?
добавить реквизит формы соответствующего типа, в событии при изменении прописать изменение отбора динамического списка.
Спасибо за Сказать спасибо

Оффлайн Мася Осипова

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-04-15
  • Сайт: 
Re: Окошко поиска
« Ответ #2: 19 Июн 2019, 07:32 »
&НаСервереБезКонтекста
Функция СписокНоменклатурыКоличествоПриИзмененииНаСервере(Номенклатура)
      //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ОстаткиНоменклатурыОстатки.КоличествоОстаток КАК КоличествоОстаток
      |ИЗ
      |   РегистрНакопления.ОстаткиНоменклатуры.Остатки КАК ОстаткиНоменклатурыОстатки
      |ГДЕ
      |   ОстаткиНоменклатурыОстатки.Номенклатура = &Номенклатура";
   
   Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Остаток=ВыборкаДетальныеЗаписи.КоличествоОстаток;
   КонецЦикла;
   
   Возврат Остаток;
   
   //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА

   
КонецФункции

&НаКлиенте
Процедура СписокНоменклатурыКоличествоПриИзменении(Элемент)
   //Записали в переменную СТР (Тип структура, массив) содержимое строки таблицы
   Стр=Элементы.СписокНоменклатуры.ТекущиеДанные;
   Остаток=СписокНоменклатурыКоличествоПриИзмененииНаСервере(Стр.Номенклатура);
   Если Стр.Количество>Остаток Тогда
      ПоказатьОповещениеПользователя("Нельзя продать больше, чем есть на складе");
      КонтрольОстатков=Ложь;
   Иначе
      КонтрольОстатков=Истина;
   КонецЕсли;
   
КонецПроцедуры

Оффлайн AIFrame

  • *****
  • Сообщений: 1391
  • РЕПУТАЦИЯ: 179
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
Re: Окошко поиска
« Ответ #3: 20 Июн 2019, 06:55 »
Добрый вечер. Нужно реализовать окошко поиска для динамического списка, подскажите, как это реализовать на форме элемента в документе?
А почему не добавить для командной панели этого списка на форме стандартное поле поиска?


Теги:
 

Что лучше использовать для поиска связи между документами записи в регистре или критерии отбора

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1583
Последний ответ 05 Сен 2016, 11:26
от ilyay
Поправить обработку - вместо поиска по коду поиск по модели

Автор xavikzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 771
Последний ответ 09 Сен 2015, 14:06
от vitasw
Обработка поиска с заданным значением по справочнику

Автор Tgr11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 6237
Последний ответ 27 Июн 2013, 14:36
от Dethmontt
Не работают поля поиска в конвертации данных 2

Автор demon3Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 1675
Последний ответ 23 Авг 2017, 10:44
от oleg-x
Возможно ли изменить параметры поиска

Автор Nail2010Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1969
Последний ответ 20 Июл 2011, 07:20
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

MuI_I_Ika MuI_I_Ika
78 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
59 Сообщений
LexaK
28 Сообщений
Александр Мун Александр Мун
17 Сообщений
DmitriyF DmitriyF
17 Сообщений
alexandr_ll
16 Сообщений
wise wise
15 Сообщений
BuhRust
15 Сообщений
antoneus antoneus
8 Сообщений
MaxPoi
8 Сообщений

* Кто онлайн

  • Точка Гостей: 638
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal