Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
01 Дек 2020, 09:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Элемент формы СписокЗначений с типом СписокЗначений  (Прочитано 1241 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Людмила Киреенкова

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-03-20
  • Сайт: 
Доброе утро!
1С:Предприятие 8.3 (8.3.12.1790).
На форме создаю реквизит Договор. Тип реквизита - СписокЗначений.
ТипЗначения - также СписокЗначений. См.вложение Реквизит.png.
Как программно добраться ко второму списку, чтобы заполнить его элементами?
Спасибо!


Онлайн antoneus

  • ****
  • Сообщений: 397
  • РЕПУТАЦИЯ: 105
  • КПД: 26%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
Изврат какой-то) Тогда уж дерево значений лучше. А вообще как-то так

Для каждого ТекДоговор из Договор Цикл
    Для каждого Элемент из ТекДоговор.Значение Цикл
        Сообщить(Элемент.Значение)
    КонецЦикла;
КонецЦикла;

А заполнить еще проще:

СЗ = Новый СписокЗначений;
СЗ.Добавить("123");
Договор.Добавить(СЗ);

Последний раз редактировалось: antoneus; 20 Мар 2019, 10:17

Оффлайн AIFrame

  • *****
  • Сообщений: 1395
  • РЕПУТАЦИЯ: 184
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
	Список2 = Новый СписокЗначений;
Список2.Добавить("А");
Список2.Добавить("Б");
Список2.Добавить("В");

Договор.Добавить(Список2);
Сообщить(Договор[0].Значение.Количество());
Для Каждого ЗначениеСписка ИЗ  Договор[0].Значение Цикл
Сообщить(ЗначениеСписка.Значение);
КонецЦикла;


 

Для объекта конфигурации есть возможность выбирать способ редактирования ("в диалоге", "в списке", "обоими способами)" и выбора ("из формы", "быстрый выбор", "обоими способами")

Автор MusulmaninРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 411
Последний ответ 06 Апр 2020, 10:53
от Musulmanin
Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3027
Последний ответ 21 Сен 2017, 10:33
от Insider
ПолеВвода формы "Контрагент"

Автор waxymonkeyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 43
Последний ответ 30 Ноя 2020, 14:22
от waxymonkey
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1219
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6618
Последний ответ 03 Авг 2011, 11:45
от t955938

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

DmitriyF DmitriyF
31 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
28 Сообщений
alexandr_ll
20 Сообщений
MuI_I_Ika MuI_I_Ika
17 Сообщений
antoneus antoneus
10 Сообщений
LexaK
10 Сообщений
Дидар Оразалы Дидар Оразалы
9 Сообщений
Yamuna
9 Сообщений
gribok
9 Сообщений
Каримдат Каримдат
7 Сообщений

* Кто онлайн

  • Точка Гостей: 372
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal