Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 06:27

Свертка базы

Автор Sork, 15 мар 2019, 22:45

0 Пользователей и 1 гость просматривают эту тему.

Sork

Добрый вечер, первый раз делаю свертку базы и столкнулся с такой ошибкой:  https://wampi.ru/image/6Z0fsYn

отладчик показывает ошибку на месте НаборЗаписей.Записать();

подскажите,как исправить

процедура
Процедура сбСформироватьДокументВводаОстатков(Запрос, ТекРег, ДатаСвертки, ОграничиватьРазмерДокументовВводаОстатков, ТипРегистра, КоличествоСтрокВДокументеВводаОстатков,ЕстьИтогиПоУчреждению=Ложь)
Результат = Запрос.Выполнить();
Если НЕ Результат.Пустой() Тогда
ТекУчреждение = Справочники.Организации.ПустаяСсылка();
Если ОграничиватьРазмерДокументовВводаОстатков Тогда
Если ЕстьИтогиПоУчреждению Тогда
ТабУчр = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ТабУчр.Следующий() Цикл
ТекУчреждение = ТабУчр.УчреждениеИтог;
ТабДвиж = ТабУчр.Выбрать();
    НомерПоследнейЗаписи = 0;
КолСтрокДвижений = ТабДвиж.Количество();
    Пока НомерПоследнейЗаписи < КолСтрокДвижений Цикл
НомерПервойЗаписи = НомерПоследнейЗаписи + 1;
НомерПоследнейЗаписи = НомерПервойЗаписи + КоличествоСтрокВДокументеВводаОстатков;
НомерПоследнейЗаписи = Мин(НомерПоследнейЗаписи, КолСтрокДвижений);

ДокОст = сбСформироватьШапкуДокументаВводаОстатков(ТекРег, ДатаСвертки, ТипРегистра, НомерПервойЗаписи, НомерПоследнейЗаписи,ТекУчреждение);
Если ТипРегистра = "накопления" Тогда
НаборЗаписей = РегистрыНакопления[ТекРег.Имя].СоздатьНаборЗаписей();
Иначе
НаборЗаписей = РегистрыСведений[ТекРег.Имя].СоздатьНаборЗаписей();
КонецЕсли;
НаборЗаписей.Отбор.Регистратор.Установить(ДокОст);

Для ш = НомерПервойЗаписи По НомерПоследнейЗаписи Цикл
ТабДвиж.Следующий();
НоваяЗапись = НаборЗаписей.Добавить();
ЗаполнитьЗначенияСвойств(НоваяЗапись, ТабДвиж);
НоваяЗапись.Регистратор = ДокОст;
КонецЦикла;
НаборЗаписей.Записать();

КонецЦикла;

КонецЦикла;

Иначе
ТабДвиж = Результат.Выбрать();
НомерПоследнейЗаписи = 0;
Пока НомерПоследнейЗаписи < ТабДвиж.Количество() Цикл
НомерПервойЗаписи = НомерПоследнейЗаписи + 1;
НомерПоследнейЗаписи = НомерПервойЗаписи + КоличествоСтрокВДокументеВводаОстатков;
НомерПоследнейЗаписи = Мин(НомерПоследнейЗаписи, ТабДвиж.Количество());

ДокОст = сбСформироватьШапкуДокументаВводаОстатков(ТекРег, ДатаСвертки, ТипРегистра, НомерПервойЗаписи, НомерПоследнейЗаписи);

Если ТипРегистра = "накопления" Тогда
НаборЗаписей = РегистрыНакопления[ТекРег.Имя].СоздатьНаборЗаписей();
Иначе
НаборЗаписей = РегистрыСведений[ТекРег.Имя].СоздатьНаборЗаписей();
КонецЕсли;

НаборЗаписей.Отбор.Регистратор.Установить(ДокОст);

Для ш = НомерПервойЗаписи По НомерПоследнейЗаписи Цикл
ТабДвиж.Следующий();
НоваяЗапись = НаборЗаписей.Добавить();
ЗаполнитьЗначенияСвойств(НоваяЗапись, ТабДвиж);
НоваяЗапись.Регистратор = ДокОст.Ссылка;
КонецЦикла;
НаборЗаписей.Записать();

КонецЦикла;
КонецЕсли;

Иначе
Если ЕстьИтогиПоУчреждению Тогда
ТабУчр = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ТабУчр.Следующий() Цикл
ТекУчреждение = ТабУчр.УчреждениеИтог;
ТабДвиж = ТабУчр.Выбрать();

ДокОст = сбСформироватьШапкуДокументаВводаОстатков(ТекРег, ДатаСвертки, ТипРегистра, , ,ТекУчреждение);
Если ТипРегистра = "накопления" Тогда
НаборЗаписей = РегистрыНакопления[ТекРег.Имя].СоздатьНаборЗаписей();
Иначе
НаборЗаписей = РегистрыСведений[ТекРег.Имя].СоздатьНаборЗаписей();
КонецЕсли;
НаборЗаписей.Отбор.Регистратор.Установить(ДокОст);

Пока ТабДвиж.Следующий() Цикл
НоваяЗапись = НаборЗаписей.Добавить();
ЗаполнитьЗначенияСвойств(НоваяЗапись, ТабДвиж);
НоваяЗапись.Регистратор = ДокОст;
КонецЦикла;
НаборЗаписей.Записать();
КонецЦикла;
Иначе

ТабДвиж = Результат.Выгрузить();

ДокОст = сбСформироватьШапкуДокументаВводаОстатков(ТекРег, ДатаСвертки, ТипРегистра);

Если ТипРегистра = "накопления" Тогда
НаборЗаписей = РегистрыНакопления[ТекРег.Имя].СоздатьНаборЗаписей();
Иначе
НаборЗаписей = РегистрыСведений[ТекРег.Имя].СоздатьНаборЗаписей();
КонецЕсли;

НаборЗаписей.Отбор.Регистратор.Установить(ДокОст);
НаборЗаписей.Загрузить(ТабДвиж);
НаборЗаписей.Записать();   ////////////////////// ВЫДАЕТ ОШИБКУ НА ЭТОМ МЕСТЕ
КонецЕсли;
КонецЕсли;

сбСообщениеСвертки("Сформирован документ ввода остатков " + ТекРег.Имя);

КонецЕсли;

КонецПроцедуры


pavl_vs

Sork, какой релиз конфигурации и какой обработкой воспользовались?

Геннадий ОбьГЭС

Цитата: pavl_vs от 16 мар 2019, 14:19
Sork, какой релиз конфигурации и какой обработкой воспользовались?
Ни в каких последних релизах ни в каких конфигурациях свертки не работают

Обрезайте вручную, вводя остатки

pavl_vs

Цитата: Геннадий ОбьГЭС от 16 мар 2019, 21:35
Ни в каких последних релизах ни в каких конфигурациях свертки не работают

Напрасно так безапелляционно, см. скрин.

DmitriyF

Цитата: Геннадий ОбьГЭС от 16 мар 2019, 21:35
Цитата: pavl_vs от 16 мар 2019, 14:19
Sork, какой релиз конфигурации и какой обработкой воспользовались?
Ни в каких последних релизах ни в каких конфигурациях свертки не работают

Обрезайте вручную, вводя остатки
Скажу больше, в БГУ 2 уже есть свертка вводом начальных остатков, а не корректировкой регистров.

Геннадий ОбьГЭС

Цитата: pavl_vs от 17 мар 2019, 12:48
Напрасно так безапелляционно, см. скрин.
Скиншот обработки - это что доказывает?
А где скриншот успешно отработавшей и свернувшей базу свертки?
БГУ версии 1 - это не последней версии.
У БГУ последние версии 2.0.61.**, а не 1.0.56.7

Цитата: DmitriyF от 17 мар 2019, 22:09
Скажу больше, в БГУ 2 уже есть свертка вводом начальных остатков, а не корректировкой регистров.
Прям какие-то сказки Хаббибуллина
А как содержимое обрезаемых и удаляемых регистров и документов как и куда исчезает?

Сами делали такую "свертку" или в кино увидели?

pavl_vs

Цитата: Геннадий ОбьГЭС от 18 мар 2019, 14:20
Скиншот обработки - это что доказывает?
А где скриншот успешно отработавшей и свернувшей базу свертки?
БГУ версии 1 - это не последней версии.
У БГУ последние версии 2.0.61.**, а не 1.0.56.7

Сами делали такую "свертку" или в кино увидели?

1. Доказывает, что 1С не отказалась от свертки бухгалтерских баз и в частности БГУ 1.0.
2. Во всех постах кроме вашего ни слова о версии или редакции программы; в крайнем случае речь только о релизе.
3. В топике речь идет конкретно о БГУ 1.0.

И наконец, свертку баз БГУ 1.0 делали сами и не в кино.
4. Непонятно, что хотелось бы Вам увидеть на скриншоте?

Если бы Вы затеяли разговор о недостатках собственно свертки, то согласился бы с тем, что много "грязи", возможно ошибок, но заставить бухгалтеров привести базы в порядок оказалось просто невозможным.

Что же касается ошибки при свертке у автора темы, то возможно для свертки актуальной базы воспользовались либо первой скачанной из интернета, либо обработкой 1С, но из "древнего" пакета, что тоже плохо.

Геннадий ОбьГЭС

Цитата: pavl_vs от 18 мар 2019, 19:57
1. Доказывает, что 1С не отказалась от свертки бухгалтерских баз и в частности БГУ 1.0
А кто-то где-то утверждал обратное?

DmitriyF

Цитата: Геннадий ОбьГЭС от 18 мар 2019, 14:20

Сами делали такую "свертку" или в кино увидели?
Конкретно свертку вводом начальных остатков, в последнем релизе БГУ2.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск