Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Мар 2019, 06:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программное заполнение табличной части документа ДанныеДляРасчетаЗарплаты в ЗУП 3.1  (Прочитано 103 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн МолчановАнтон

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-10
  • Сайт: 
  • Профессия: Программист 8.1
Коллеги, добрый вечер!
Мне необходимо программно создать документ ДанныеДляРасчетаЗарплаты и заполнить в нем табличную часть ДанныеДетально.

В ней 2 поля: Сотрудник и Питание



Питание - показатель созданный в шаблоне ввода исходных данных.



Сам документ программно я создаю так:
		
                Док = Документы.ДанныеДляРасчетаЗарплаты.СоздатьДокумент();
Док.Организация = Справочники.Организации.НайтиПоНаименованию("ИнтерТрейд");
Док.Период = ТекущаяДата();
Док.Ответственный = ПараметрыСеанса.ТекущийПользователь;
Док.ВидДокумента = Справочники.ВидыДокументовВводДанныхДляРасчетаЗарплаты.НайтиПоНаименованию("Удержание за питание");
Док.Дата = ТекущаяДата();
//Стр = Док.ДанныеДетально.Добавить();
//Стр.Сотрудник = Справочники.ФизическиеЛица.НайтиПоНаименованию("Иванов Сергей Антонович");
//Стр.Питание=10;
Док.Записать();

А вот заполнить табличную часть ДанныеДетально у меня не получается, её не видно в контексте программы. Подскажите пожалуйста, как можно заполнить табличную часть?


Оффлайн Vit1501

  • ****
  • Сообщений: 387
  • РЕПУТАЦИЯ: 64
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
А вы уверены, что это табличная часть документа? ошибку выдает какую платформа?

Оффлайн МолчановАнтон

  • *
  • Сообщений: 13
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-06-10
  • Сайт: 
  • Профессия: Программист 8.1
Поразбиравшись, понял - что табличных частей в документе ДанныеДляРасчетаЗарплаты две:
1) ФизическиеЛица
2) ЗначенияПоказателей

Мне как раз и надо их заполнить.

Сначала я создаю документ и заполняю его реквизиты:
                Док = Документы.ДанныеДляРасчетаЗарплаты.СоздатьДокумент();		
Док.Организация = Справочники.Организации.НайтиПоНаименованию("НК Гидропривод");
Док.Период = ТекущаяДата();
Док.Ответственный = ПараметрыСеанса.ТекущийПользователь;
Док.ВидДокумента = Справочники.ВидыДокументовВводДанныхДляРасчетаЗарплаты.НайтиПоНаименованию("Удержание за питание");
Док.Дата = ТекущаяДата();

Запросом получаю список сотрудников из справочника Сотрудники:
		Запрос = Новый Запрос;
Запрос.Текст =
    "ВЫБРАТЬ
    | Сотрудники.ФизическоеЛицо КАК ФизическоеЛицо
    |ИЗ
    | Справочник.Сотрудники КАК Сотрудники";

РезультатЗапроса = Запрос.Выполнить().Выгрузить();


Циклом заполняю нужные мне табличные части ФизическиеЛица и ЗначенияПоказателей
		Для каждого Строка из РезультатЗапроса Цикл
    НоваяСтрока = Док.ФизическиеЛица.Добавить();
    НоваяСтрока.ФизическоеЛицо = Строка.ФизическоеЛицо;
    НоваяСтрока = Док.ЗначенияПоказателей.Добавить();
    НоваяСтрока.Значение = 55;
КонецЦикла;

Проверяю что данные попали в табличные части:
		Сообщение = Новый СообщениеПользователю();
Для Каждого Строка Из Док.ФизическиеЛица Цикл
Сообщение.Текст=Строка.ФизическоеЛицо;
Сообщение.Сообщить();
КонецЦикла;

Для Каждого Строка Из Док.ЗначенияПоказателей Цикл
Сообщение.Текст=Строка.Значение;
Сообщение.Сообщить();
КонецЦикла; 

Вижу что данные загрузились в табличные части:



Сохраняю документ:
Док.Записать();

После сохранения, документ появляется в списке, но при попытке его открыть выдает ошибку:

{Документ.ДанныеДляРасчетаЗарплаты.Форма.ФормаДокумента.Форма(1736)}: Индекс находится за границами массива
СведенияОПоказателе = ПоказателиРасчетаЗарплаты.НайтиСтроки(Новый Структура("Показатель", СтрокаОбъекты.Показатель))[0];

При открытии документа по номеру и просмотром табличных частей отладчиком в цикле, видно что
табличная часть ФизическиеЛица - пустая, однако данные табличной части ЗначенияПоказателей - заполнены:


Подскажите пожалуйста, почему данные табличной части ФизическиеЛица при сохранении исчезают?

Последний раз редактировалось: МолчановАнтон; 13 Мар 2019, 20:25


 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5158
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8730
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6478
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 11426
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 8336
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

LexaK
64 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
61 Сообщений
DmitriyF DmitriyF
49 Сообщений
alexandr_ll
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
alex0402
26 Сообщений
antoneus antoneus
24 Сообщений
ivangrant
16 Сообщений
isacnew21
15 Сообщений
bsn-chita
14 Сообщений

* Кто онлайн

  • Точка Гостей: 332
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal