Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 03:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПОМОГИТЕ С ДАТОЙ  (Прочитано 3198 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Юлия_161

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-04-13
  • Сайт: 
  • Профессия: Ученик 1С
Народ помогите пожалуйста
Учусь на 1с.
Есть справочник Сотрудники. В табличной части Электробезопасность Две даты
Дата_проверки и Дата_след_проверки.
Нужно сравнить Дата_след_проверки с текущей датой  и выдать  сообщение что даты совпали.
Не получается никак помогите. пересмотрела всю инфу о датах.Ошибок не выдает и результата нет
  :dfbbdrfb:


Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #1: 14 Апр 2011, 14:47 »
Код покажите как сравниваете?

Оффлайн Юлия_161

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-04-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #2: 14 Апр 2011, 14:52 »
 Если НачалоДня(Дата_след_проверки) = ТекущаяДата  тогда
        Сообщить  (" Даты совпали")
    иначе
    Сообщить("Даты не совпали");   
 КонецЕсли;

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #3: 14 Апр 2011, 14:55 »
Полный код процедуры покажите. Ну и таб часть надо минимум в цикле обходить

Оффлайн Юлия_161

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-04-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #4: 14 Апр 2011, 15:03 »
Вот что я пока решила не связваться с табличными частями просто сделала реквизиты справочника Дата_проверки
Дата_след_проверки и ТекущаяДата вот процедура.
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
Если Дата_Проверки = Дата(1, 1, 1)и Дата_след_проверки = Дата(1, 1, 1) Тогда
   Сообщить(" ОБЕ ДАТЫ ПУСТЫЕ!") иначе  Сообщить("  ДАТЫ НЕ ПУСТЫЕ!"); КонецЕсли;
  ТекущаяДата = Формат(ТекущаяДата(), "ДЛФ=Д");
  Сообщить(ТекущаяДата);
Если НачалоДня(Дата_след_проверки) = Текущая_дата  тогда
       Сообщить  (" даты совпали")
    иначе
    Сообщить("не совпали");   
 КонецЕсли;
КонецПроцедуры;
Вот такой код. Отнеситесь с пониманием только учусь :mellow:

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #5: 14 Апр 2011, 15:18 »
Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   Если Дата_Проверки = Дата_след_проверки = Дата(1, 1, 1) Тогда
      Сообщить(" ОБЕ ДАТЫ ПУСТЫЕ!");
   ИначеЕсли НАчалоДня(Дата_Проверки) = НачалоДня(Дата_след_проверки) Тогда //у дат может быть разное время
      Сообщить  ("Даты совпали");
   Иначе
      Сообщить  ("Даты не совпали");
   КонецЕсли;
КонецПроцедуры;

Оффлайн Юлия_161

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-04-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #6: 14 Апр 2011, 15:29 »
Хорошо тогда еще вопрос как мне обойти время.
мне время вообще не нужно только работа  с датой

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #7: 14 Апр 2011, 16:07 »
Ну вот проще всего приводить к началу дня, тогда время у обоих и будет одинаковое :)
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Юлия_161

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-04-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #8: 14 Апр 2011, 16:17 »
Народ помогите с датами рахобраться и временем

Оффлайн Юлия_161

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2011-04-13
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПОМОГИТЕ С ДАТОЙ
« Ответ #9: 14 Апр 2011, 16:20 »
Если пишу  так
Если НачалоДНя(Дата_след_проверки) = НачалоДня(ТекущаяДата) тогда тра та та
выводит ошибка ругается на текущую дату :(


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4292
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5551
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5888
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4366
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1978
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal