Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Апр 2019, 23:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Объединение данных  (Прочитано 126 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Петр Попович

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-02-11
  • Сайт: 
Здравствуйте, объясните, пожалуйста, новичку, самоучке, как объединить данные из "Завтрак" "Обед" "Ужин" в Общий итог. Какой "код" написать в конфигураторе?


Оффлайн LexaK

  • *****
  • Сообщений: 1651
  • РЕПУТАЦИЯ: 470
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
один из вариантов
//создать кнопку Расчитать Итог и на нее повесить этот обработчик
&НаКленте
Процедура РасчитатьИтог(Кнопка)
ОбновитьИтоги();
КонецПроцедуры
 
&НаСервере
Процедура ОбновитьИтоги()

лкИтоги = Итоги.ВыгрузитьКолонки();//здесь свои названия ТЧ: Итоги, Завтрак, ...
ДобавитьДанные(лкИтоги, Завтрак);
ДобавитьДанные(лкИтоги, Обед);
ДобавитьДанные(лкИтоги, Ужин);

лкИтоги.Свернуть("Продукты,Вид","Количество,Расход"); //здесь свои названия колонок
Итоги.Загрузить(лкИтоги);

КонецПроцедуры
 
&НаСервере
Процедура ДобавитьДанные(лкПриемник, лкИсточник)
Для каждого лкСтр Из лкИсточник Цикл
ЗаполнитьЗначенияСвойств(лкПриемник.Добавить(), лкСтр);
КонецЦикла;
КонецПроцедуры

так у вас наблюдается задвоение данных,
вообще лучше все писать в РегистрНакопления и уже из него выводить результат/итог

но для вашей задачи может и так сойдет :dfbsdfbsdf:
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн Петр Попович

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-02-11
  • Сайт: 
Прошу прощения,возможно не правильно описал свою проблему. РегистрНакопления у меня имеется. Ресурс у меня там один - "КолВоПродукции". Но этот один ресурс, не прикрепить же к каждому реквизиту из табличной части "Завтрак,обед,ужин"? Если можно, то, пожалуйста, объясните как? 
А если отдельно создавать ресурсы под каждую табличную часть в одном документе, как из этого вывести общий итог остатков ? В "приходе" движение ведь только один "Ресурс" присваивается . Буду рад вашим советам.
Буду еще рад,если дадите ссылку, на хорошую письменную информацию, где могу нормально начать учение в области 1с. "Да придет мне скилл "суперпуперспециалиста1с")


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8693
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4431
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3344
Последний ответ 26 Апр 2018, 06:45
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 9491
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 8701
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
88 Сообщений
AIFrame AIFrame
64 Сообщений
alexandr_ll
42 Сообщений
alex0402
31 Сообщений
wise wise
23 Сообщений
LexaK
18 Сообщений
BuhRust
15 Сообщений
byte777
14 Сообщений
pavl_vs
14 Сообщений
Weidermail
13 Сообщений

* Кто онлайн

  • Точка Гостей: 99
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal