Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Авг 2019, 01:02
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как сделать чтобы в табличном документе список разбивался при выводе на Подразделения?  (Прочитано 214 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ledgik

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-02-11
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте форумчане!
У меня есть справочники: Должности, Подразделения и Сотрудники; без иерархии в 1С Предприятие 8.3. Справочник Сотрудники содержит реквизиты: Должность, Подразделение, ДатаПриема, ДатаУвольнения, ДатаРождения. Реквизиты Должность и Подразделение берутся из соответствующих справочников по ссылкам. В окне конфигуратора Справочник имеет такой вид: Номер; Наименование; Код; Должность; Подразделение; ДатаПриема; ДатаУвольнения; ДатаРождения.
В целом вывести список на экран для печати создав кнопку Печать я могу через такой вот код:

&НаСервере
Процедура ПечатьНаСервере(ТабДок)
Макет = Справочники.Сотрудники.ПолучитьМакет("Макет");
ОблШапка = Макет.ПолучитьОбласть("Шапка");
ОблСтрока = Макет.ПолучитьОбласть("Строка");

Выборка = Справочники.Сотрудники.Выбрать();
ТабДок.Вывести(ОблШапка);
Номер = 1;
Пока Выборка.Следующий() Цикл
//ОблСтрока.Параметры.Код = Выборка.Код;
//ОблСтрока.Параметры.Наименование = Выборка.Наименование;

Если Выборка.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;

ОблСтрока.Параметры.Заполнить(Выборка);

ОблСтрока.Параметры.Номер = Номер;

ТабДок.Вывести(ОблСтрока);

Номер = Номер + 1;
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Печать(Команда)
ТабДок = Новый ТабличныйДокумент;
ПечатьНаСервере(ТабДок);
ТабДок.Показать();
ТабДок.ОтображатьСетку = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
КонецПроцедуры

А как сделать чтобы в табличном документе список разбивался при выводе на Подразделения не знаю. Я только начал изучать программирование в 1С. Буду рад помощи по данному Вопросу! И еще подскажите что можно и нужно изучить чтобы в этом разбираться! Спасибо!


Оффлайн alexandr_ll

  • *****
  • Сообщений: 1079
  • РЕПУТАЦИЯ: 173
  • КПД: 16%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте форумчане!
У меня есть справочники: Должности, Подразделения и Сотрудники; без иерархии в 1С Предприятие 8.3. Справочник Сотрудники содержит реквизиты: Должность, Подразделение, ДатаПриема, ДатаУвольнения, ДатаРождения. Реквизиты Должность и Подразделение берутся из соответствующих справочников по ссылкам. В окне конфигуратора Справочник имеет такой вид: Номер; Наименование; Код; Должность; Подразделение; ДатаПриема; ДатаУвольнения; ДатаРождения.
В целом вывести список на экран для печати создав кнопку Печать я могу через такой вот код:

&НаСервере
Процедура ПечатьНаСервере(ТабДок)
Макет = Справочники.Сотрудники.ПолучитьМакет("Макет");
ОблШапка = Макет.ПолучитьОбласть("Шапка");
ОблСтрока = Макет.ПолучитьОбласть("Строка");

Выборка = Справочники.Сотрудники.Выбрать();
ТабДок.Вывести(ОблШапка);
Номер = 1;
Пока Выборка.Следующий() Цикл
//ОблСтрока.Параметры.Код = Выборка.Код;
//ОблСтрока.Параметры.Наименование = Выборка.Наименование;

Если Выборка.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;

ОблСтрока.Параметры.Заполнить(Выборка);

ОблСтрока.Параметры.Номер = Номер;

ТабДок.Вывести(ОблСтрока);

Номер = Номер + 1;
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Печать(Команда)
ТабДок = Новый ТабличныйДокумент;
ПечатьНаСервере(ТабДок);
ТабДок.Показать();
ТабДок.ОтображатьСетку = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
КонецПроцедуры

А как сделать чтобы в табличном документе список разбивался при выводе на Подразделения не знаю. Я только начал изучать программирование в 1С. Буду рад помощи по данному Вопросу! И еще подскажите что можно и нужно изучить чтобы в этом разбираться! Спасибо!
Какая-то самописная конфигурация?
Сгруппировать можно, предварительно выгрузив результаты выборки в таблицу значений, либо использовать запрос.

Оффлайн wise

  • *****
  • Сообщений: 902
  • РЕПУТАЦИЯ: 131
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0)
вывести список на экран для печати
МОЖНО просто. :befhbt:
зайди в форме "Все действия"->Настроить список
там на закладке группировка выбери "Подразделение"
далее кнопка "Завершить редактирование"
и СНОВА "Все действия"->Вывести список
и распечатывай :P
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


 

Что такое "Список Значений", "Таблица значений" и "Дерево Значений"?

Автор JahongirРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 8912
Последний ответ 23 Дек 2011, 16:43
от sergeevds
В 1с предприятие 8.3 управление торговлей 11.1 как изменить цену на несколько товаров с одним и тем же артиклем на последнюю введенную цену с помощью загрузки обработки или как это сделать в 1с с помощью программирования? прилагаю полный текст обработки

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 271
Последний ответ 11 Фев 2019, 15:15
от сергей123
Добрый день Необходимо на основании типовой конфигурации бухгалтерии сделать обработку, которая будет переносить остатки со счета расчетов 62.01 с одной организации в документ ввода начальных

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 874
Последний ответ 18 Авг 2017, 11:57
от ZSS
Как "Наименование" сделать числом

Автор zedikusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2501
Последний ответ 24 Авг 2015, 06:26
от cska-fanat-kz
заполнение закладки "Материалы" в документе "Поступление из переработки"

Автор Sasa1CРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4326
Последний ответ 10 Июн 2013, 22:34
от Sasa1C

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
117 Сообщений
alexandr_ll
58 Сообщений
LexaK
47 Сообщений
alex0402 alex0402
45 Сообщений
DmitriyF DmitriyF
29 Сообщений
MuI_I_Ika MuI_I_Ika
27 Сообщений
BuhRust
27 Сообщений
Stanislav Gareev
19 Сообщений
Funt432286
18 Сообщений
Андрей_gen_D
16 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal