Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 сен 2021, 16:51

Как сделать чтобы в табличном документе список разбивался при выводе на Подразделения?

Автор Ledgik, 11 фев 2019, 11:00

0 Пользователей и 1 гость просматривают эту тему.

Ledgik

Здравствуйте форумчане!
У меня есть справочники: Должности, Подразделения и Сотрудники; без иерархии в 1С Предприятие 8.3. Справочник Сотрудники содержит реквизиты: Должность, Подразделение, ДатаПриема, ДатаУвольнения, ДатаРождения. Реквизиты Должность и Подразделение берутся из соответствующих справочников по ссылкам. В окне конфигуратора Справочник имеет такой вид: Номер; Наименование; Код; Должность; Подразделение; ДатаПриема; ДатаУвольнения; ДатаРождения.
В целом вывести список на экран для печати создав кнопку Печать я могу через такой вот код:

&НаСервере
Процедура ПечатьНаСервере(ТабДок)
Макет = Справочники.Сотрудники.ПолучитьМакет("Макет");
ОблШапка = Макет.ПолучитьОбласть("Шапка");
ОблСтрока = Макет.ПолучитьОбласть("Строка");

Выборка = Справочники.Сотрудники.Выбрать();
ТабДок.Вывести(ОблШапка);
Номер = 1;
Пока Выборка.Следующий() Цикл
//ОблСтрока.Параметры.Код = Выборка.Код;
//ОблСтрока.Параметры.Наименование = Выборка.Наименование;

Если Выборка.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;

ОблСтрока.Параметры.Заполнить(Выборка);

ОблСтрока.Параметры.Номер = Номер;

ТабДок.Вывести(ОблСтрока);

Номер = Номер + 1;
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Печать(Команда)
ТабДок = Новый ТабличныйДокумент;
ПечатьНаСервере(ТабДок);
ТабДок.Показать();
ТабДок.ОтображатьСетку = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
КонецПроцедуры

А как сделать чтобы в табличном документе список разбивался при выводе на Подразделения не знаю. Я только начал изучать программирование в 1С. Буду рад помощи по данному Вопросу! И еще подскажите что можно и нужно изучить чтобы в этом разбираться! Спасибо!

alexandr_ll

Цитата: Ledgik от 11 фев 2019, 11:00
Здравствуйте форумчане!
У меня есть справочники: Должности, Подразделения и Сотрудники; без иерархии в 1С Предприятие 8.3. Справочник Сотрудники содержит реквизиты: Должность, Подразделение, ДатаПриема, ДатаУвольнения, ДатаРождения. Реквизиты Должность и Подразделение берутся из соответствующих справочников по ссылкам. В окне конфигуратора Справочник имеет такой вид: Номер; Наименование; Код; Должность; Подразделение; ДатаПриема; ДатаУвольнения; ДатаРождения.
В целом вывести список на экран для печати создав кнопку Печать я могу через такой вот код:

&НаСервере
Процедура ПечатьНаСервере(ТабДок)
Макет = Справочники.Сотрудники.ПолучитьМакет("Макет");
ОблШапка = Макет.ПолучитьОбласть("Шапка");
ОблСтрока = Макет.ПолучитьОбласть("Строка");

Выборка = Справочники.Сотрудники.Выбрать();
ТабДок.Вывести(ОблШапка);
Номер = 1;
Пока Выборка.Следующий() Цикл
//ОблСтрока.Параметры.Код = Выборка.Код;
//ОблСтрока.Параметры.Наименование = Выборка.Наименование;

Если Выборка.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;

ОблСтрока.Параметры.Заполнить(Выборка);

ОблСтрока.Параметры.Номер = Номер;

ТабДок.Вывести(ОблСтрока);

Номер = Номер + 1;
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура Печать(Команда)
ТабДок = Новый ТабличныйДокумент;
ПечатьНаСервере(ТабДок);
ТабДок.Показать();
ТабДок.ОтображатьСетку = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
КонецПроцедуры

А как сделать чтобы в табличном документе список разбивался при выводе на Подразделения не знаю. Я только начал изучать программирование в 1С. Буду рад помощи по данному Вопросу! И еще подскажите что можно и нужно изучить чтобы в этом разбираться! Спасибо!
Какая-то самописная конфигурация?
Сгруппировать можно, предварительно выгрузив результаты выборки в таблицу значений, либо использовать запрос.

wise

(0)
Цитата: Ledgik от 11 фев 2019, 11:00вывести список на экран для печати
МОЖНО просто. :befhbt:
зайди в форме "Все действия"->Настроить список
там на закладке группировка выбери "Подразделение"
далее кнопка "Завершить редактирование"
и СНОВА "Все действия"->Вывести список
и распечатывай :P
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск