Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 00:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Списать комплектующие  (Прочитано 2467 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
Задача следующая :

--В справочнике Номенклатура созданно две группы Установки и комплектующие.
-- Документ "КомплектующиеНоменклатуры" (реквизит "Установка", ТЧ "комплектующие" с реквизитами Деталь и Количество) создает записи в регистре сведений "СоставУстановок" Где измерения : "Установки" и "Комплектующие" типа Справочник.Номенклатура.... тем самым осуществляю уникальность комплектующих у установок.
--Далее в документе Расходная накладная, если указанна в колонке  номенклатура "Установка 1" нужно ссылаясь на регистр сведений списывать все Комплектующие этой установки.

p.s. такой же механизм в УТ, но никак не могу разобраться  что там  к чему...слишком много лишнего
(я учебник))

вот код расходной накладной:


Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
   Для Каждого ТекСтрокаТовары Из Товары Цикл
      // регистр ОстаткиНоменклатуры Расход
            
      Запрос = Новый Запрос;
      Запрос.Текст =   
      "ВЫБРАТЬ
      |   РасходнаяНакладнаяТовары.Номенклатура КАК Номенклатура,
      |   РасходнаяНакладнаяТовары.ТипНоменклатуры,
      |   ЕСТЬNULL(ОстаткиНоменклатурыОстатки.КоличествоОстаток, 0) КАК КоличествоНаСкладе,
      |   СУММА(РасходнаяНакладнаяТовары.Количество) КАК КоличествоВДокументе,
      |   СоставУстановок.Установки КАК Установка,
      |   СоставУстановок.Комплектующие КАК Деталь
      |ИЗ
      |   Документ.РасходнаяНакладная.Товары КАК РасходнаяНакладнаяТовары
      |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.ОстаткиНоменклатуры.Остатки КАК ОстаткиНоменклатурыОстатки
      |      ПО РасходнаяНакладнаяТовары.Номенклатура = ОстаткиНоменклатурыОстатки.Номенклатура
      |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.СоставУстановок КАК СоставУстановок
      |      ПО РасходнаяНакладнаяТовары.Номенклатура = СоставУстановок.Комплектующие
      |         И РасходнаяНакладнаяТовары.Номенклатура = СоставУстановок.Установки
      |ГДЕ
      |   РасходнаяНакладнаяТовары.Ссылка = &Ссылка
      |
      |СГРУППИРОВАТЬ ПО
      |   ЕСТЬNULL(ОстаткиНоменклатурыОстатки.КоличествоОстаток, 0),
      |   РасходнаяНакладнаяТовары.Номенклатура,
      |   РасходнаяНакладнаяТовары.ТипНоменклатуры,
      |   СоставУстановок.Установки,
      |   СоставУстановок.Комплектующие";
      
      Запрос.УстановитьПараметр("Ссылка",Ссылка);
      Результат = Запрос.Выполнить();
      Выборка = Запрос.Выполнить().Выбрать();
      Пока Выборка.Следующий() Цикл
         Если Выборка.КоличествоВДокументе > Выборка.КоличествоНаСкладе Тогда
            Сообщить("На складе не хватает " + (Выборка.КоличествоВДокументе - Выборка.КоличествоНаСкладе)+" единиц "+Выборка.Номенклатура);
           Отказ=Истина;
        КонецЕсли;
        Если Выборка.Номенклатура = Выборка.Установка Тогда   

???????????????????????????????????????????????????????????
           КонецЕсли    
//////         // обход нужно выполнить регистра сведений с определенными условиями но никак это в коде реализовать не могу
      КонецЦикла; 
      
      Движение = Движения.ОстаткиНоменклатуры.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
      Движение.Период = Дата;
      Движение.Номенклатура = Выборка.Номенклатура;
      Движение.Количество = Выборка.КоличествоВДокументе;

      
      
   КонецЦикла;
   
   
   
   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры




Помогите пожалуйста ! :trhregerhg:


Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
Ммм...можно поподробнее пожалуйста про эту вторую ТЧ...немного не понял вас


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 181
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal