Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 07:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как выбрать ОПРЕДЕЛЕННЫЙ документ за период  (Прочитано 9435 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Chuchi

  • ***
  • Сообщений: 133
  • РЕПУТАЦИЯ: 4
  • КПД: 3%
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Ученик 1С
наверно предыдущая тема уже не правильная.(...
попробую снова
задача: выбрав на форме из Поля ТипДокумента в результате Отчета вывести все оформленные документы с таким типом за указанный диапазон
нашла следующий код

Запрос = Новый Запрос;
    ТекстЗапроса = "";
    Для Каждого Элем Из Метаданные.Документы цикл
        ТекстЗапроса = ТекстЗапроса + "
        |ВЫБРАТЬ
        | Ссылка,
        | Дата
        |ИЗ
        | Документ." + Элем.Имя + "
        |ГДЕ
        | Дата МЕЖДУ &НачДата И &КонДата
        |ОБЪЕДИНИТЬ ВСЕ";
    КонецЦикла;
    
    ТекстЗапроса = Лев(ТекстЗапроса,СтрДлина(ТекстЗапроса) - 15);
    ТекстЗапроса = ТекстЗапроса + "
    |УПОРЯДОЧИТЬ ПО
    | Дата";
    
    Запрос.Текст = ТекстЗапроса;
    Запрос.УстановитьПараметр("НачДата",НачДата);
    Запрос.УстановитьПараметр("КонДата",КонДата);

Но этот код выводит ВСЕ документы..
в каком месте и КАК мне необходимо указать какой именно ТипДокумента нужно выводить... :trhregerhg:


Оффлайн Chuchi

  • ***
  • Сообщений: 133
  • РЕПУТАЦИЯ: 4
  • КПД: 3%
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Ученик 1С
Попробовала так
Для Каждого Элем Из Метаданные.Документы[ТипДокумента] цикл

но пишет что Итератор не верный

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
 Для Каждого Элем Из Метаданные.Документы цикл 
        ТекстЗапроса = ТекстЗапроса + "
        |ВЫБРАТЬ
        | Документ.Ссылка,
        | Документ.Дата
        |ИЗ
        | Документ." + Элем.Имя + " КАК Документ
        |ГДЕ
        | Документ.Дата МЕЖДУ &НачДата И &КонДата
        |ОБЪЕДИНИТЬ ВСЕ";
    КонецЦикла;

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Приветствую!
Цитировать
в каком месте и КАК мне необходимо указать какой именно ТипДокумента нужно выводить...
Цикл перебирает все возможные документы. Чтобы получить только нужный тип - нужно сделать свой цикл по нужным документам (если необходимо несколько типов обработать), либо вообще убрать цикл и вставить нужный тип (это если нужен один тип документов).
В строчке
| Документ." + Элем.Имя + " КАК Документ 
переменной Элем.Имя как раз и подставляется тип документа. Можем вместо него подставить нужный - например, РТУ:
| Документ." + "РеализацияТоваровУслуг" + " КАК Документ
ну и если нужен один документ, то смело убираем ненужное объединение, обрезание текста...
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Chuchi

  • ***
  • Сообщений: 133
  • РЕПУТАЦИЯ: 4
  • КПД: 3%
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Ученик 1С
Попробовал вот так

Процедура ДокументыВывести()
    Запрос = Новый Запрос;
 Для Каждого Элем Из Метаданные.Документы цикл
        ТекстЗапроса = ТекстЗапроса + "
        |ВЫБРАТЬ
        | Документ.Ссылка,
        | Документ.Дата
        |ИЗ
        | Документ." + Элем.Имя + " КАК Документ
        |ГДЕ
        | Документ.Дата МЕЖДУ &НачДата И &КонДата
        |ОБЪЕДИНИТЬ ВСЕ";
    КонецЦикла;


    
     Запрос.Текст = ТекстЗапроса;
    Запрос.УстановитьПараметр("НачалоПериода",НачалоПериода);
    Запрос.УстановитьПараметр("КонецПериода",КонецПериода);
   ЭлементыФормы.Результат.Очистить();

   ТекстЗапроса.Выполнить();
   ТекстЗапроса.РазмещениеИзмеренийВСтроках = ТипРазмещенияИзмерений.Вместе;
   ТекстЗапроса.РазмещениеРеквизитовИзмеренийВСтроках = ТипРазмещенияРеквизитовИзмерений.Отдельно;
   ТекстЗапроса.РазмещениеРеквизитовИзмеренийВКолонках = ТипРазмещенияРеквизитовИзмерений.Отдельно;
   ТекстЗапроса.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Лето);
   ТекстЗапроса.Макет = ОтчетОбъект.ПолучитьМакет("РеестрДокументов");
   ТекстЗапроса.ОформитьМакет();
   ТекстЗапроса.Вывести(ЭлементыФормы.Результат);
КонецПроцедуры   


Но пишет что Преобразование значения к типу Число не может быть выполнено
        ТекстЗапроса = ТекстЗапроса + "

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Ну как минимум, нужно проинициализировать переменную ТекстЗапроса
ТекстЗапроса="";
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Chuchi

  • ***
  • Сообщений: 133
  • РЕПУТАЦИЯ: 4
  • КПД: 3%
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Ученик 1С
Получилось вот так

Процедура ДокументыВывести()
    ЭлементыФормы.Результат.Очистить();
   
    ТекстЗапроса.Текст = "
    |ВЫБРАТЬ
    | Ссылка,
    | Дата
    |ИЗ
    | Документ." + ТипДокумента + "
    |ГДЕ
    | Дата МЕЖДУ &НачДата И &КонДата
    |УПОРЯДОЧИТЬ ПО
    | Дата";
   
    ТекстЗапроса.ЗаполнитьНастройки(); 
    ТекстЗапроса.Параметры.Вставить("НачалоПериода",НачалоПериода);
    ТекстЗапроса.Параметры.Вставить("КонецПериода",КонецПериода);
   
    ТекстЗапроса.РазмещениеИзмеренийВСтроках = ТипРазмещенияИзмерений.Вместе;
    ТекстЗапроса.РазмещениеРеквизитовИзмеренийВСтроках = ТипРазмещенияРеквизитовИзмерений.Отдельно;
    ТекстЗапроса.РазмещениеРеквизитовИзмеренийВКолонках = ТипРазмещенияРеквизитовИзмерений.Отдельно;
    ТекстЗапроса.МакетОформления = ПолучитьМакетОформления(СтандартноеОформление.Лето);
    ТекстЗапроса.Макет = ОтчетОбъект.ПолучитьМакет("РеестрДокументов");
    ТекстЗапроса.ОформитьМакет();
    ТекстЗапроса.Вывести(ЭлементыФормы.Результат);
   
КонецПроцедуры


СПАСИБО БОЛЬШОЕ ЗА СОДЕЙСТВИЕ


Теги:
 

Какова взаимосвязь объектов конфигурации "Договоры" и "Документ"?

Автор DDDРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4396
Последний ответ 25 Ноя 2008, 10:43
от DDD
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9328
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
не могу вывести отображение цен в "подборе" документ "Заявка покупателя" УТ 10.3

Автор Виталий ЕмельяновРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3904
Последний ответ 05 Окт 2015, 19:22
от Виталий Емельянов
Как программно открыть документ программно

Автор СерьезныйЧеловекРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 19009
Последний ответ 10 Ноя 2010, 14:08
от Lexius
Документ "Сторно" в 1с 8.2 бух 2.0

Автор cannabis_86Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 12342
Последний ответ 09 Июн 2011, 12:57
от defers

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
167 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 310
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal