Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Мар 2019, 01:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: 1С 8.3 : Работа с изображениями (картинками) в интерфейсе Такси  (Прочитано 260 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sheriff

  • ***
  • Сообщений: 125
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Всем доброго времени суток!
1С:Предприятие 8.3 (8.3.12.1595)
Бухгалтерия для Казахстана, редакция 3.0, (3.0.24.2)
Необходимо в РегистреСведений, хранить изображение. Сделал как было описано в этой статье https://helpf.pro/faq83/view/1563.html (но, тут используется справочник), ещё один код, взял тут https://курсы-по-1с.рф/articles/статьи-по-платформе-01-файлы-в-такси/ (с комментариев пользователей). В итоге, после того, как нажал кнопку "Записать-Закрыть" и повторно открыл форму, то картинки нет.
Как сделать чтобы она там сохранялась?
Код, который я использовал ниже. Использовал и то, что закомментарил, ничего не помогает.
&НаКлиенте
Процедура ВыбратьФайлКартинки (Команда)
Оповещение  =  Новый ОписаниеОповещения("ОбработатьВыборФайла",   ЭтотОбъект);
//Открываем интерактивно  окно для выбора файла
НачатьПомещениеФайла(Оповещение,   ,   ,   Истина,   УникальныйИдентификатор);
КонецПроцедуры

&НаКлиенте
Процедура ОбработатьВыборФайла(Результат, Адрес, ВыбранноеИмяФайла, ДополнительныеПараметры) Экспорт
Если Не Результат Тогда
 Возврат;
КонецЕсли;
Картинка = Адрес;
КонецПроцедуры   

&НаСервере
Процедура Перед3аписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЭтоАдресВременногоХранилища(Картинка) Тогда
ДвоичныеДанные = ПолучитьИзВременногоХранилища(Картинка);
ЗаписьРегистра = РегистрыСведений.Изображения.СоздатьМенеджерЗаписи();       
ЗаписьРегистра.Объект = Объект.СправочникСсылка.ФизическиеЛица;         
ЗаписьРегистра.Изображение = Новый ХранилищеЗначения(ДвоичныеДанные);     
ЗаписьРегистра.Записать();         
КонецЕсли;
//Если ЭтоАдресВременногоХранилища(Картинка) Тогда
// ТекущийОбъект.Изображение = Новый ХранилищеЗначения( ПолучитьИзВременногоХранилища(Картинка) );
//КонецЕсли;
КонецПроцедуры

 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ЗначениеКлюча = Новый Структура;   
ЗначениеКлюча.Вставить("Объект", Объект.СправочникСсылка.ФизическиеЛица);   
КлючЗаписи = РегистрыСведений.Изображения.СоздатьКлючЗаписи(ЗначениеКлюча);       
Картинка = ПолучитьНавигационнуюСсылку(КлючЗаписи, "Изображение");
//ОбновитьИзображение();
//СсылкаНаКартинку = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "ДанныеКартинки");
КонецПроцедуры

//&НаСервере
//Процедура ОбновитьИзображение()
//
// // Конвертируем объект формы в объект справочника, чтобы
// //можно было работать с реквизитом типа "Хранилище значений"
// ОбъектЭлемента = РеквизитФормыВЗначение("Объект");
//
// // Помещаем двоичные данные из реквизита во временное хранилище.
// //Адрес из хранилища помещаем в строковой реквизит
// // формы "Фото сотрудника"
// Картинка = ПоместитьВоВременноеХранилище(Объект.Ссылка.Изображение.Получить(),
//УникальныйИдентификатор);
//
//КонецПроцедуры



Оффлайн wise

  • *****
  • Сообщений: 818
  • РЕПУТАЦИЯ: 121
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0)
ЗаписьРегистра.Объект = Объект.СправочникСсылка.ФизическиеЛица;//НЕ спозиционирован объект

ТипЗначения ЗаписьРегистра.Объект = СправочникСсылка.ФизическиеЛица
а
ТипЗначения Объект.СправочникСсылка.ФизическиеЛица <> СправочникСсылка.ФизическиеЛица
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Sheriff

  • ***
  • Сообщений: 125
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
(0)
ЗаписьРегистра.Объект = Объект.СправочникСсылка.ФизическиеЛица;//НЕ спозиционирован объект

ТипЗначения ЗаписьРегистра.Объект = СправочникСсылка.ФизическиеЛица
а
ТипЗначения Объект.СправочникСсылка.ФизическиеЛица <> СправочникСсылка.ФизическиеЛица
Можно вот тут подробнее, т.к не понял, что нужно сделать
Добавлено: 14 Янв 2019, 13:15

Кто ещё может помочь в этом вопросе, отзовитесь

Последний раз редактировалось: Sheriff; 14 Янв 2019, 13:15. Причина: Объединение сообщений


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

LexaK
64 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
59 Сообщений
DmitriyF DmitriyF
49 Сообщений
alexandr_ll
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
alex0402
26 Сообщений
antoneus antoneus
24 Сообщений
ivangrant
16 Сообщений
isacnew21
15 Сообщений
bsn-chita
14 Сообщений

* Кто онлайн

  • Точка Гостей: 273
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal