Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 12:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Чтение XML  (Прочитано 2427 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Yeahkaterina

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Бухгалтер
Чтение XML
« Первое сообщение: 12 Апр 2011, 13:36 »
Здравствуйте! Подскажите пожалуйста, как создать обработку файла xml.
Фрагмент файла:

<ФайлОбмена ВерсияФормата="2.0" ДатаВыгрузки="2011-03-22T15:38:22" НачалоПериодаВыгрузки="2011-02-28T00:00:00" ОкончаниеПериодаВыгрузки="2011-02-28T00:00:00" ИмяКонфигурацииИсточника="Бухгалтерский учет, редакция 4.5" ИмяКонфигурацииПриемника="БухгалтерияПредприятия" ИдПравилКонвертации="46f37d56-deff-4ae4-8060-10c3e36ccc0a" Комментарий="">
+ <ПравилаОбмена ВерсияФормата="2.01" Ид="46f37d56-deff-4ae4-8060-10c3e36ccc0a" Наименование="Выгрузка в ВТО" ДатаВремяСоздания="2011-03-22T15:32:07" Источник="Бухгалтерский учет, редакция 4.5" Приемник="БухгалтерияПредприятия">
+ <ПравилаКонвертацииОбъектов>
+ <ПравилаОбмена ВерсияФормата="2.01" Ид="46f37d56-deff-4ae4-8060-10c3e36ccc0a" Наименование="Выгрузка в ВТО" ДатаВремяСоздания="2011-03-22T15:32:07" Источник="Бухгалтерский учет, редакция 4.5" Приемник="БухгалтерияПредприятия">
- <Объект Нпп="3" Тип="СправочникСсылка.Номенклатура" ИмяПравила="Номенклатура">
+ <Ссылка Нпп="3">
- <Свойство Имя="Код" Тип="Строка">
  <Значение>6066</Значение>
  </Свойство>
  </Ссылка>
- <Свойство Имя="Наименование" Тип="Строка">
  <Значение>Маслины крупные </Значение>
  </Свойство>

Не могу понять, как получить значение "Маслины крупные". Подскажите пожалуйста!
Код:

Файл = Новый ЧтениеXML;
   ПутьКФайлу = СокрЛП(ФайлЗагрузки);
   Файл.ОткрытьФайл(ФайлЗагрузки);
   Пока Файл.Прочитать() Цикл
      
      Если Файл.Имя = "ПравилаОбмена" И Файл.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
         Для Атрибут = 0 По Файл.КоличествоАтрибутов() Цикл
            Если Атрибут = 2 Тогда
               Наименование = Файл.ПолучитьАтрибут(Атрибут);
            ИначеЕсли Атрибут = 3 Тогда
               ДатаВыгрузки = Файл.ПолучитьАтрибут(Атрибут);
            ИначеЕсли Атрибут = 4 Тогда
               Источник = Файл.получитьАтрибут(Атрибут);
            КонецЕсли;
         КонецЦикла;
      КонецЕсли;
      
      Если Файл.Имя = "Объект" И Файл.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
         
         НПП        = Файл.ПолучитьАтрибут(0);
         ТипОбъекта = Файл.ПолучитьАтрибут(1);
         ИмяПравила = Файл.ПолучитьАтрибут(2);
         
         
         Если ТипОбъекта = "СправочникСсылка.Номенклатура" Тогда
            
            ПрочитатьЭлементНоменклатура(Файл);
            
            
            НоваяСтрока=ТаблицаНоменклатуры.Добавить();
            НоваяСтрока.НПП          = НПП;
            НоваяСтрока.ИмяПравила   = ИмяПравила;
            
                                       
            // читать номенклатуру в буфер (ТаблицаНоменклатуры)
         ИначеЕсли ТипОбъекта = "ДокументСсылка.РеализацияТоваровУслуг" Тогда
            
            ПрочитатьДокументРеализацияТоваровУслуг(Файл);

            НоваяСтрока=ТаблицаРеализацияТоваровУслуг.Добавить();
            НоваяСтрока.НПП          = НПП;
            НоваяСтрока.ИмяПравила   = ИмяПравила;
            
            
            
            // читать в таблицу документ
         Иначе
            
            ПрочитатьТаблицаСчетФактураВыданный(Файл);

            НоваяСтрока=ТаблицаСчетФактураВыданный.Добавить();
            НоваяСтрока.НПП          = НПП;
            НоваяСтрока.ИмяПравила   = ИмяПравила;
            
            
         КонецЕсли;
         КонецЕсли;

   КонецЦикла;         
КонецПроцедуры



Теги:
 

работа с файлами excel открытие файла xls, чтение данных и запись нового файла xls

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2783
Последний ответ 11 Фев 2016, 12:49
от Rasty
Справочник - как раздать права пользователям на чтение элементов

Автор LuunaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1947
Последний ответ 12 Дек 2012, 13:31
от MuI_I_Ika
Чтение файла ексель и загрузка его в таблицу значений

Автор Igor100500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1569
Последний ответ 07 Окт 2016, 12:06
от Igor100500
Чтение XML в дерево значений. Проблема с прочтением.

Автор delo_irisРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 8187
Последний ответ 14 Авг 2011, 10:31
от delo_iris
Чтение из xml и запись информации в справочники и документы

Автор Ученик_2014Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3147
Последний ответ 10 Фев 2014, 07:13
от sdilshod

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 823
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal