Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Сен 2019, 14:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: как правильно описать заполнение табличной части.?  (Прочитано 225 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Филипп Остырко

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-11-25
  • Сайт: 
  • Профессия: Ученик 1С
Мне нужно чтобы в документе реализации по команде "показать остатки" поле Товары.Количество заполнялось текущими Остатками из регистра. При запуске не срабатывает, говорит ,что "Количество" не определено. Как ее определить в коде? Спасибо за внимание.

"Процедура ВыполнитьКоманду(ИдентификаторКоманды, ОбъектыНазначения, ПараметрыВыполнения) Экспорт
        Если ИдентификаторКоманды = "ПоказатьОстатки" Тогда
        Форма = ПараметрыВыполнения.ЭтаФорма;

         ТЧ = Форма.Объект.Товары;
        Для Каждого ТекущаяСтрока Из ТЧ Цикл
            ТекущаяСтрока.Количество = ПолучитьОстатокТовараИзРегистра(Строка.Номенклатура);                 
        КонецЦикла;     
    КонецЕсли;
КонецПроцедуры"

Последний раз редактировалось: Филипп Остырко; 09 Дек 2018, 18:02


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
92 Сообщений
LexaK
53 Сообщений
alexandr_ll
41 Сообщений
Yamuna
35 Сообщений
KOI8-R
30 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
BuhRust
21 Сообщений
DmitriyF DmitriyF
19 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений

* Кто онлайн

  • Точка Гостей: 575
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal