Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 04:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ОбновитьФайл  (Прочитано 3415 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Добрый вечер! Кто нибудь расскажите об этом подробно, нужна любая информация, хотя бы по человечески:

Если НЕ  (1)ПодключитьРасширениеРаботыСФайлами() Тогда
     (2)УстановитьРасширениеРаботыСФайлами();
КонецЕсли;
 
Если  ПодключитьРасширениеРаботыСФайлами() Тогда
     Иначе
     Предупреждение("Выполнение не поддерживается.Не установлено расширение работы с файлами.");
КонецЕсли;

(3)ЗапроситьРазрешениеПользователя()


Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Re: ОбновитьФайл
« Ответ #1: 11 Апр 2011, 17:03 »
Или хотя бы пример небольшой или схему чтобы было попонятнее

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Re: ОбновитьФайл
« Ответ #2: 11 Апр 2011, 17:58 »
Ауу, есть кто доброволец, нужна помощь по этому поводу! :( :(

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: ОбновитьФайл
« Ответ #3: 11 Апр 2011, 18:46 »
Что за шум, а драки нет?!
На русском же языке написано:
Если не выполнена функция подключение расширения файлов,
тогда его надо выполнить через функцию.
------------------------------------------------------------
Если НЕ  (1)ПодключитьРасширениеРаботыСФайлами() Тогда
     (2)УстановитьРасширениеРаботыСФайлами();
КонецЕсли;

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Re: ОбновитьФайл
« Ответ #4: 11 Апр 2011, 18:49 »
Если через функцию подклчить расширение работы с файлами, тогда делать неизвестно что,
Иначе будет выдано на экран предупрежение "Выполнение не поддерживается.Не установлено расширение работы с файлами."
-------------------------------------------------
Если  ПодключитьРасширениеРаботыСФайлами() Тогда
     Иначе
     Предупреждение("Выполнение не поддерживается.Не установлено расширение работы с файлами.");
КонецЕсли;
-----------------------------
Ну а потом будет запрошено разрешение у пользователя, естественно через функцию.
(3)ЗапроситьРазрешениеПользователя()

P.S. Сделают функции пользователей, а потом не знают как их "есть". А если бы на английском программировали? Что было бы тогда?

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Re: ОбновитьФайл
« Ответ #5: 12 Апр 2011, 09:15 »
откуда мне знать что это функция, я же не могу проверить, что в ней есть?

Оффлайн Maxim

  • ***
  • Сообщений: 248
  • РЕПУТАЦИЯ: 10
  • КПД: 4%
  • Регистрация: 2010-11-09
  • Сайт: 
Re: ОбновитьФайл
« Ответ #6: 12 Апр 2011, 13:59 »
Лады, разобрался и не только в этом. Можете закрыть.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 176
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal