Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Управление торговлей 11. Печать непроведенных документов  (Прочитано 19214 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sakustov

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Консультант 1С
Здравствуйте, уважаемые!

Подскажите, что сделать, чтобы можно было печатать ТОРГ12 на основании документа реализации без проведения?

спасибо!


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Отменить проверку проведенности документа.

Оффлайн sakustov

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Консультант 1С
Пробовал комментировать проверку проведенности документа. В итоге ругательств нет, но выходит пустой бланк. ничего не заполнено. Чистый лист...
Вы сами пробовали?

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1308
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
УТ 11 нет, но скорей всего если требует проведения документа и печатает пустой бланк, значит обращается к регистрам за данными. Хотя могу и ошибаться. Вобще в отладчике посмотри и узнаешь.

Оффлайн Slin

  • Глобальный модератор
  • *****
  • Сообщений: 780
  • РЕПУТАЦИЯ: 247
  • КПД: 32%
  • Game over...
  • Регистрация: 2010-10-13
  • Сайт: 
  • Профессия: Программист 1С
Так оно и есть.
Многие, если не все, процедуры печати документов берут данные из регистров, так как данные в регистрах считаются (самой фирмой 1С) наиболее верными.
Т.е. для печати надо не только отменять проверку проведенности, но и менять соответствующим образом саму процедуру проведения - источники данных.
skype: slin-dev

Оффлайн sakustov

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Консультант 1С
Команда ПечатьТорг12  убрать проверку проведенности + в модуле менеджера в функции СформироватьПечатнуюФормуТОРГ12 в запросе закомментировать пару раз проверку на проведенность.

В запросе вроде нет строк на проверку проведенности...

Оффлайн jeam

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-30
  • Сайт: 
  • Профессия: Программист 1С
Если нужна печать определенного документа, то можно сделать так:

Показано на примере Печати Заказа Клиента.
Открываем конфигуратор:
Документы -> ЗаказКлиента -> Команды -> ПечатьЗаказКлиента
Функция РольДоступнаНаСервере( ИмяРоли )

Возврат РольДоступна( ИмяРоли );

КонецФункции

// Процедура - обработчик события "ОбработкаКоманды".
//
&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)

Если РольДоступнаНаСервере( "ПолныеПрава" ) или
УправлениеПечатьюКлиент.ПроверитьДокументыПроведены(ПараметрКоманды, ПараметрыВыполненияКоманды.Источник) Тогда

УправлениеПечатьюКлиент.ВыполнитьКомандуПечати(
"Документ.ЗаказКлиента",
"ЗаказКлиента",
ПараметрКоманды,
Неопределено,
Неопределено
);

КонецЕсли;

КонецПроцедуры

Оффлайн Slaid

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-23
  • Сайт: 
  • Профессия: Ученик 1С
в 1С 8,2 Управление сервисным центром, есть в доп. настройках пользователя, разрешения для печати документов без проведения, может у вас такое же есть.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal