Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
10 Дек 2018, 15:33
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите создать справочник для сим карт  (Прочитано 95 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Влад Триханов

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-11-21
  • Сайт: 
1) Создал 2 справочника (Симкарт и СостоянияСимкарт) (рисунок 1)
2) нужно объединить в одну форму элемента (рисунок 2)
3) на рисунке 1 где таблица и ... при нажатие вводим ФИО,долг ,и выбор даты.
4) при нажатие любой строки - можно было ее изменить и так же удалить полностью
5) код модуля справочник симкарт
 
              //==============================================================================
Процедура ПриОткрытии()
симСостояние.Очистить();
симСостояние.НоваяКолонка("ДатаОперации",,,,"Дата операции",9);
симСостояние.НоваяКолонка("ДатаВыдачи",,,,"Дата Выдачи",20);
симСостояние.НоваяКолонка("Владелец",,,,"Владелец",20);
симСостояние.НоваяКолонка("Долг",,,,"Долг",20);
с = СоздатьОбъект("Справочник.СостоянияСимкарт");
с.ИспользоватьВладельца(ТекущийЭлемент());
с.ВыбратьЭлементы();
Пока с.ПолучитьЭлемент()=1 Цикл
Если с.ПометкаУдаления()=1 Тогда
Продолжить;
КонецЕсли;
тзВнести(симСостояние,"ДатаОперации",с.ДатаОперации,"ДатаВыдачи",СокрЛП(с.ДатаВыдачи),"Владелец",СокрЛП(с.Владелец),"Долг",СокрЛП(с.Долг),);
КонецЦикла;

КонецПроцедуры
//==============================================================================
Процедура Добавить()
   
    стр="";
Если ВвестиСтроку(стр,"Введите инфомацию по состоянию кпк",600) = 1 Тогда
с = СоздатьОбъект("Справочник.СостояниеСимкарт");
с.ИспользоватьВладельца(ТекущийЭлемент());
        Попытка
            с.Новый();
с.ДатаОперации = ТекущаяДата();
            с.Состояние = СокрЛП(стр);
с.Записать();
тзВнести(симСостояние,"ДатаОперации",с.ДатаОперации,"ДатаВыдачи",СокрЛП(с.ДатаВыдачи),"Владелец",СокрЛП(с.Владелец),"Долг",СокрЛП(с.Долг),);;
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;

КонецПроцедуры
//==============================================================================
Процедура Удалить()

Если симСостояние.ТекущаяСтрока()>0 Тогда
текДата = симСостояние.ПолучитьЗначение(симСостояние.ТекущаяСтрока(),"ДатаОперации");
текСостояние = СокрЛП(симСостояние.ПолучитьЗначение(симСостояние.ТекущаяСтрока(),"Состояние"));
с = СоздатьОбъект("Справочник.СостояниеСимкарт");
с.ИспользоватьВладельца(ТекущийЭлемент());
с.ВыбратьЭлементы();
Пока с.ПолучитьЭлемент()=1 Цикл
Если (с.ДатаОперации = текДата) и (СокрЛП(с.Состояние)=текСостояние) Тогда
Попытка
с.Удалить(0);
симСостояние.УдалитьСтроку(симСостояние.ТекущаяСтрока());
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
Прервать;
КонецЕсли;
КонецЦикла;
Иначе
Предупреждение("Выделете строку, которую нужно удалить!");
КонецЕсли;

КонецПроцедуры
//==============================================================================
Процедура ПриКликеПоСтроке()
Если симСостояние.ТекущаяСтрока()>0 Тогда
стр = СокрЛП(симСостояние.ПолучитьЗначение(симСостояние.ТекущаяСтрока(),"Состояние"));
текДата = симСостояние.ПолучитьЗначение(симСостояние.ТекущаяСтрока(),"ДатаОперации");
старСтр = стр;
Если ВвестиСтроку(стр,"Отредактируйте инфомацию по состоянию кпк",600) = 1 Тогда
с = СоздатьОбъект("Справочник.СостояниеСимкарт");
с.ИспользоватьВладельца(ТекущийЭлемент());
с.ВыбратьЭлементы();
Пока с.ПолучитьЭлемент()=1 Цикл
Если (с.ДатаОперации = текДата) и (СокрЛП(с.Состояние)=старСтр) Тогда
Попытка
с.Состояние = стр;
с.Записать();
симСостояние.УстановитьЗначение(симСостояние.ТекущаяСтрока(),"Состояние",СокрЛП(стр));
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЕсли;
КонецПроцедуры
//==============================================================================
помогите кому не сложно , где я сделал не так и не доработал


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
84 Сообщений
byte777
43 Сообщений
AIFrame AIFrame
40 Сообщений
alex0402
36 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
30 Сообщений
wise wise
26 Сообщений
alexandr_ll
26 Сообщений
LexaK
22 Сообщений
happynattion
22 Сообщений
antoneus
20 Сообщений

* Кто онлайн

  • Точка Гостей: 712
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal