Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Ноя 2018, 22:36
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите, не получается посчитать себестоимость по услугам, отдельно от товаров  (Прочитано 80 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nastyaru0898

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-11-08
  • Сайт: 
  • Профессия: Ученик 1С
Не считает себестоимость услуги, себестоимость товаров считает без проблем. По моему мнению, ошибка где-то в "Запросе", а где не знаю. Помогите как исправить

это общий модуль установки цен:


   Движения.ЦеныНоменклатуры.Записывать = Истина;
   Движения.СебестоимостьУслуги.Записывать = Истина;
   Для Каждого ТекСтрокаТовары Из Товары Цикл
      Если ТекСтрокаТовары.Номенклатура.Услуга = Ложь Тогда
         Движение = Движения.ЦеныНоменклатуры.Добавить();
         Движение.Период = Дата;
         Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
         Движение.Цена = ТекСтрокаТовары.Цена;
      Иначе
         Движение = Движения.СебестоимостьУслуги.Добавить();
         Движение.Период = Дата;
         Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
         Движение.Себестоимость = ТекСтрокаТовары.Цена;
      КонецЕсли;
   КонецЦикла;

Это часть модуля,а именно то, что отвечает за себестоимость услуги:
Иначе   

         Запрос = Новый Запрос ("ВЫБРАТЬ
                                |   СебестоимостьУслугиСрезПоследних.Номенклатура,
                                |   СебестоимостьУслугиСрезПоследних.Себестоимость,
                                |ИЗ
                                |   РегистрСведений.СебестоимостьУслуги.СрезПоследних КАК СебестоимостьУслугиСрезПоследних") ;
            Запрос.УстановитьПараметр("Дата",Дата);
            Запрос.УстановитьПараметр("Номенклатура", СтрокаИзДокумента.Номенклатура);
            
            
            Выборка = Запрос.Выполнить().Выбрать();
            Если Выборка.Следующий() Тогда
               СебестоимотьУслуги = Выборка.Себестоимость;
            Иначе
               СебестоимостьУслуги = 0;
            КонецЕсли;
            ОбщаяСебестоимость = СебестоимостьУслуги * СтрокаИзДокумента.Количество;


Оффлайн oleg-x

  • *****
  • Сообщений: 932
  • РЕПУТАЦИЯ: 216
  • КПД: 23%
  • Регистрация: 2016-11-02
  • Сайт: vk.com
  • Профессия: Программист 1С
         Запрос = Новый Запрос ("ВЫБРАТЬ
                                |   СебестоимостьУслугиСрезПоследних.Номенклатура,
                                |   СебестоимостьУслугиСрезПоследних.Себестоимость,
                                |ИЗ
                                |   РегистрСведений.СебестоимостьУслуги.СрезПоследних КАК СебестоимостьУслугиСрезПоследних") ;
            Запрос.УстановитьПараметр("Дата",Дата);
            Запрос.УстановитьПараметр("Номенклатура", СтрокаИзДокумента.Номенклатура);
Либо не полностью выложили, либо хрень полнейшая.
Параметры устанавливаете, но где эти параметры в самом запросе?
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Оффлайн wise

  • *****
  • Сообщений: 710
  • РЕПУТАЦИЯ: 97
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) может    РегистрСведений.СебестоимостьУслуги.СрезПоследних(&ВыбДата, Номенклатура = &ВыбНоменклатура)

Запрос.УстановитьПараметр("ВыбДата",Дата);
Запрос.УстановитьПараметр("ВыбНоменклатура", СтрокаИзДокумента.Номенклатура);
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4946
Последний ответ 24 Дек 2015, 15:34
от дфтын
На фото демонстрируется личная карточка сотрудника, но во столбце "ЗА ЯКИЙ ПЕРІОД " не показывает ничего, как это можно решить, помогите пожалуйста

Автор cBeginnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 327
Последний ответ 26 Июл 2018, 17:44
от alex0402
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 6207
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 6491
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5571
Последний ответ 10 Сен 2015, 13:57
от Dm109

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
73 Сообщений
AIFrame AIFrame
63 Сообщений
wise wise
50 Сообщений
alex0402
45 Сообщений
alexandr_ll
45 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
38 Сообщений
BuhRust
28 Сообщений
andron81_81
24 Сообщений
byte777
21 Сообщений
LexaK
21 Сообщений

* Кто онлайн

  • Точка Гостей: 263
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal