Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 21:42
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пометка в списке значений  (Прочитано 4169 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн inoifantom

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-03-25
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день! Помогите с простой задачкой.
Есть список значений. Код:
Для Каждого Элемент Из СписокЗданий Цикл
      Если  Элемент.Пометка Тогда
         ПолучитьДанные=Элемент.Значение;
         СсылкаНаЗдание=ПолучитьДанные.Ссылка;
         ОбъектЗдание=СсылкаНаЗдание.ПолучитьОбъект();
      КонецЕсли;
КонецЦикла;
Как сделать, чтобы если ни 1 элемент не помечен, пометились все элементы???
Спасибо.


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Счетчик = 0;
Для Каждого Элемент Из СписокЗданий Цикл
      Если  Элемент.Пометка Тогда
Счетчик = Счетчик +1;
         ПолучитьДанные=Элемент.Значение;
         СсылкаНаЗдание=ПолучитьДанные.Ссылка;
         ОбъектЗдание=СсылкаНаЗдание.ПолучитьОбъект();
      КонецЕсли;
КонецЦикла;

Если Счетчик = 0 тогда
Для Каждого Элемент Из СписокЗданий Цикл
//---- А тут помечаешь  всё
КонецЦикла;
КонецЕсли

P.S. Ну это первое что в голову пришло.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
А можно было Счетчик сделать булевым, тогда красивее получилось бы.

Оффлайн inoifantom

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-03-25
  • Сайт: 
  • Профессия: Разработчик 1С
Спасибо)

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Ну уж если действительно помог и желаете сказать "Спасибо", то достаточно клинкуть по ссылке "Сказать СПАСИБО".


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 685
Последний ответ 20 Мар 2018, 16:54
от alex0402
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1298
Последний ответ 15 Июн 2017, 07:53
от mvk843
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 22891
Последний ответ 13 Фев 2011, 17:36
от proofet
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6617
Последний ответ 28 Июл 2011, 23:55
от Dethmontt
1C ЗУП 2.5 Помогите с отчетом "Списки сотрудников организации" Объединение значений ячеек

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1397
Последний ответ 10 Фев 2017, 10:49
от ksander-fars

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Alter
29 Сообщений
Анюта17
29 Сообщений
ilyay ilyay
29 Сообщений

* Кто онлайн

  • Точка Гостей: 242
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal