Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 07:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Пометка в списке значений  (Прочитано 3795 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн inoifantom

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-03-25
  • Сайт: 
  • Профессия: Разработчик 1С
Добрый день! Помогите с простой задачкой.
Есть список значений. Код:
Для Каждого Элемент Из СписокЗданий Цикл
      Если  Элемент.Пометка Тогда
         ПолучитьДанные=Элемент.Значение;
         СсылкаНаЗдание=ПолучитьДанные.Ссылка;
         ОбъектЗдание=СсылкаНаЗдание.ПолучитьОбъект();
      КонецЕсли;
КонецЦикла;
Как сделать, чтобы если ни 1 элемент не помечен, пометились все элементы???
Спасибо.


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Счетчик = 0;
Для Каждого Элемент Из СписокЗданий Цикл
      Если  Элемент.Пометка Тогда
Счетчик = Счетчик +1;
         ПолучитьДанные=Элемент.Значение;
         СсылкаНаЗдание=ПолучитьДанные.Ссылка;
         ОбъектЗдание=СсылкаНаЗдание.ПолучитьОбъект();
      КонецЕсли;
КонецЦикла;

Если Счетчик = 0 тогда
Для Каждого Элемент Из СписокЗданий Цикл
//---- А тут помечаешь  всё
КонецЦикла;
КонецЕсли

P.S. Ну это первое что в голову пришло.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
А можно было Счетчик сделать булевым, тогда красивее получилось бы.

Оффлайн inoifantom

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2011-03-25
  • Сайт: 
  • Профессия: Разработчик 1С
Спасибо)

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Ну уж если действительно помог и желаете сказать "Спасибо", то достаточно клинкуть по ссылке "Сказать СПАСИБО".


Теги:
 

"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 750
Последний ответ 15 Июн 2017, 07:53
от mvk843
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 20756
Последний ответ 13 Фев 2011, 17:36
от proofet
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6223
Последний ответ 28 Июл 2011, 23:55
от Dethmontt
1C ЗУП 2.5 Помогите с отчетом "Списки сотрудников организации" Объединение значений ячеек

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1068
Последний ответ 10 Фев 2017, 10:49
от ksander-fars
Обход дерева значений на клиенте / развернуть многоуровневое дерево на клиенте

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5180
Последний ответ 01 Ноя 2015, 10:07
от Азиман

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 132
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal