Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 окт 2021, 13:44

Ошибка при вызове конструктора (COMObject)

Автор Анжела, 30 окт 2018, 04:25

0 Пользователей и 1 гость просматривают эту тему.

Анжела

Всем привет, ребята ошибка распространённая. Облазил все темы. Даже в гуголе до 10 страницы добрался ничего не помогает. Все перепробовал. Вот сама ошибка. База серверная
Конфигурация ИТИЛ 1С:ITIL. Управление информационными технологиями предприятия. ПРОФ, редакция 1.1. Версия платформы 1С:Предприятие 8.3 (8.3.10.2466). При выполнение ExcelApplication = Новый COMObject("Excel.Application");
Ошибка
{ВнешняяОбработка.ЗагрузкаЭлектроныхАдресовИзЭксель.Форма.Форма.Форма(4)}: Ошибка при вызове конструктора (COMObject)
  ExcelApplication = Новый COMObject("Excel.Application");
по причине:
-2147221005(0x800401F3): Недопустимая строка с указанием класса

Может кто подскажет что еще может быть, что еще можно сделать. Ну или хотябы вместе разберемся с этой проблемой.

alex0402

Цитата: Анжела от 30 окт 2018, 04:25Недопустимая строка с указанием класса
а чего в папке 7.7?
значит не установлен Excel. База какая? Файл,Сервер? Где выполняется код на сервере или на клиенте?
Спасибо за Сказать спасибо

Анжела

Случайно на счет 7.7
База сервер, код на севере.

     Сообщить("!!");
  ТЗ = Неопределено;
  //
  ExcelApplication = Новый COMObject("Excel.Application");
  ФайлЭксель = ExcelApplication.WorkBooks.Open(Адрес);
  ЛистЭксель = ФайлЭксель.Sheets(НомерЛиста);
  //
  Если ВсегоСтрок = 0 Тогда
  //
  ВсегоСтрок = ЛистЭксель.Cells.SpecialCells(11).Row;
  //
  КонецЕсли;
  //
  Если ВсегоКолонок = 0 Тогда
  //
  ВсегоКолонок = ЛистЭксель.Cells.SpecialCells(11).Column;
  //
  КонецЕсли;
 
  Если ТЗ = Неопределено Тогда
  //
  Область = ЛистЭксель.Range(ЛистЭксель.Cells(НомерПервойСтроки,НомерПервойКолонки), ЛистЭксель.Cells(ВсегоСтрок,ВсегоКолонок));
  Данные = Область.Value.Выгрузить();
  //
  ТЗ =  Новый ТаблицаЗначений;
  //
  Для Счетчик = 0 По ВсегоКолонок - 1 Цикл
  //
  ТЗ.Колонки.Добавить(Данные[счетчик][0], Новый ОписаниеТипов("Строка"));
  //
  КонецЦикла;
  //
  КонецЕсли;
 
  НомерПервойСтроки = 2;
  //
  Для Счетчик = НомерПервойСтроки По ВсегоСтрок Цикл
  //
  НоваяСтрока = ТЗ.Добавить();
  //
  КонецЦикла;
 
  Область = ЛистЭксель.Range(ЛистЭксель.Cells(НомерПервойСтроки,НомерПервойКолонки), ЛистЭксель.Cells(ВсегоСтрок,ВсегоКолонок));
  Данные = Область.Value.Выгрузить();
 
  Для Счетчик = 1 По ВсегоКолонок - 1 Цикл
  //
  ТЗ.ЗагрузитьКолонку(Данные[Счетчик], Счетчик);
  //
  КонецЦикла;
 
  ExcelApplication.DisplayAlerts = 0;
 
  ExcelApplication.Quit();
  ExcelApplication = Неопределено;
  //
  Возврат ТЗ;
  //

alex0402

Цитата: Анжела от 30 окт 2018, 08:58База сервер, код на севере.

Excel на сервере установлен?
Спасибо за Сказать спасибо

Анжела

Только глянул, на самом серваке не стоит.
Добавлено: 30 окт 2018, 09:09


Это может быть влиять на мою проблему?

AIFrame

Ну пока вместе с платформой 1С не будет поставляться свой чоткий Excel - да, тебе нужно, чтобы он стоял, чтобы его запустить :befhbt:

Анжела

На сервере стоит Эксель, проблему не решило

alexandr_ll

Цитата: Анжела от 13 ноя 2018, 05:10
На сервере стоит Эксель, проблему не решило
В файловой базе работает?

AIFrame

Цитата: Анжела от 13 ноя 2018, 05:10
На сервере стоит Эксель, проблему не решило
win+R
excel
- проверь, может у тебя его нет в окружении.

Анжела


Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск