Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 сен 2021, 04:40

Корректный вывод печатной формы во внешней обработке

Автор skillful, 27 окт 2018, 21:13

0 Пользователей и 1 гость просматривают эту тему.

skillful

Внешняя обработка. Код:
&НаКлиенте
Процедура РасчитатьВсех(Команда)

ТабДок = ГоЗаМакетомНаСервер();         

ТабДок.Показать();

КонецПроцедуры

&НаСервере
Функция ГоЗаМакетомНаСервер()     

Табдок = новый ТабличныйДокумент;
ТекОбъект = РеквизитФормыВЗначение("Объект");
Макет = ТекОбъект.ПолучитьМакет("Макет");     


ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
ОбластьМакета.Параметры.ТекстЗаголовка = "Заголовок";
ТабДок.Вывести(ОбластьМакета);

Возврат Табдок;
Конецфункции 


При нажатии на кнопку выводит как в экселе с номерами столбцов и строк.(Screenshot_1).

А как сделать, чтоб нормально выводилась печ. форма?? (Screenshot_2)

alexandr_ll

ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;

skillful

Цитата: alexandr_ll от 28 окт 2018, 08:35
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;


Это понятно, что можно скрыть сетку и заголовки. Но интересуют именно кнопки печати, предпросмотра и т .д., т. е. все кнопки которые на скриншоте №2.

alexandr_ll

Цитата: skillful от 28 окт 2018, 17:04
Цитата: alexandr_ll от 28 окт 2018, 08:35
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;


Это понятно, что можно скрыть сетку и заголовки. Но интересуют именно кнопки печати, предпросмотра и т .д., т. е. все кнопки которые на скриншоте №2.
Создайте на форме реквизит типа "Табличный документ" и полученную печатную форму выводите в него, кнопки будут на форме.

skillful

Цитата: alexandr_ll от 28 окт 2018, 18:40
Цитата: skillful от 28 окт 2018, 17:04
Цитата: alexandr_ll от 28 окт 2018, 08:35
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;


Это понятно, что можно скрыть сетку и заголовки. Но интересуют именно кнопки печати, предпросмотра и т .д., т. е. все кнопки которые на скриншоте №2.
Создайте на форме реквизит типа "Табличный документ" и полученную печатную форму выводите в него, кнопки будут на форме.
Можно поподробнее. Как полученную печатную форму выводить в него?

alexandr_ll

Цитата: skillful от 28 окт 2018, 19:12
Цитата: alexandr_ll от 28 окт 2018, 18:40
Цитата: skillful от 28 окт 2018, 17:04
Цитата: alexandr_ll от 28 окт 2018, 08:35
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Истина;


Это понятно, что можно скрыть сетку и заголовки. Но интересуют именно кнопки печати, предпросмотра и т .д., т. е. все кнопки которые на скриншоте №2.
Создайте на форме реквизит типа "Табличный документ" и полученную печатную форму выводите в него, кнопки будут на форме.
Можно поподробнее. Как полученную печатную форму выводить в него?

&НаКлиенте
Процедура РасчитатьВсех(Команда)
    ГоЗаМакетомНаСервер();         
КонецПроцедуры

&НаСервере
Процедура ГоЗаМакетомНаСервер()     

    Табдок = новый ТабличныйДокумент;
    ТекОбъект = РеквизитФормыВЗначение("Объект");
    Макет = ТекОбъект.ПолучитьМакет("Макет");     

   
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка = "Заголовок";
    ТабДок.Вывести(ОбластьМакета);
    // "Результат" - имя реквизита на форме с типом "Табличный документ"
    Результат = ТабДок;
КонецПроцедуры 

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск