Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 сен 2021, 05:32

Подскажите как посчитать

Автор Yuran9393, 21 окт 2018, 18:38

0 Пользователей и 1 гость просматривают эту тему.

Yuran9393

Вообщем надо посчитать сумму. При изменении цены пересчет суммы. А при изменении суммы пересчет цены.
Подскажите как реализовать?
Код снизу пробую (и не могу понять как сделать чтобы оба условия выполнялись).
//   Если  СтрокаТЧ.Количество*СтрокаТЧ.Цена       Тогда
//         СтрокаТЧ.Сумма=СтрокаТЧ.Количество*СтрокаТЧ.Цена;
//КонецЕсли;
   Если СтрокаТЧ.Количество*СтрокаТЧ.Цена <> СтрокаТЧ.Сумма Тогда
       СтрокаТЧ.Цена=СтрокаТЧ.Сумма/СтрокаТЧ.Количество;
КонецЕсли;

Golickoff

Сделай две разных процедуры: одну при изменении цены и вторую при изменении суммы.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Yuran9393

Для суммы:
На клиенте
Процедура ТоварыСуммаПриИзменении(Элемент)
ТекущиеДанные=Элементы.Товары.ТекущиеДанные;
ТекущиеДанные.Сумма=ТекущиеДанные.Количество*ТекущиеДанные.Цена;
КонецПроцедуры;

Так?


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск