Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2018, 11:03
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как уменьшить шрифт в макете программно в зависимости от кол-ва символов. УПП  (Прочитано 149 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kiksi

  • ***
  • Сообщений: 133
  • РЕПУТАЦИЯ: 4
  • КПД: 3%
  • Новичок в программировании 1С,сильно не ругайте =)
  • Регистрация: 2012-02-27
  • Сайт: 
  • Профессия: Консультант 1С
Как можно в макете печатной формы при выводе комментария из документа уменьшать шрифт в ячейке в зависимости от кол-ва символов,  то есть если комментарий длинный, то шрифт уменьшить, чтобы поместился в ячейке :dfbbdrfb:


Оффлайн barabambler

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-09-30
  • Сайт: 
  • Профессия: Ученик 1С
Если Условие1 Тогда
    МойШрифт = новый шрифт(,НужныйРазмер);
Иначе
    МойШрифт = новый шрифт(,НужныйРазмер);
КонецЕсли;

Область.ТекущаяОбласть.Шрифт = МойШрифт;

//В таком ключе

Оффлайн kiksi

  • ***
  • Сообщений: 133
  • РЕПУТАЦИЯ: 4
  • КПД: 3%
  • Новичок в программировании 1С,сильно не ругайте =)
  • Регистрация: 2012-02-27
  • Сайт: 
  • Профессия: Консультант 1С
Вышла из положения пока так:

ДлинаНаименования1    = СтрДлина(ОбластьМакета.Параметры.КомментарийКладовщикам1);
   ДлинаНаименования2    = СтрДлина(ОбластьМакета.Параметры.КомментарийКладовщикам2);
   
Если ДлинаНаименования1 > 50 Тогда
ОбластьМакета.Область("КомментарийКладовщикам1").Шрифт = Новый Шрифт(ОбластьМакета.Область("КомментарийКладовщикам1").Шрифт,, 7,Ложь);
     Иначе ОбластьМакета.Область("КомментарийКладовщикам1").Шрифт = Новый Шрифт(ОбластьМакета.Область("КомментарийКладовщикам1").Шрифт,, 9,Ложь);
  КонецЕсли;
Если ДлинаНаименования2 > 50 Тогда
          ОбластьМакета.Область("КомментарийКладовщикам2").Шрифт = Новый Шрифт(ОбластьМакета.Область("КомментарийКладовщикам2").Шрифт,, 7,Ложь);
     Иначе ОбластьМакета.Область("КомментарийКладовщикам2").Шрифт = Новый Шрифт(ОбластьМакета.Область("КомментарийКладовщикам2").Шрифт,, 9,Ложь);
  КонецЕсли;


 

Программно открыть отчет скд и отчет подключенный как внешний отчет

Автор 1ckaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4868
Последний ответ 02 Фев 2015, 10:06
от 1cka
Как открыть программно открыть форму контрагента?

Автор VzonderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2843
Последний ответ 18 Янв 2017, 12:32
от sertak
Программно добавить "Содержание" в товарную часть

Автор Артур СРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 1575
Последний ответ 02 Окт 2016, 17:22
от Артур С
"Доступ к информационной базе разрешен" программно

Автор 12040Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1720
Последний ответ 10 Янв 2017, 10:20
от LexaK
Как программно открыть форму и закрыть с записью, чтобы отработал метод перед записью

Автор con2rРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6076
Последний ответ 13 Июн 2017, 12:17
от Whisper

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
78 Сообщений
wise wise
39 Сообщений
AIFrame AIFrame
39 Сообщений
alex0402
38 Сообщений
byte777
35 Сообщений
alexandr_ll
33 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
26 Сообщений
LexaK
24 Сообщений
happynattion
22 Сообщений
antoneus
20 Сообщений

* Кто онлайн

  • Точка Гостей: 756
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal