Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Окт 2018, 01:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема с отображением картинок на веб-клиенте.  (Прочитано 93 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nikam0811

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-21
  • Сайт: 
  • Профессия: Программист 1С
Доброго времени суток,

Имеется управляемая форма номенклатуры в самописной УТ 10.3. На форме есть список номенклатуры, слева от списка имеется поле картинки в которое выводится основное изображение активной номенклатуры. На тонком клиенте все работает без вопросов, но в веб-клиенте начинаются неполадки. При нажатии ПКМ на картинке (картинка отображается в поле) и выборе стандартных функций из выпадающего окна ("Просмотреть картинку", "Сохранить_как") открывается пустое окно, без картинки, либо же выдает ошибку "Неправильный путь к файлу 'e1cib/convertPicture?sysver=8.3.10.2561&interfaceVar=16&scale=100'"
На тонком клиенте эти функции работают нормально.

Код:

&НаКлиенте
Процедура ПоказатьКартинку() Экспорт
   
   ТекЗначение = Элементы.Список.ТекущаяСтрока;
   Если ТекЗначение <> Неопределено Тогда
      СтруктураДанныхКартинки = ПолучитьДанныеКартинки(ТекЗначение);
      Если СтруктураДанныхКартинки.Свойство("НавигационнаяСсылка") = Истина Тогда
         ФотоНоменклатуры = СтруктураДанныхКартинки.НавигационнаяСсылка;
      Иначе
         ФотоНоменклатуры = "";
      КонецЕсли;
      Элементы.ФотоНоменклатуры.Обновить();   


   КонецЕсли;   
   
КонецПроцедуры   

&НаСервере
Функция ПолучитьДанныеКартинки(СсылкаНаНоменклатуру)
   
   УстановитьПривилегированныйРежим(Истина);
   
   ДанныеКартинки = Новый Структура;
   
   Если не СсылкаНаНоменклатуру.ЭтоГруппа Тогда
      ДанныеКартинки.Вставить("НавигационнаяСсылка", ПоместитьВоВременноеХранилище(СсылкаНаНоменклатуру.ОсновноеИзображение.Хранилище.Получить(),
                                    УникальныйИдентификатор));
                                    
   КонецЕсли;
   Возврат ДанныеКартинки;
   
   КонецФункции


Оффлайн Геннадий ОбьГЭС

  • Консультант - программист 1С - решу или поговорю об 1С круглосуточно
  • *****
  • Сообщений: 2469
  • РЕПУТАЦИЯ: 111
  • КПД: 4%
  • Проблемы учета или 1С круглосуточно
  • Регистрация: 2015-03-12
  • Сайт: nsk1c.wordpress.com
  • Профессия: Программист 1С
Доброго времени суток,

Имеется управляемая форма номенклатуры в самописной УТ 10.3. На форме есть список номенклатуры, слева от списка имеется поле картинки в которое выводится основное изображение активной номенклатуры. На тонком клиенте все работает без вопросов, но в веб-клиенте начинаются неполадки. При нажатии ПКМ на картинке (картинка отображается в поле) и выборе стандартных функций из выпадающего окна ("Просмотреть картинку", "Сохранить_как") открывается пустое окно, без картинки, либо же выдает ошибку "Неправильный путь к файлу 'e1cib/convertPicture?sysver=8.3.10.2561&interfaceVar=16&scale=100'"
На тонком клиенте эти функции работают нормально
Что такое тонкий клиент на УТ 10.3????
Режиме совместимости с версией 8.2.13 выставлен?
Версия УТ 10.3 какая?
Геннадий
(Консультант 1С - программист  1C - бухгалтер 1С - индивидуальный тренер / преподаватель по минимальным ценам. Внедрение, настройка учета, помощь в организации бизнеса )

Оффлайн nikam0811

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-21
  • Сайт: 
  • Профессия: Программист 1С
Что такое тонкий клиент на УТ 10.3????
Режиме совместимости с версией 8.2.13 выставлен?
Версия УТ 10.3 какая?

Версия 10.3.3.3
Режим совместимости выставлен на 8.2.16
В тонком и веб-клиенте запускаю одну из подсистем, вся УТ не переписывалась под управляемые формы.


 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1468
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5469
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3546
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3806
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4106
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
85 Сообщений
alexandr_ll
69 Сообщений
MuI_I_Ika MuI_I_Ika
53 Сообщений
wise wise
43 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
LexaK
35 Сообщений
byte777
35 Сообщений
alex0402
29 Сообщений
Каримдат Каримдат
21 Сообщений
АлександрВладимирович
19 Сообщений

* Кто онлайн

  • Точка Гостей: 141
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal