Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Май 2018, 19:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: проблема с доступностью  (Прочитано 1879 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alexsey777

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2010-10-15
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте!
Мой вопрос может показаться тупым, но я только осваиваю 1с. Вопрос такой. На форме имеется поле ввода и флажок. Нужно сделать так, что если флажок стоит то поле ввода доступно для редактирования, а если его нет, то данное поле недоступно.


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Как два пальцо обо...ать....

Процедура НМАПриИзменении(Элемент)
Если ЭлементыФормы.НМА.Значение = Ложь Тогда
ЭлементыФормы.Панель1.Страницы["НМА"].Видимость = Ложь;
Иначе
ЭлементыФормы.Панель1.Страницы["НМА"].Видимость = Истина;
КонецЕсли;
КонецПроцедуры

Можете этот код чуть-чуть подправить для своей задачи.

Оффлайн alexsey777

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 1
  • КПД: 3%
  • Регистрация: 2010-10-15
  • Сайт: 
  • Профессия: Программист 1С
Как два пальцо обо...ать....

Процедура НМАПриИзменении(Элемент)
Если ЭлементыФормы.НМА.Значение = Ложь Тогда
ЭлементыФормы.Панель1.Страницы["НМА"].Видимость = Ложь;
Иначе
ЭлементыФормы.Панель1.Страницы["НМА"].Видимость = Истина;
КонецЕсли;
КонецПроцедуры

Можете этот код чуть-чуть подправить для своей задачи.
Спасибо. Но только это не совсем то. Элемент не надо совсем скрывать. Нужно сделать его недоступным для выбора.

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Спасибо. Но только это не совсем то. Элемент не надо совсем скрывать. Нужно сделать его недоступным для выбора.
Дак его подправить надо
Процедура НМАПриИзменении(Элемент)
Если ЭлементыФормы.НМА.Значение = Ложь Тогда
ЭлементыФормы.Панель1.Страницы["НМА"].Доступность = Ложь;
Иначе
ЭлементыФормы.Панель1.Страницы["НМА"].Доступность = Истина;
КонецЕсли;
КонецПроцедуры

Оффлайн has

  • Модератор
  • *****
  • Сообщений: 1310
  • РЕПУТАЦИЯ: 285
  • КПД: 22%
  • Регистрация: 2011-01-28
  • Сайт: 
  • Профессия: Программист 1С
Так лучше
Процедура НМАПриИзменении(Элемент)
ЭлементыФормы.Панель1.Страницы["НМА"].Доступность = ЭлементыФормы.НМА.Значение;
КонецПроцедуры
ну только на свои переменные заменить


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1381
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5297
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3124
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3679
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3995
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
153 Сообщений
oleg-x
69 Сообщений
alex0402
65 Сообщений
AIFrame AIFrame
55 Сообщений
wise wise
39 Сообщений
buketov.av buketov.av
36 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
27 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 321
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal