Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2018, 05:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Право добавлять теги в карточке контрагента  (Прочитано 77 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн S.Boev

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-07-25
  • Сайт: 
  • Профессия: Ученик 1С
Всех приветствую!
Подскажите, пожалуйста, новичку, как сделать так, чтобы в карточке контрагента устанавливать и менять теги могли только некоторые пользователи?

Пишу:
&НаСервере
Процедура ПриИзмененииРеквизитовНаСервере()
Если ПараметрыСеанса.ТекущийПользователь <> Пользователи.НайтиПоИмени("Иванов Иван") Тогда
Объект.Теги = Объект.Теги.ТолькоПросмотр;
Объект.ПолеВводаТега = Объект.ПолеВводаТега.ТолькоПросмотр;
КонецЕсли;
КонецПроцедуры

Это не работает. Если впихиваю этот код в ПроцедуруПриЗаписи, то никто, кроме Иванова Ивана не может нажать кнопку Записать, выдаёт ошибку про теги.

1С:Предприятие 8.3 (8.3.12.1469)
УНФ 1.6 (1.6.15.55)


Оффлайн Sy4a

  • **
  • Сообщений: 90
  • РЕПУТАЦИЯ: 17
  • КПД: 19%
  • Регистрация: 2015-07-16
  • Сайт: 
  • Профессия: Программист 1С
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если не РольДоступна("ПолныеПрава") тогда
    Объект.Теги = Объект.Теги.ТолькоПросмотр;
    Объект.ПолеВводаТега = Объект.ПолеВводаТега.ТолькоПросмотр;
КонецЕсли;
КонецПРоцедуры;
Где "ПолныеПрава" название роли. Либо создайте свою роль хоть без всяких прав доступа просто раздайте людям тем кто должен мочь ну или выберите из имеющихся. также можно написать запрос и посмотреть группу прав доступа у текущего пользователя и уж от неё плясать. Я такие вещи обычно пишу только туда куда обычным смертным дорога закрыта, поэтому у меня и проверка на "ПолныеПрава"
и да это всё у меня прописано в событиях формы "При создании на сервере". можно и в подписку запихнуть и проверять при записи чтобы не править типовой функционал.

Оффлайн S.Boev

  • *
  • Сообщений: 14
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-07-25
  • Сайт: 
  • Профессия: Ученик 1С
Sy4a, благодарю, но...
у пользователя с ПолнымиПравами всё норм, а вот остальных даже в карточку не пускает с ошибкой "Поле объекта не обнаружено (ТолькоПросмотр)".
Я так думаю неправильно прописан путь к полю что-ли. В общем, буду пробовать.
Добавлено: 14 Сен 2018, 00:10

В общем, по-другому решил сделать, код вообще не стал писать.
Надо было мне более полно описать задачу...
Идея в том, чтобы выводить какие-то важные стикеры о контрагенте в документе ЗаказПокупателя (VIP-клиент, 100% предоплата и т.п.).
Вывел ячейку Теги в ЗаказПокупателя – убрал всё лишнее, поставил им ТолькоПросмотр, а в карточке контрагента для поля Теги установил видимость только для определённой роли (на видимость в ЗаказеПокупателя это никак не повлияло – видят все).

Последний раз редактировалось: S.Boev; 14 Сен 2018, 00:10. Причина: Объединение сообщений


Теги: теги права 
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alexandr_ll
59 Сообщений
alex0402
49 Сообщений
AIFrame AIFrame
42 Сообщений
MuI_I_Ika MuI_I_Ika
30 Сообщений
LexaK
29 Сообщений
wise wise
29 Сообщений
Каримдат Каримдат
25 Сообщений
Sy4a
19 Сообщений
Golickoff Golickoff
18 Сообщений
BuhRust
18 Сообщений

* Кто онлайн

  • Точка Гостей: 160
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal