Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Сен 2018, 04:20
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запись значения в Реквизит  (Прочитано 261 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн alex0402

  • *****
  • Сообщений: 1650
  • РЕПУТАЦИЯ: 287
  • КПД: 17%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Подскажите пожалуйста, можно ли сделать поиск среди всех справочников?
нет.
Можно
Справочники[Имя].НайтиПоНаименованию(Значение)
или

Для каждого Спр Из Метаданные.Справочники Цикл
    ЗначениеПоиска = Справочники[Спр.Имя].НайтиПоНаименованию(Значение);
    Если Не ЗначениеПоиска.Пустая() Тогда
        Прервать;
    КонецЕсли;
КонецЦикла;

но для данного случая это не правильно.
Спасибо за Сказать спасибо


Оффлайн Malum

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-11
  • Сайт: 
  • Профессия: Программист 1С
Подскажите пожалуйста, можно ли сделать поиск среди всех справочников?
нет.
Можно
Справочники[Имя].НайтиПоНаименованию(Значение)
или

Для каждого Спр Из Метаданные.Справочники Цикл
    ЗначениеПоиска = Справочники[Спр.Имя].НайтиПоНаименованию(Значение);
    Если Не ЗначениеПоиска.Пустая() Тогда
        Прервать;
    КонецЕсли;
КонецЦикла;

но для данного случая это не правильно.

Спасибо. Первый метод помог.
Хотелось бы узнать, как я могу добавить строку в табличной части документа и параллельно ее заполнять.
               
НовЭлем = Справочники[ТипРек].НайтиПоНаименованию(ЗнчРек);
НовДок[ИмяТаб][Счет][ИмяРек] = НовЭлем;

ИмяТаб - это имя таблицы документа.
Счет - номер строки (по крайней мере должен ей быть)
ИмяРек - Имя реквизита табличной части

Выдает ошибку, "Индекс находится за границами массива". Вероятнее всего ругается на счетчик.

Оффлайн alex0402

  • *****
  • Сообщений: 1650
  • РЕПУТАЦИЯ: 287
  • КПД: 17%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Я обычно делаю так:
НоваяСтрка = НовДок[ИмяТаб].Добавить();
НоваяСтрка[ИмяРек] = НовЭлем;

Выдает ошибку, "Индекс находится за границами массива". Вероятнее всего ругается на счетчик.

Предварительно нужно вызвать:
НовДок[ИмяТаб].Добавить()
Счет+1 раз.
Спасибо за Сказать спасибо

Оффлайн Malum

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-11
  • Сайт: 
  • Профессия: Программист 1С
Я обычно делаю так:
НоваяСтрка = НовДок[ИмяТаб].Добавить();
НоваяСтрка[ИмяРек] = НовЭлем;

Выдает ошибку, "Индекс находится за границами массива". Вероятнее всего ругается на счетчик.

Предварительно нужно вызвать:
НовДок[ИмяТаб].Добавить()
Счет+1 раз.
Обращение к строке я делаю правильное? Я смогу таким образом, после добавления, вписать значения в другие реквизиты?

Оффлайн alex0402

  • *****
  • Сообщений: 1650
  • РЕПУТАЦИЯ: 287
  • КПД: 17%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
правильно, только строк должно быть как минимум Счет+1 на момент обращения
Спасибо за Сказать спасибо

Оффлайн Malum

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-11
  • Сайт: 
  • Профессия: Программист 1С
правильно, только строк должно быть как минимум Счет+1 на момент обращения
Привет, еще раз нужна помощь. С тем разобрался, благодаря тебе.
У меня есть текстовый файл, там указано Имя реквизита. Его тип и значение.

ОтражениеВУСН
Перечисление.ОтражениеВУСН
Принимаются

Типа такого. Так вот.. Со справочником я разобрался, а здесь не могу понять, как мне это все объединить и засунуть в реквизит в таблице. Как мне эти строки привести к нужному типу?

Оффлайн alex0402

  • *****
  • Сообщений: 1650
  • РЕПУТАЦИЯ: 287
  • КПД: 17%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
ОтражениеВУСН
Перечисление.ОтражениеВУСН
Принимаются

точно так же
Перечисления["ОтражениеВУСН"]["Принимаются"]
Спасибо за Сказать спасибо

Оффлайн Malum

  • *
  • Сообщений: 9
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-11
  • Сайт: 
  • Профессия: Программист 1С
ОтражениеВУСН
Перечисление.ОтражениеВУСН
Принимаются

точно так же
Перечисления["ОтражениеВУСН"]["Принимаются"]

Так, хорошо, а если документ ссылается на другой документ

ДокументПартии
Документ.ПоступлениеТоваровУслуг
Поступление (акт, накладная) КП00-000017 от 03.02.2016 12:50:27

В текстовом файле это выглядит так. Первая строка имя реквизита. Вторая его тип. Третья - значение реквизита.
Должно быть что то типа
Документы[Тип].Найтичтото ?


Теги: помощь 8.3  
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 553
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1350
Последний ответ 11 Июл 2016, 09:00
от vitasw
Реквизит "ГоловнойКонтрагент" в справочнике "Контрагенты"

Автор SergWolf07Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 8030
Последний ответ 28 Авг 2011, 19:12
от SergWolf07
Как сложить значения Столбца "Объем"

Автор anton.kislovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 16099
Последний ответ 04 Май 2017, 10:48
от ospov11789
Ошибка "Итератор для значения не определён"

Автор КараулРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1209
Последний ответ 17 Авг 2016, 11:25
от Караул

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alexandr_ll
59 Сообщений
alex0402
49 Сообщений
AIFrame AIFrame
42 Сообщений
MuI_I_Ika MuI_I_Ika
30 Сообщений
LexaK
29 Сообщений
wise wise
29 Сообщений
Каримдат Каримдат
25 Сообщений
Sy4a
19 Сообщений
BuhRust
18 Сообщений
Golickoff Golickoff
18 Сообщений

* Кто онлайн

  • Точка Гостей: 163
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal