Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Ноя 2018, 22:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Условия для текущего пользователя  (Прочитано 227 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн aNDYsm

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-09
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите пож-та, как определить текущего пользователя?
Нужно что определенным пользователям выходили свои сообщения.
Прописал в модуле управления

Процедура ПриНачалеРаботыСистемы()
   
      Если ПараметрыСеанса.ТекущийПользователь = ("КузнецовАВ") тогда
      Сообщить("В начале месяца прошу предоставить акт сверки")
      КонецЕсли;
      
КонецПроцедуры

Выдает ошибку
МодульУправляемогоПриложения(91,8)}: Переменная не определена (ПараметрыСеанса)
      Если <<?>>ПараметрыСеанса.ТекущийПользователь = ("КузнецовАВ") тогда (Проверка: Тонкий клиент)




Оффлайн Golickoff

  • ****
  • Сообщений: 432
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Программист 1С
К параметрам сеанса нужно обращаться на стороне сервера.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн aNDYsm

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-09
  • Сайт: 
  • Профессия: Ученик 1С
К параметрам сеанса нужно обращаться на стороне сервера.

Простите, можно чуть подробнее как именно прописать?

Оффлайн Golickoff

  • ****
  • Сообщений: 432
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Программист 1С
Создайте процедуру/функцию с директивой &НаСервере и проверяйте имя пользователя внутри этой процедуры/функции.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн aNDYsm

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-09
  • Сайт: 
  • Профессия: Ученик 1С
Создайте процедуру/функцию с директивой &НаСервере и проверяйте имя пользователя внутри этой процедуры/функции.

&НаКлиенте
Процедура ПриНачалеРаботыСистемы()
   
   ПриНачалеРаботыСистемыНаша();
      
КонецПроцедуры

&НаСервере
Процедура ПриНачалеРаботыСистемыНаша()
         
   Если сокрлп(ПользователиИнформационнойБазы.ТекущийПользователь().Имя)="КузнецовАВ" тогда
      
      Сообщить("В начале месяца прошу предоставить акт сверки");
      
   Конецесли;
         
КонецПроцедуры

Ругается что
 Процедура или функция с указанным именем не определена (ПриНачалеРаботыСистемыНаша)
   <<?>>ПриНачалеРаботыСистемыНаша(); (Проверка: Тонкий клиент)


Оффлайн alex0402

  • *****
  • Сообщений: 1713
  • РЕПУТАЦИЯ: 303
  • КПД: 18%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Ругается что
 Процедура или функция с указанным именем не определена (ПриНачалеРаботыСистемыНаша)
   <<?>>ПриНачалеРаботыСистемыНаша(); (Проверка: Тонкий клиент)

из модуля приложения нельзя обратиться на сервер. Нужно создать общий модуль с галочками сервер и вызов сервера и засунуть все это туда...
Спасибо за Сказать спасибо

Оффлайн aNDYsm

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-09
  • Сайт: 
  • Профессия: Ученик 1С
Ругается что
 Процедура или функция с указанным именем не определена (ПриНачалеРаботыСистемыНаша)
   <<?>>ПриНачалеРаботыСистемыНаша(); (Проверка: Тонкий клиент)

из модуля приложения нельзя обратиться на сервер. Нужно создать общий модуль с галочками сервер и вызов сервера и засунуть все это туда...

Получилось так

Создан общий модуль "ПоказатьПользователя"

&НаСервере
Процедура ПриНачалеРаботыСистемыНаша()
      
   Если сокрлп(ПользователиИнформационнойБазы.ТекущийПользователь().Имя)="КузнецовАВ" тогда
   Сообщить("В начале месяца прошу предоставить акт сверки");
   Конецесли;
            
КонецПроцедуры

А в модуле управления прописано

&НаКлиенте
Процедура ПриНачалеРаботыСистемы()
   
   ПоказатьПользователя.ПриНачалеРаботыСистемыНаша();
      
КонецПроцедуры

Но пишет так же ошибку
Переменная не определена (ПоказатьПользователя)
   <<?>>ПоказатьПользователя.ПриНачалеРаботыСистемыНаша(); (Проверка: Тонкий клиент)



Оффлайн LexaK

  • *****
  • Сообщений: 1473
  • РЕПУТАЦИЯ: 413
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
можно без всей этой свистопляски с общими модулями обойтись
просто используйте функцию

Глобальный контекст (Global context)
ИмяПользователя (UserName)
Синтаксис:
ИмяПользователя()
Возвращаемое значение:
Тип: Строка.
Имя пользователя.
Описание:
Получает имя пользователя, указанного при запуске программы.

Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Пример:
ТекущийПользователь = ИмяПользователя();
 
Помогло? - Нажми СПАСИБО!!!
                       :)

Оффлайн aNDYsm

  • *
  • Сообщений: 5
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-09-09
  • Сайт: 
  • Профессия: Ученик 1С
можно без всей этой свистопляски с общими модулями обойтись
просто используйте функцию

Глобальный контекст (Global context)
ИмяПользователя (UserName)
Синтаксис:
ИмяПользователя()
Возвращаемое значение:
Тип: Строка.
Имя пользователя.
Описание:
Получает имя пользователя, указанного при запуске программы.

Доступность:
Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Пример:
ТекущийПользователь = ИмяПользователя();

Извиняюсь за наглость, куда это все вписывать?

Оффлайн LexaK

  • *****
  • Сообщений: 1473
  • РЕПУТАЦИЯ: 413
  • КПД: 28%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
да это можно использовать в самой первой вашей процедуре
Процедура ПриНачалеРаботыСистемы()
   
      //Если ПараметрыСеанса.ТекущийПользователь = ("КузнецовАВ") тогда
      Если ИмяПользователя() = "КузнецовАВ" Тогда //и все, ни каких общих модулей с серверами
      Сообщить("В начале месяца прошу предоставить акт сверки")
      КонецЕсли;
     
КонецПроцедуры
Помогло? - Нажми СПАСИБО!!!
                       :)


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
52 Сообщений
alexandr_ll
46 Сообщений
alex0402
44 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
29 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 255
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal