Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 21:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку. Как вывести элементы из справочника в отчет?  (Прочитано 5144 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nestov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-07
  • Сайт: 
  • Профессия: Программист 7.7
вот в чем проблема:
выводит только "шапку", а "строка" - пуста :(

-создал справочник "сотрудники"; ввел элементы(фамилия, имя, должность)
-создал отчет "сотрудники"
-в отчет->Таблица выделил "шапку" (фамилия, имя), и "строка" (фамилия, имя)
-прописал в модуле:
"Процедура Сформировать()
   
   спр=создатьобъект("справочник.сотрудники");   
              Таб=создатьобъект ("таблица");
           Таб.вывестиСекцию ("шапка");
                     таб.вывестисекцию("строка");
           Таб.толькопросмотр(1);
           таб.показать("");
КонецПроцедуры"


Оффлайн Mitay_D

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 14
  • КПД: 16%
  • Регистрация: 2011-02-02
  • Сайт: 
  • Профессия: Программист 7.7
а где цикл?
Процедура Сформировать()
       Спр = СоздатьОбъект("Справочник.сотрудники");
      Спр.ВыбратьЭлементы();
    Таб.вывестиСекцию ("шапка");
      Пока Спр.ПолучитьЭлемент() = 1 Цикл
         таб.вывестисекцию("строка");
      КонецЦикла;
КонецПроцедуры

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1377
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Совет!
Обучаться лучше на версии 8.2. И перспектив больше и место более хлебное.

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
ну эт там в Москвах, а по России можно сильно оспорить

Оффлайн Nestov

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-07
  • Сайт: 
  • Профессия: Программист 7.7
Спасибо. 7.7 у меня просто в универе преподают, да и если обучусь нормально, то во время учебы в универе буду подрабатывать на 7.7


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
161 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
Alter
29 Сообщений
Анюта17
29 Сообщений
ilyay ilyay
29 Сообщений

* Кто онлайн

  • Точка Гостей: 265
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal