Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Окт 2018, 04:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как чаще создаются отчеты: с помощью конструктора или набираются вручную?  (Прочитано 202 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн zork265

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-21
  • Сайт: 
Как чаще создаются отчеты: с помощью конструктора или набираются вручную?


Оффлайн alex0402

  • *****
  • Сообщений: 1672
  • РЕПУТАЦИЯ: 295
  • КПД: 18%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Как чаще создаются отчеты: с помощью конструктора или набираются вручную?

СКД
Спасибо за Сказать спасибо

Онлайн AIFrame

  • *****
  • Сообщений: 1135
  • РЕПУТАЦИЯ: 139
  • КПД: 12%
  • Регистрация: 2015-07-22
  • Сайт: 
Как чаще создаются отчеты: с помощью конструктора или набираются вручную?
Как чаще делается Торг-12: через формирование печатной формы или ручкой и линейкой?

Оффлайн zork265

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-21
  • Сайт: 
Я понимаю что тут собралось достаточно много крутых профи которые понимают шифры и прочие хитрые выражения. Но все же интересует понятный для начинающего ответ.

Оффлайн alex0402

  • *****
  • Сообщений: 1672
  • РЕПУТАЦИЯ: 295
  • КПД: 18%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Я понимаю что тут собралось достаточно много крутых профи которые понимают шифры и прочие хитрые выражения. Но все же интересует понятный для начинающего ответ.

СКД - Система компоновки данных. Я чаще всего использую СКД. Особенно для чисто информативных запросов без всяких изысков. Удобно тем, что составил запрос, настроил вариант вывода информации и готово... в т.ч. расшифровки данных.
Спасибо за Сказать спасибо

Оффлайн zork265

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-21
  • Сайт: 
СКД - Система компоновки данных. Я чаще всего использую СКД. Особенно для чисто информативных запросов без всяких изысков. Удобно тем, что составил запрос, настроил вариант вывода информации и готово... в т.ч. расшифровки данных.
Согласен с вами, конструктором отчеты делать гораздо удобней. Вопрос возник потому, что я сейчас на стадии изучения того, как создаются отчеты. И вот в некоторых книгах по программированию 1с целые большие главы посвящены тому как отчеты писать вручную. Вот и решил спросить. А так ли это важно делать отчеты вручную. ) Конструктор поудобней будет. )

Онлайн AIFrame

  • *****
  • Сообщений: 1135
  • РЕПУТАЦИЯ: 139
  • КПД: 12%
  • Регистрация: 2015-07-22
  • Сайт: 
Конструктор не умеет _.*, конструктор не умеет "" + переменная + "".

Оффлайн zork265

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-08-21
  • Сайт: 
Конструктор не умеет _.*, конструктор не умеет "" + переменная + "".

Видимо кодить отчеты вручную нужно только в особых случаях? Часто бывают такие случаи?

Онлайн AIFrame

  • *****
  • Сообщений: 1135
  • РЕПУТАЦИЯ: 139
  • КПД: 12%
  • Регистрация: 2015-07-22
  • Сайт: 
Нет.
Добавлено: 29 Авг 2018, 22:39

Никто не заставляет такое писать руками. Собрал конструктором один вариант, разбавил переменными.
Например, ты хочешь получить все реквизиты объектов справочника функцией, указав какой-то отбор. Ну, предположим, что нет у тебя другого варианта. И второе условие - справочники будут разные, а функция должна быть одна.
Ты можешь - перебрать все варианты, на каждый сделать запрос. Получится длинная простыня текста.
А можешь:
&НаСервере
Процедура Тест()

СтруктураПараметров = Новый Структура;
ГруппаРеквизита = Справочники.СтруктураСети.НайтиПоКоду("000000001"); // какаято-группа
СтруктураПараметров.Вставить("Наименование", "%.1.113");
СтруктураПараметров.Вставить("ГруппаРеквизита", ГруппаРеквизита);
СтрокаУсловия = "ГДЕ
| _.Наименование ПОДОБНО &Наименование
| И _.Ссылка В ИЕРАРХИИ (&ГруппаРеквизита)";

Выборка = ПолучитьДанныеПоСправочнику("СтруктураСети", СтрокаУсловия, СтруктураПараметров);
Если Выборка.Следующий() Тогда
Сообщить(Выборка.Ссылка);
// Запрос вернул ссылку на 192.168.1.113
Иначе
Сообщить("Запрос вернул ничего");
КонецЕсли;

КонецПроцедуры

&НаСервере
Функция ПолучитьДанныеПоСправочнику(ИмяСправочника, СтрокаУсловия = "", СтруктураПараметров = неопределено)
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | _.*
    |ИЗ
    | Справочник."+ИмяСправочника+" КАК _
|"+СтрокаУсловия;
Если ТипЗнч(СтруктураПараметров) = Тип("Структура") Тогда
Для Каждого Параметр из СтруктураПараметров Цикл
Запрос.УстановитьПараметр(Параметр.Ключ, Параметр.Значение);
КонецЦикла;
КонецЕсли;
Возврат Запрос.Выполнить().Выбрать();
КонецФункции

Последний раз редактировалось: AIFrame; 29 Авг 2018, 22:39. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

AIFrame AIFrame
86 Сообщений
alexandr_ll
70 Сообщений
MuI_I_Ika MuI_I_Ika
49 Сообщений
wise wise
38 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
37 Сообщений
byte777
35 Сообщений
LexaK
34 Сообщений
alex0402
29 Сообщений
Каримдат Каримдат
21 Сообщений
АлександрВладимирович
18 Сообщений

* Кто онлайн

  • Точка Гостей: 176
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal