Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Мар 2021, 08:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ошибка "Поле объекта не обнаружено" при записи табл.части документа "ОперацияБух"  (Прочитано 2355 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Q37

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2018-08-05
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Документ ОперацияБух, у которого в табличной части содержатся таблицы регистров и сведений.
Нужно достать все значения, которые там присутствуют. Вот такой код:
	ДокументОбъект = ВыбранныйДокумент.ПолучитьОбъект();
Для Каждого НаборЗаписей Из ДокументОбъект.Движения Цикл
Сообщить(НаборЗаписей);
НаборЗаписей.Прочитать();
для каждого измерение из НаборЗаписей.Метаданные().Измерения цикл
Сообщить(НаборЗаписей[измерение.Имя]);
конецЦикла;
конецЦикла;
но выводится ошибка "Поле объекта не обнаружено (имя измерения)"
И впринципе я понимаю, что так пишется, потому что у конкретно этого документа его нет, но как мне получить то, что есть ? все данные, которые касаются нужного документа ?
Подскажите пожалуйста!


Оффлайн бухг123

  • *
  • Сообщений: 42
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2012-03-22
  • Сайт: 
  • Профессия: Бухгалтер
Думаю так проще увидеть все записи в документе ОперацияБух


    НаборЗаписей = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Регистратор.Установить(Объект.Докум); //Документ ОперацияБух
    НаборЗаписей.Прочитать();
    Если НаборЗаписей.Количество()>0 Тогда
        ТЗ = НаборЗаписей.Выгрузить();
        Для СтрокаТЗ=0 По ТЗ.Количество()-1 Цикл
            Для КолТЗ=0 По ТЗ.Колонки.Количество()-1 Цикл
                Сообщить("Строка № "+СтрокаТЗ+1+""". Реквизит табличной части: """+ТЗ.Колонки[КолТЗ].Заголовок + """ со значением: "+?(ЗначениеЗаполнено(ТЗ[СтрокаТЗ][ТЗ.Колонки[КолТЗ].Имя]), ТЗ[СтрокаТЗ][ТЗ.Колонки[КолТЗ].Имя], "Не заполненно значение..."));
            КонецЦикла;
        КонецЦикла;
        Сообщить("Есть записи!");
    Иначе
        Сообщить("Нет записей!");
    КонецЕсли;

Оффлайн Q37

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 2
  • КПД: 6%
  • Регистрация: 2018-08-05
  • Сайт: 
  • Профессия: Ученик 1С
Думаю так проще увидеть все записи в документе ОперацияБух


    НаборЗаписей = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Регистратор.Установить(Объект.Докум); //Документ ОперацияБух
    НаборЗаписей.Прочитать();
    Если НаборЗаписей.Количество()>0 Тогда
        ТЗ = НаборЗаписей.Выгрузить();
        Для СтрокаТЗ=0 По ТЗ.Количество()-1 Цикл
            Для КолТЗ=0 По ТЗ.Колонки.Количество()-1 Цикл
                Сообщить("Строка № "+СтрокаТЗ+1+""". Реквизит табличной части: """+ТЗ.Колонки[КолТЗ].Заголовок + """ со значением: "+?(ЗначениеЗаполнено(ТЗ[СтрокаТЗ][ТЗ.Колонки[КолТЗ].Имя]), ТЗ[СтрокаТЗ][ТЗ.Колонки[КолТЗ].Имя], "Не заполненно значение..."));
            КонецЦикла;
        КонецЦикла;
        Сообщить("Есть записи!");
    Иначе
        Сообщить("Нет записей!");
    КонецЕсли;


Спасибо большое за помощь!


Теги:  ошибка 
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6567
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Создание диалога(Да/Нет) и создание документа с проведением

Автор kolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 11049
Последний ответ 17 Дек 2014, 07:59
от has
Закрытие месеца, ошибка при закрытие 26сч

Автор GendelfРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 5777
Последний ответ 26 Июл 2013, 11:00
от Gendelf
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1705
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4340
Последний ответ 30 Сен 2011, 20:01
от gorbach178500

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
104 Сообщений
antoneus antoneus
30 Сообщений
Алексей_1985_06
29 Сообщений
LexaK
24 Сообщений
BuhRust
18 Сообщений
ls600 ls600
17 Сообщений
kah
13 Сообщений
DNN
12 Сообщений
DmitriyF DmitriyF
10 Сообщений
Ивашка
9 Сообщений

* Кто онлайн

  • Точка Гостей: 124
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal