Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
25 Апр 2019, 16:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: выгрузка в excel  (Прочитано 229 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andrig

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-12-19
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, что прописать, чтоб не заполнялись строки,если сч.фактуры у Приходной нет.

Процедура КнопкаСформироватьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    Макет = ПолучитьМакет("Макет");
   
   
    ВыборкаЧ =  Документы.ПоступлениеТоваровУслуг.Выбрать(НачалоДня(НачДата),КонецДня(КонДата));
    Пока ВыборкаЧ.Следующий() Цикл
       
        Если Не(ВыборкаЧ.Проведен) Тогда
            Продолжить;
        КонецЕсли;
        ОбластьНоменклатура = Макет.ПолучитьОбласть("Стр99");
       
        ДокСФ = Документы.СчетФактураПолученный.Выбрать(НачалоДня(НачДата),КонецДня(КонДата));
       
        Для каждого Стр из ВыборкаЧ.Товары  Цикл
           
            Пока ДокСФ.Следующий() Цикл
               
                Если  ДокСФ.ДокументОснование.Ссылка = ВыборкаЧ.Ссылка Тогда   
                   
                    Прервать;
                Иначе
                    ///////   
                   
                   
                КонецЕсли;                                         
            КонецЦикла;
           
            ОбластьНоменклатура.Параметры.НомерНакладной = ВыборкаЧ.НомерВходящегоДокумента;
            ОбластьНоменклатура.Параметры.ДатаНакладной  = ВыборкаЧ.ДатаВходящегоДокумента;
            ОбластьНоменклатура.Параметры.Номенкл        = Стр.Номенклатура;


Оффлайн buketov.av

  • ***
  • Сообщений: 162
  • РЕПУТАЦИЯ: 8
  • КПД: 5%
  • смутные...
  • Регистрация: 2017-07-10
    • Skype: buketov.av
  • Сайт: 
  • Профессия: Разработчик 1С
Re: выгрузка в excel
« Ответ #1: 13 Авг 2018, 12:47 »
чет не могу связать заголовок темы и Ваше сообщение в теме. Поясните, пожалуйста.

Оффлайн Golickoff

  • ****
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Регистрация: 2015-02-05
  • Сайт: 
  • Профессия: Программист 1С
Re: выгрузка в excel
« Ответ #2: 16 Авг 2018, 02:19 »
Цитировать
ДокСФ = Документы.СчетФактураПолученный.Выбрать(НачалоДня(НачДата),КонецДня(КонДата));
       
        Для каждого Стр из ВыборкаЧ.Товары  Цикл
           
            Пока ДокСФ.Следующий() Цикл
               
                Если  ДокСФ.ДокументОснование.Ссылка = ВыборкаЧ.Ссылка Тогда   
                   
                    Прервать;
                Иначе
                    ///////   
                КонецЕсли;                                 
          КонецЦикла;
А если у нас холдинг с тысячами документов в день?
Запрос = Новый Запрос("ВЫБРАТЬ
| СчетФактура.Ссылка КАК Ссылка
|ИЗ
| Документ.СчетФактура КАК СчетФактура
|ГДЕ
| СчетФактураВыданный.ДокументОснование = &Ссылка");
Запрос.УстановитьПараметр("Ссылка", ВыборкаЧ.Ссылка);
По аналогии приведите к нормальному виду первую выборку, разберитесь с левым соединением и будет вам счастье.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5638
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3420
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 10004
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
выгрузка в УПП через Конвертацию "Проведение документа: Платежное поручение исходящее Не совпадают сумма документа и ее расшифровка"

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 395
Последний ответ 03 Янв 2019, 00:00
от Св Ч
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1428
Последний ответ 11 Май 2016, 13:23
от Rasty

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
81 Сообщений
AIFrame AIFrame
46 Сообщений
alexandr_ll
37 Сообщений
alex0402
29 Сообщений
wise wise
21 Сообщений
BuhRust
15 Сообщений
pavl_vs
14 Сообщений
byte777
14 Сообщений
Weidermail
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 674
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal