Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Авг 2018, 01:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: выгрузка в excel  (Прочитано 91 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн andrig

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2016-12-19
  • Сайт: 
  • Профессия: Ученик 1С
Подскажите, что прописать, чтоб не заполнялись строки,если сч.фактуры у Приходной нет.

Процедура КнопкаСформироватьНажатие(Кнопка)
    // Вставить содержимое обработчика.
    Макет = ПолучитьМакет("Макет");
   
   
    ВыборкаЧ =  Документы.ПоступлениеТоваровУслуг.Выбрать(НачалоДня(НачДата),КонецДня(КонДата));
    Пока ВыборкаЧ.Следующий() Цикл
       
        Если Не(ВыборкаЧ.Проведен) Тогда
            Продолжить;
        КонецЕсли;
        ОбластьНоменклатура = Макет.ПолучитьОбласть("Стр99");
       
        ДокСФ = Документы.СчетФактураПолученный.Выбрать(НачалоДня(НачДата),КонецДня(КонДата));
       
        Для каждого Стр из ВыборкаЧ.Товары  Цикл
           
            Пока ДокСФ.Следующий() Цикл
               
                Если  ДокСФ.ДокументОснование.Ссылка = ВыборкаЧ.Ссылка Тогда   
                   
                    Прервать;
                Иначе
                    ///////   
                   
                   
                КонецЕсли;                                         
            КонецЦикла;
           
            ОбластьНоменклатура.Параметры.НомерНакладной = ВыборкаЧ.НомерВходящегоДокумента;
            ОбластьНоменклатура.Параметры.ДатаНакладной  = ВыборкаЧ.ДатаВходящегоДокумента;
            ОбластьНоменклатура.Параметры.Номенкл        = Стр.Номенклатура;


Оффлайн buketov.av

  • ***
  • Сообщений: 110
  • РЕПУТАЦИЯ: 8
  • КПД: 7%
  • смутные...
  • Регистрация: 2017-07-10
    • Skype: buketov.av
  • Сайт: 
  • Профессия: Разработчик 1С
Re: выгрузка в excel
« Ответ #1: 13 Авг 2018, 12:47 »
чет не могу связать заголовок темы и Ваше сообщение в теме. Поясните, пожалуйста.


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5043
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3107
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 9516
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1247
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1494
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

AIFrame AIFrame
98 Сообщений
LexaK
72 Сообщений
alex0402
72 Сообщений
alexandr_ll
51 Сообщений
byte777
29 Сообщений
Alex26
28 Сообщений
ilyay ilyay
25 Сообщений
DialogVM
25 Сообщений
Sy4a
24 Сообщений
Вадим Ф Вадим Ф
23 Сообщений

* Кто онлайн

  • Точка Гостей: 162
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal