Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
08 Апр 2020, 17:09
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите решить задачу по 1С  (Прочитано 1022 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн AIFrame

  • *****
  • Сообщений: 1395
  • РЕПУТАЦИЯ: 183
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
ДатаВывода = НачалоМесяца(ДатаВвода);
Если ДатаВывода = Дата(1, 1, 1) Тогда
ПоказатьПредупреждение(,"Не введена дата!");
Возврат;
КонецЕсли;

Пока Месяц(ДатаВывода) = Месяц(ДатаВвода) Цикл
    СтрокаВывода = "" + СтрокаВывода + День(ДатаВывода) + ", ";
    ДатаВывода = КонецДня(ДатаВывода) + 1;
КонецЦикла;

Если СтрДлина(СтрокаВывода) > 1 Тогда
    СтрокаВывода = Лев(СтрокаВывода, СтрДлина(СтрокаВывода) - 2);
КонецЕсли;

ПоказатьПредупреждение(,СтрокаВывода);


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
66 Сообщений
LexaK
53 Сообщений
alexandr_ll
30 Сообщений
Алексей Рожков Алексей Рожков
20 Сообщений
antoneus antoneus
19 Сообщений
Musulmanin
18 Сообщений
Varg . Varg .
17 Сообщений
Алексей_1985_06
13 Сообщений
DmitriyF DmitriyF
12 Сообщений
wise wise
10 Сообщений

* Кто онлайн

  • Точка Гостей: 494
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal