Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Сен 2019, 14:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите решить задачу по 1С  (Прочитано 843 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Мишка_777

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-07-28
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет:)

Помогите пожалуйста решить задачу по 1С. Никак не получается написать код с требуемым результатом.<_<

Вот задание;
Интерактивно введите дату, выведите в окно сообщений каждый день месяца, дата
которого была задана.

Буду благодарен даже за подсказку.:D

Спасибо


Оффлайн AIFrame

  • *****
  • Сообщений: 1396
  • РЕПУТАЦИЯ: 182
  • КПД: 13%
  • Регистрация: 2015-07-22
  • Сайт: 
  • Профессия: Программист 1С
ДатаВывода = НачалоМесяца(ДатаВвода);
Если ДатаВывода = Дата(1, 1, 1) Тогда
ПоказатьПредупреждение(,"Не введена дата!");
Возврат;
КонецЕсли;

Пока Месяц(ДатаВывода) = Месяц(ДатаВвода) Цикл
    СтрокаВывода = "" + СтрокаВывода + День(ДатаВывода) + ", ";
    ДатаВывода = КонецДня(ДатаВывода) + 1;
КонецЦикла;

Если СтрДлина(СтрокаВывода) > 1 Тогда
    СтрокаВывода = Лев(СтрокаВывода, СтрДлина(СтрокаВывода) - 2);
КонецЕсли;

ПоказатьПредупреждение(,СтрокаВывода);

Оффлайн Мишка_777

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2018-07-28
  • Сайт: 
  • Профессия: Ученик 1С
ДатаВывода = НачалоМесяца(ДатаВвода);
Если ДатаВывода = Дата(1, 1, 1) Тогда
ПоказатьПредупреждение(,"Не введена дата!");
Возврат;
КонецЕсли;

Пока Месяц(ДатаВывода) = Месяц(ДатаВвода) Цикл
    СтрокаВывода = "" + СтрокаВывода + День(ДатаВывода) + ", ";
    ДатаВывода = КонецДня(ДатаВывода) + 1;
КонецЦикла;

Если СтрДлина(СтрокаВывода) > 1 Тогда
    СтрокаВывода = Лев(СтрокаВывода, СтрДлина(СтрокаВывода) - 2);
КонецЕсли;

ПоказатьПредупреждение(,СтрокаВывода);

Спасибо большое. Работает)))
Добавлено: 28 Июл 2018, 10:12

Есть еще одна задача, которую я так и не смог решить

Пусть имеется адресная строка http://lenta.ru/news/2013/10/02/betterkittens/. Выведите в
окно сообщений каждое слово разделенное флешем.

Сможете помочь)?

Последний раз редактировалось: Мишка_777; 28 Июл 2018, 10:12. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
92 Сообщений
LexaK
53 Сообщений
alexandr_ll
41 Сообщений
Yamuna
35 Сообщений
KOI8-R
30 Сообщений
Funt432286
23 Сообщений
antoneus antoneus
22 Сообщений
BuhRust
21 Сообщений
DmitriyF DmitriyF
19 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений

* Кто онлайн

  • Точка Гостей: 578
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal