Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 00:28

Как получить ссылку на справочник

Автор Hanri, 13 июл 2018, 18:03

0 Пользователей и 1 гость просматривают эту тему.

Hanri

Имеется справочник Номенклатура. В нем есть один из реквизитов "Вес".
Также создана Общая форма для подсчета веса всех товаров.
В данной форме есть Реквизит "Товары" с типом Таблица значений, в котором есть столбец Товар с типом СправочникСсылка.Номенклатура.

Уже многими способами пыталась получить ссылку на сервере, чтобы передать значение Веса на клиент.
Не знаю, нужно ли передавать какие-то параметры на сервер в функции ПолучитьВес() и как именно получить на сервере ссылку на товар.

&НаКлиенте
Процедура ТоварыПриИзменении(Элемент) 
Для Каждого Стр Из Товары Цикл
ЭтаФорма.ОбщийВес = ЭтаФорма.ОбщийВес + ПолучитьВес(...);
КонецЦикла;
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьВес(...)
Возврат текСсылка.Вес;
КонецФункции


Hanri


Каримдат

Опишите, каким способом удалось получить вес?)

Hanri

Вот так:

&НаКлиенте
Процедура ПолучениеВеса()
текДанные = ЭтаФорма.ТекущийЭлемент.ТекущиеДанные;
текВес = ПолучитьВес(текДанные.Товар);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьВес(текСсылка)
Возврат текСсылка.Вес;
КонецФункции             

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск