Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Ноя 2018, 23:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При попытке соединения с COM-сервером произошла следующая ошибка  (Прочитано 1766 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
скинь как ты подключаешься? что написал ?


Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
скинь как ты подключаешься? что написал ?
В8 = Новый COMОбъект("V83.COMConnector.1");
    ПутьКБазе = "File=""E:\Distr\Базы1С\блокировка документа"";Usr=""Администратор"";Pwd=""19911972"";";
            Попытка
                Соединение = В8.Connect(ПутьКБазе);
Сообщить("Ошибка создания объекта "+В8+" !") ;
Сообщить(ОписаниеОшибки()) ;
            Исключение
               // Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()) + " база ", СтатусСообщения.Важное);
            КонецПопытки;   
           // Соединение = "";
           // В8 = ""
Если использовать весь твой код ,то вообще ничего не выдает.

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Попытка                 Соединение = В8.Connect(ПутьКБазе); Сообщить("Ошибка создания объекта "+В8+" !") ; Сообщить(ОписаниеОшибки()) ;

)))))) если не выдает то подключение удачно прошло, а если выдаст ошибку то не смог подключится, убери из попытки описание ошибки, а мой код раскоментируй

Добавлено: 17 Июл 2018, 13:25

если после попытки в режиме отладки когда идешь переходит после подключения сразу к концу попытки то все удачно, от этого и пляши, делай в своем документа так

Последний раз редактировалось: Alex26; 17 Июл 2018, 13:25. Причина: Объединение сообщений

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Попытка                 Соединение = В8.Connect(ПутьКБазе); Сообщить("Ошибка создания объекта "+В8+" !") ; Сообщить(ОписаниеОшибки()) ;

)))))) если не выдает то подключение удачно прошло, а если выдаст ошибку то не смог подключится, убери из попытки описание ошибки, а мой код раскоментируй

Добавлено: 17 Июл 2018, 13:25

если после попытки в режиме отладки когда идешь переходит после подключения сразу к концу попытки то все удачно, от этого и пляши, делай в своем документа так
Да, соединение установлено!
Но, как теперь грамотно прописать это в моём коде)
Перем СтрокаПодключения;

Если СтруктураПараметров = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;

ПараметровДостаточно = МодульЦемзавод.ОпределитьДостаточностьПараметровДляПодключенияКИнформационнойБазе(СтруктураПараметров, СтрокаПодключения, СтрокаСообщенияОбОшибке);

Если Не ПараметровДостаточно Тогда
Возврат Неопределено;
КонецЕсли;

Если СтруктураПараметров.СерверныйРежим Тогда
ПараметрыПодключения = "Srvr=""" + СокрЛП(СтруктураПараметров.ИмяСервера) + """; Ref=""" + СокрЛП(СтруктураПараметров.ИмяБазы) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
Иначе
ПараметрыПодключения = "File=""" + СокрЛП(СтруктураПараметров.ПутьКБазе) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
КонецЕсли;


Попытка
//#Если Клиент Тогда
//Состояние("Идет процесс соединения ...");
Сообщить("Идет процесс соединения ...");
//#КонецЕсли


Попытка
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда
Обработчик = Новый COMОбъект("V82.COMConnector");
Иначе
Обработчик = Новый COMОбъект("V83.COMConnector");
КонецЕсли;
Исключение
Сообщить("Ошибка создания объекта "+Обработчик+" !") ;
Сообщить(ОписаниеОшибки()) ;
КонецПопытки;


ТекCOMОбъект = Обработчик.Connect(ПараметрыПодключения);

//#Если Клиент Тогда
//Состояние("Соединение установлено");
Сообщить("Соединение установлено");
//#КонецЕсли

Исключение

СтрокаСообщенияОбОшибке = "При попытке соедиения с COM-сервером произошла следующая ошибка:" + Символы.ПС
+ ОписаниеОшибки();
//#Если Клиент Тогда
Сообщить(СтрокаСообщенияОбОшибке, СтатусСообщения.Важное);
    //Состояние("Соединение установить не удалось");
//Состояние();
    Сообщить("Соединение установить не удалось");
//#КонецЕсли

Возврат Неопределено;

КонецПопытки;

Возврат ТекCOMОбъект;
Чтоб грамотно отрабатывало

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Ты только к одной базе подключаться собираешься или нескольким?

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Ты только к одной базе подключаться собираешься или нескольким?
Только к одной, файловой.

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Во первых добавь .1 в комконекторе пусть все отрабатывает перед строкой ТекCOMОбъект = Обработчик.Connect вставь ту строку подключения по которой у тебя удачно прошло подключение в скобке ТекCOMОбъект = Обработчик.Connect(ПутьКБазе) попробуй так просто незнаю что у теб она делает

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Во первых добавь .1 в комконекторе пусть все отрабатывает перед строкой ТекCOMОбъект = Обработчик.Connect вставь ту строку подключения по которой у тебя удачно прошло подключение в скобке ТекCOMОбъект = Обработчик.Connect(ПутьКБазе) попробуй так просто незнаю что у теб она делает
Попытка
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда
Обработчик = Новый COMОбъект("V82.COMConnector.1");
Иначе
Обработчик = Новый COMОбъект("V83.COMConnector.1");
КонецЕсли;
Исключение
Сообщить("Ошибка создания объекта "+Обработчик+" !") ;
Сообщить(ОписаниеОшибки()) ;
КонецПопытки;

ПутьКБазе = "File=""E:\Distr\Базы1С\блокировка документа"";Usr=""Администратор"";Pwd=""19911972"";";
//ТекCOMОбъект = Обработчик.Connect(ПараметрыПодключения);
ТекCOMОбъект = Обработчик.Connect(ПутьКБазе);

//#Если Клиент Тогда
//Состояние("Соединение установлено");
Сообщить("Соединение установлено");
//#КонецЕсли
И нихрена, база не обнаружена.
Тут он просто подключается к ней, а затем при записи документов, он их передаёт, по этому соединению.

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Во первых добавь .1 в комконекторе пусть все отрабатывает перед строкой ТекCOMОбъект = Обработчик.Connect вставь ту строку подключения по которой у тебя удачно прошло подключение в скобке ТекCOMОбъект = Обработчик.Connect(ПутьКБазе) попробуй так просто незнаю что у теб она делает
Попытка
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда
Обработчик = Новый COMОбъект("V82.COMConnector.1");
Иначе
Обработчик = Новый COMОбъект("V83.COMConnector.1");
КонецЕсли;
Исключение
Сообщить("Ошибка создания объекта "+Обработчик+" !") ;
Сообщить(ОписаниеОшибки()) ;
КонецПопытки;

ПутьКБазе = "File=""E:\Distr\Базы1С\блокировка документа"";Usr=""Администратор"";Pwd=""19911972"";";
//ТекCOMОбъект = Обработчик.Connect(ПараметрыПодключения);
ТекCOMОбъект = Обработчик.Connect(ПутьКБазе);

//#Если Клиент Тогда
//Состояние("Соединение установлено");
Сообщить("Соединение установлено");
//#КонецЕсли
И нихрена, база не обнаружена.

Напиши код как я тебе скинул не поросто коннект а попытку добавь и исключения так же все сделай
Тут он просто подключается к ней, а затем при записи документов, он их передаёт, по этому соединению.
Добавлено: 17 Июл 2018, 14:11

Закоментируй код при соединении где комконектор и ТекCOMОбъект = Обработчик.Connect вставь мой код только не так как ты его исправил а изначально

Последний раз редактировалось: Alex26; 17 Июл 2018, 14:11. Причина: Объединение сообщений

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Во первых добавь .1 в комконекторе пусть все отрабатывает перед строкой ТекCOMОбъект = Обработчик.Connect вставь ту строку подключения по которой у тебя удачно прошло подключение в скобке ТекCOMОбъект = Обработчик.Connect(ПутьКБазе) попробуй так просто незнаю что у теб она делает
Попытка
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда
Обработчик = Новый COMОбъект("V82.COMConnector.1");
Иначе
Обработчик = Новый COMОбъект("V83.COMConnector.1");
КонецЕсли;
Исключение
Сообщить("Ошибка создания объекта "+Обработчик+" !") ;
Сообщить(ОписаниеОшибки()) ;
КонецПопытки;

ПутьКБазе = "File=""E:\Distr\Базы1С\блокировка документа"";Usr=""Администратор"";Pwd=""19911972"";";
//ТекCOMОбъект = Обработчик.Connect(ПараметрыПодключения);
ТекCOMОбъект = Обработчик.Connect(ПутьКБазе);

//#Если Клиент Тогда
//Состояние("Соединение установлено");
Сообщить("Соединение установлено");
//#КонецЕсли
И нихрена, база не обнаружена.

Напиши код как я тебе скинул не поросто коннект а попытку добавь и исключения так же все сделай
Тут он просто подключается к ней, а затем при записи документов, он их передаёт, по этому соединению.
Добавлено: 17 Июл 2018, 14:11

Закоментируй код при соединении где комконектор и ТекCOMОбъект = Обработчик.Connect вставь мой код только не так как ты его исправил а изначально
Вообще всё лишнее закомментил, оставил только то, что работало по кнопке, но нихрена, ошибка та же
Функция ПодключитсяКИнформационнойБазе2(СтруктураПараметров, СтрокаСообщенияОбОшибке = "") Экспорт 

//Перем СтрокаПодключения;
//
//Если СтруктураПараметров = Неопределено Тогда
// Возврат Неопределено;
//КонецЕсли;
//
//ПараметровДостаточно = МодульЦемзавод.ОпределитьДостаточностьПараметровДляПодключенияКИнформационнойБазе(СтруктураПараметров, СтрокаПодключения, СтрокаСообщенияОбОшибке);
//
//Если Не ПараметровДостаточно Тогда
// Возврат Неопределено;
//КонецЕсли;
//
//Если СтруктураПараметров.СерверныйРежим Тогда
// ПараметрыПодключения = "Srvr=""" + СокрЛП(СтруктураПараметров.ИмяСервера) + """; Ref=""" + СокрЛП(СтруктураПараметров.ИмяБазы) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
//Иначе
// ПараметрыПодключения = "File=""" + СокрЛП(СтруктураПараметров.ПутьКБазе) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
//КонецЕсли;
//
// //Попытка
// //#Если Клиент Тогда
// //Состояние("Идет процесс соединения ...");
// Сообщить("Идет процесс соединения ...");
// //#КонецЕсли


//Попытка
В8 = Новый COMОбъект("V83.COMConnector.1");
    ПутьКБазе = "File=""C:\Users\1\Documents\InfoBase11"";Usr=""Администратор"";Pwd=""1"";";
            Попытка
                Соединение = В8.Connect(ПутьКБазе);
            Исключение
                Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()) + " база ", СтатусСообщения.Важное);
            КонецПопытки;   
            Соединение = "";
            В8 = "";

// Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда
// Обработчик = Новый COMОбъект("V82.COMConnector.1");
// Иначе
// Обработчик = Новый COMОбъект("V83.COMConnector.1");
// КонецЕсли;
//Исключение
// Сообщить("Ошибка создания объекта "+Обработчик+" !") ;
// Сообщить(ОписаниеОшибки()) ;
//КонецПопытки;

// ПутьКБазе = "File=""E:\Distr\Базы1С\блокировка документа"";Usr=""Администратор"";Pwd=""19911972"";";
////ТекCOMОбъект = Обработчик.Connect(ПараметрыПодключения);
//ТекCOMОбъект = Обработчик.Connect(ПутьКБазе);

//#Если Клиент Тогда
//Состояние("Соединение установлено");
//общить("Соединение установлено");
//#КонецЕсли

//Исключение
//
// СтрокаСообщенияОбОшибке = "При попытке соедиения с COM-сервером произошла следующая ошибка:" + Символы.ПС
// + ОписаниеОшибки();
// //#Если Клиент Тогда
// Сообщить(СтрокаСообщенияОбОшибке, СтатусСообщения.Важное);
//     //Состояние("Соединение установить не удалось");
// //Состояние();
//     Сообщить("Соединение установить не удалось");
// //#КонецЕсли
//
// Возврат Неопределено;
//
//КонецПопытки;
//
//Возврат ТекCOMОбъект;

КонецФункции


Теги:
 

Ошибка "Неправильный псевдоним "Т.Ссылка" <<?>> Т.Ссылка как номенклатура"

Автор Андрей БулановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 214
Последний ответ 13 Окт 2018, 21:51
от Андрей Буланов
При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5315
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7088
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5102
Последний ответ 28 Апр 2014, 15:53
от maskito
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 131
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
52 Сообщений
alexandr_ll
46 Сообщений
alex0402
44 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
29 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 284
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal