Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Ноя 2018, 23:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При попытке соединения с COM-сервером произошла следующая ошибка  (Прочитано 1765 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?


Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
для примера создай кнопку, напиши в ней
 В8 = Новый COMОбъект("V83.COMConnector.1");
  ПутьДоБазы = "Srvr=""1.1.1.1:1111"";Ref=""TEST_BUH"";Usr=""user"";Pwd=""user"";";

Попытка
Соединение = В8.Connect(ПутьДоБазы);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()), СтатусСообщения.Важное);
КонецПопытки;
поставь точку останова и посмотри зайдет в исключения или нет, в строке путь до базы свои данные укажи


Добавлено: 17 Июл 2018, 11:14

Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?
дальше еще провались не туда смотртишь в V83 туда провались, там будет папка компоненты оттуда бери название

Последний раз редактировалось: Alex26; 17 Июл 2018, 11:18

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
для примера создай кнопку, напиши в ней
 В8 = Новый COMОбъект("V83.COMConnector.1");
  ПутьДоБазы = "Srvr=""1.1.1.1:1111"";Ref=""TEST_BUH"";Usr=""user"";Pwd=""user"";";

Попытка
Соединение = В8.Connect(ПутьДоБазы);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()), СтатусСообщения.Важное);
КонецПопытки;
поставь точку останова и посмотри зайдет в исключения или нет, в строке путь до базы свои данные укажи


Добавлено: 17 Июл 2018, 11:14

Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?
дальше еще провались не туда смотртишь в V83 туда провались, там будет папка компоненты оттуда бери название
Да, там V83.COMConnector.1 , вместо V83.COMConnector

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
кнопку создал? получилось подключиться? используй тогда .1 правильный вариант

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
кнопку создал? получилось подключиться? используй тогда .1 правильный вариант
Не, кнопку пока не создавал, вариант подключения у меня из серверной в файловую.
Пробовал прописать с .1 , результат тот же, не может он базу найти

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?
Да, могу!

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?
Да, могу!
попробуй создай кнопку
В8 = Новый COMОбъект("V83.COMConnector.1");
ПутьКБазе = "File=""C:\Users\1\Documents\InfoBase11"";Usr=""Администратор"";Pwd=""1"";";
Попытка
Соединение = В8.Connect(ПутьКБазе);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()) + " база ", СтатусСообщения.Важное);
КонецПопытки;
Соединение = "";
В8 = ""
путь к базе возьми с платформы при запуске вначале выбора базы, вставь в ПутьКБазе, и  проверь логин и пароль чтоб подходили

Последний раз редактировалось: Alex26; 17 Июл 2018, 12:32

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?
Да, могу!
попробуй создай кнопку
В8 = Новый COMОбъект("V83.COMConnector.1");
ПутьКБазе = "File=""C:\Users\1\Documents\InfoBase11"";Usr=""Администратор"";Pwd=""1"";";
Попытка
Соединение = В8.Connect(ПутьКБазе);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()) + " база ", СтатусСообщения.Важное);
КонецПопытки;
Соединение = "";
В8 = ""
путь к базе возьми с платформы при запуске вначале выбора базы, вставь в ПутьКБазе, и  проверь логин и пароль чтоб подходили
Ошибка создания объекта COMОбъект !


Теги:
 

Ошибка "Неправильный псевдоним "Т.Ссылка" <<?>> Т.Ссылка как номенклатура"

Автор Андрей БулановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 214
Последний ответ 13 Окт 2018, 21:51
от Андрей Буланов
При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5315
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7088
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5102
Последний ответ 28 Апр 2014, 15:53
от maskito
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 131
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
52 Сообщений
alexandr_ll
46 Сообщений
alex0402
44 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
29 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 283
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal