Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Сен 2018, 13:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При попытке соединения с COM-сервером произошла следующая ошибка  (Прочитано 1162 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Alex26

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 5
  • КПД: 17%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?


Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?

Оффлайн Alex26

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 5
  • КПД: 17%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
для примера создай кнопку, напиши в ней
 В8 = Новый COMОбъект("V83.COMConnector.1");
  ПутьДоБазы = "Srvr=""1.1.1.1:1111"";Ref=""TEST_BUH"";Usr=""user"";Pwd=""user"";";

Попытка
Соединение = В8.Connect(ПутьДоБазы);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()), СтатусСообщения.Важное);
КонецПопытки;
поставь точку останова и посмотри зайдет в исключения или нет, в строке путь до базы свои данные укажи


Добавлено: 17 Июл 2018, 11:14

Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?
дальше еще провались не туда смотртишь в V83 туда провались, там будет папка компоненты оттуда бери название

Последний раз редактировалось: Alex26; 17 Июл 2018, 11:18

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
для примера создай кнопку, напиши в ней
 В8 = Новый COMОбъект("V83.COMConnector.1");
  ПутьДоБазы = "Srvr=""1.1.1.1:1111"";Ref=""TEST_BUH"";Usr=""user"";Pwd=""user"";";

Попытка
Соединение = В8.Connect(ПутьДоБазы);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()), СтатусСообщения.Важное);
КонецПопытки;
поставь точку останова и посмотри зайдет в исключения или нет, в строке путь до базы свои данные укажи


Добавлено: 17 Июл 2018, 11:14

Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда Обработчик = Новый COMОбъект("V82.COMConnector"); Иначе Обработчик = Новый COMОбъект("V83.COMConnector"); КонецЕсли;
Зайди в компоненты посмотри у тебя точно так называется V83.COMConnector ? не V83.COMConnector.1 ?
дальше еще провались не туда смотртишь в V83 туда провались, там будет папка компоненты оттуда бери название
Да, там V83.COMConnector.1 , вместо V83.COMConnector

Оффлайн Alex26

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 5
  • КПД: 17%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
кнопку создал? получилось подключиться? используй тогда .1 правильный вариант

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
кнопку создал? получилось подключиться? используй тогда .1 правильный вариант
Не, кнопку пока не создавал, вариант подключения у меня из серверной в файловую.
Пробовал прописать с .1 , результат тот же, не может он базу найти

Оффлайн Alex26

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 5
  • КПД: 17%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?
Да, могу!

Оффлайн Alex26

  • *
  • Сообщений: 30
  • РЕПУТАЦИЯ: 5
  • КПД: 17%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?
Да, могу!
попробуй создай кнопку
В8 = Новый COMОбъект("V83.COMConnector.1");
ПутьКБазе = "File=""C:\Users\1\Documents\InfoBase11"";Usr=""Администратор"";Pwd=""1"";";
Попытка
Соединение = В8.Connect(ПутьКБазе);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()) + " база ", СтатусСообщения.Важное);
КонецПопытки;
Соединение = "";
В8 = ""
путь к базе возьми с платформы при запуске вначале выбора базы, вставь в ПутьКБазе, и  проверь логин и пароль чтоб подходили

Последний раз редактировалось: Alex26; 17 Июл 2018, 12:32

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Ты можешь в базу зайти файловую на сервере где база лежит клиент - серверная? то есть просто в пользовательском режиме открыть?
Да, могу!
попробуй создай кнопку
В8 = Новый COMОбъект("V83.COMConnector.1");
ПутьКБазе = "File=""C:\Users\1\Documents\InfoBase11"";Usr=""Администратор"";Pwd=""1"";";
Попытка
Соединение = В8.Connect(ПутьКБазе);
Исключение
Сообщить("" + ТекущаяДата() + " " +"Ошибка " + КраткоеПредставлениеОшибки(ИнформацияОбОшибке()) + " база ", СтатусСообщения.Важное);
КонецПопытки;
Соединение = "";
В8 = ""
путь к базе возьми с платформы при запуске вначале выбора базы, вставь в ПутьКБазе, и  проверь логин и пароль чтоб подходили
Ошибка создания объекта COMОбъект !


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5250
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7013
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5030
Последний ответ 28 Апр 2014, 15:53
от maskito
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 51
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10780
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

alexandr_ll
61 Сообщений
alex0402
47 Сообщений
MuI_I_Ika MuI_I_Ika
44 Сообщений
AIFrame AIFrame
36 Сообщений
LexaK
32 Сообщений
wise wise
29 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
27 Сообщений
Каримдат Каримдат
25 Сообщений
BuhRust
20 Сообщений
Golickoff Golickoff
19 Сообщений

* Кто онлайн

  • Точка Гостей: 704
  • Точка Скрытых: 1
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal