Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Ноя 2018, 23:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: При попытке соединения с COM-сервером произошла следующая ошибка  (Прочитано 1768 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Всем доброго времени суток!
1С:Предприятие 8.3 (8.3.9.2170)
Бухгалтерия для Казахстана, редакция 3.0
WindowsServer 2012 R2 Standart
64-х битный
Клиент-Серверная база (ms sql)
При попытке соединения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(415)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Ошибка доступа к файлу '\\172.16.10.244\bases\автовесовая завода\1Cv8.cdn'. 5(0x00000005): Отказано в доступе.
При файловом варианте, всё норм! Соединение устанавливается.
Серверная база на своём серваке, а фалойловая, к котором подключаемся на своём серваке. Пусть к базе прописан.
Что делать? Как получить доступ?


Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Попробовал ещё сделать так:
На самом сервере, создал в ФАЙЛОВОМ варианте базу и результат тот же, ошибка та же.
Хотя к самой папке доступ есть ,т.е я по сети с сервера, могу там создать какой-либо файл и удалить без проблем.

Оффлайн ДмитрийФ

  • *
  • Сообщений: 36
  • РЕПУТАЦИЯ: 10
  • КПД: 28%
  • Регистрация: 2016-01-29
  • Сайт: 
  • Профессия: Программист 1С
Хотя к самой папке доступ есть ,т.е я по сети с сервера, могу там создать какой-либо файл и удалить без проблем.
Возможно пользователь под которым стартует 1С все-таки не имеет доступа к папке.

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Хотя к самой папке доступ есть ,т.е я по сети с сервера, могу там создать какой-либо файл и удалить без проблем.
Возможно пользователь под которым стартует 1С все-таки не имеет доступа к папке.
Запуски под админом тоже не помогают. Да и на самом сервере, пользователь Администратор и USERSV8, под которым агент сервера работает

Оффлайн wise

  • *****
  • Сообщений: 709
  • РЕПУТАЦИЯ: 97
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(1) ЕСЛИ { Отказано в доступе } значит проблема с ПРАВАМИ.!!
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
(1) ЕСЛИ { Отказано в доступе } значит проблема с ПРАВАМИ.!!
Нет проблем с ПРАВАМИ, всем доступ открыт.
расположили обе базы на сервер, обе в файловый вариант, к базе, которой подключаемся ,полные права на папку и всё содержимое.
Итог При попытке соедиения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(415)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): {МодульВнешнегоСоединения(13)}: Ошибка при вызове конструктора (ComОбъект)

Последний раз редактировалось: Sheriff; 11 Июл 2018, 12:41

Оффлайн wise

  • *****
  • Сообщений: 709
  • РЕПУТАЦИЯ: 97
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(5) А вот ЭТО уже ИНТЕРЕСНЕЕ: { Ошибка при вызове конструктора (ComОбъект) }

напишите тестовый отчёт, который будет &наКлиенте создавать ComОбъект и подключаться туда.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
(5) А вот ЭТО уже ИНТЕРЕСНЕЕ: { Ошибка при вызове конструктора (ComОбъект) }

напишите тестовый отчёт, который будет &наКлиенте создавать ComОбъект и подключаться туда.
Теперь другая странность
При попытке соедиения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(415)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Информационная база не обнаружена
Отсутствует файл базы данных 'E:\Distr\Базы1С\блокировка документа/1Cv8.1CD'
Файл есть и доступ к нему есть.

Оффлайн Alex26

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 5
  • КПД: 16%
  • Регистрация: 2018-07-13
  • Сайт: 
  • Профессия: Программист 1С
    (5) А вот ЭТО уже ИНТЕРЕСНЕЕ: { Ошибка при вызове конструктора (ComОбъект) }

    напишите тестовый отчёт, который будет &наКлиенте создавать ComОбъект и подключаться туда.

Теперь другая странность
При попытке соедиения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(415)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Информационная база не обнаружена
Отсутствует файл базы данных 'E:\Distr\Базы1С\блокировка документа/1Cv8.1CD'
Файл есть и доступ к нему есть.

Скинь фрагмент кода как ты к базе подключаешься, и у тебя на сервере установлен компонент V83.COMConnector.1 ?

Оффлайн Sheriff

  • ***
  • Сообщений: 123
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2016-10-04
  • Сайт: 
  • Профессия: Ученик 1С
    (5) А вот ЭТО уже ИНТЕРЕСНЕЕ: { Ошибка при вызове конструктора (ComОбъект) }

    напишите тестовый отчёт, который будет &наКлиенте создавать ComОбъект и подключаться туда.

Теперь другая странность
При попытке соедиения с COM-сервером произошла следующая ошибка:
{ОбщийМодуль.МодульРегламентныхЗаданий.Модуль(415)}: Ошибка при вызове метода контекста (Connect): Произошла исключительная ситуация (V83.COMConnector.1): Информационная база не обнаружена
Отсутствует файл базы данных 'E:\Distr\Базы1С\блокировка документа/1Cv8.1CD'
Файл есть и доступ к нему есть.

Скинь фрагмент кода как ты к базе подключаешься, и у тебя на сервере установлен компонент V83.COMConnector.1 ?
Тут код при открытии списка Реализации
&НаСервере
Процедура ПриОткрытииНаСервере()
///////////////////////////////////////////////////////////// поключение к базе
///-- если константа заполнена то создаем соеденение
//ПутьКБазе = Константы.ЦЗС_АдресБазыАвтовесовой.Получить();
//Если  ЗначениеЗаполнено(Константы.ЦЗС_АдресБазыАвтовесовой.Получить()) Тогда

  //Если глV21Object = Неопределено Тогда
//ПутьКБазе = Константы.ЦЗС_АдресБазыАвтовесовой.Получить();
СтруктураПодключения = МодульРегламентныхЗаданий.ПолучитьСтруктуруПодключения_Авто() ;
глV21Object = МодульРегламентныхЗаданий.ПодключитсяКИнформационнойБазе2(СтруктураПодключения);
Если глV21Object = Неопределено Тогда
Сообщить( "Ошибка подключения к базе данных!!!", СтатусСообщения.Важное ) ;
Возврат ;
КонецЕсли;
Сообщить( ""+ТекущаяДата() + " - Подключение к конфигурации "+глV21Object.Метаданные.Synonym+" выполнено успешно!" ) ;
//КонецЕсли;
//КонецЕсли;

КонецПроцедуры
Тут уже модуль
Функция ПолучитьСтруктуруПодключения_Авто(КаталогИБДляПодключения="") Экспорт 

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ ПЕРВЫЕ 1
| НастройкаАвтовесовой.ПутьКБазе,
| НастройкаАвтовесовой.Платформа,
| НастройкаАвтовесовой.Серверная,
| НастройкаАвтовесовой.ИмяСервера,
| НастройкаАвтовесовой.ИмяБазы,
| НастройкаАвтовесовой.Пользователь,
| НастройкаАвтовесовой.Пароль
|ИЗ
| РегистрСведений.НастройкаАвтовесовой КАК НастройкаАвтовесовой
|ГДЕ
| НастройкаАвтовесовой.База = &База";

Запрос.УстановитьПараметр("База", Перечисления.УдаленныеБазы.АвтоВесовая);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Если ВыборкаДетальныеЗаписи.Следующий() Тогда
СтруктураПодключения = Новый Структура();
СтруктураПодключения.Вставить("ПутьКБазе" , ВыборкаДетальныеЗаписи.ПутьКБазе);
СтруктураПодключения.Вставить("Платформа" , Строка(ВыборкаДетальныеЗаписи.Платформа));
СтруктураПодключения.Вставить("СерверныйРежим", ВыборкаДетальныеЗаписи.Серверная);
СтруктураПодключения.Вставить("ИмяСервера" , ВыборкаДетальныеЗаписи.ИмяСервера);
СтруктураПодключения.Вставить("ИмяБазы" , ВыборкаДетальныеЗаписи.ИмяБазы);
СтруктураПодключения.Вставить("Пользователь" , ВыборкаДетальныеЗаписи.Пользователь);
СтруктураПодключения.Вставить("Пароль" , ВыборкаДетальныеЗаписи.Пароль);
Возврат СтруктураПодключения;
КонецЕсли;

Возврат Неопределено;

КонецФункции // ПолучитьСтруктуруПодключения()


//=== ФУНКЦИИ ОБРАБОТКИ ПОДКЛЮЧЕНИЯ К УДАЛЕННО БАЗЕ ДАННЫХ ======================
// их можно вставить в общий модуль, и обращаться из рахных объектов
Функция ПодключитсяКИнформационнойБазе2(СтруктураПараметров, СтрокаСообщенияОбОшибке = "") Экспорт

Перем СтрокаПодключения;

Если СтруктураПараметров = Неопределено Тогда
Возврат Неопределено;
КонецЕсли;

ПараметровДостаточно = МодульЦемзавод.ОпределитьДостаточностьПараметровДляПодключенияКИнформационнойБазе(СтруктураПараметров, СтрокаПодключения, СтрокаСообщенияОбОшибке);

Если Не ПараметровДостаточно Тогда
Возврат Неопределено;
КонецЕсли;

Если СтруктураПараметров.СерверныйРежим Тогда
ПараметрыПодключения = "Srvr=""" + СокрЛП(СтруктураПараметров.ИмяСервера) + """; Ref=""" + СокрЛП(СтруктураПараметров.ИмяБазы) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
Иначе
ПараметрыПодключения = "File=""" + СокрЛП(СтруктураПараметров.ПутьКБазе) + """; Usr=""" + СокрЛП(СтруктураПараметров.Пользователь) + """; Pwd=""" + СокрЛП(СтруктураПараметров.Пароль) + """;";
КонецЕсли;


Попытка
//#Если Клиент Тогда
//Состояние("Идет процесс соединения ...");
Сообщить("Идет процесс соединения ...");
//#КонецЕсли


Попытка
Если СтруктураПараметров.Платформа = Перечисления.Платформы.Платформа82 Тогда
Обработчик = Новый COMОбъект("V82.COMConnector");
Иначе
Обработчик = Новый COMОбъект("V83.COMConnector");
КонецЕсли;
Исключение
Сообщить("Ошибка создания объекта "+Обработчик+" !") ;
Сообщить(ОписаниеОшибки()) ;
КонецПопытки;


ТекCOMОбъект = Обработчик.Connect(ПараметрыПодключения);

//#Если Клиент Тогда
//Состояние("Соединение установлено");
Сообщить("Соединение установлено");
//#КонецЕсли

Исключение

СтрокаСообщенияОбОшибке = "При попытке соедиения с COM-сервером произошла следующая ошибка:" + Символы.ПС
+ ОписаниеОшибки();
//#Если Клиент Тогда
Сообщить(СтрокаСообщенияОбОшибке, СтатусСообщения.Важное);
    //Состояние("Соединение установить не удалось");
//Состояние();
    Сообщить("Соединение установить не удалось");
//#КонецЕсли

Возврат Неопределено;

КонецПопытки;

Возврат ТекCOMОбъект;

КонецФункции
Компонента установлена и зарегистрирована.
Вообще на сервере стоит только одна платформа 8.3
Обе базы работают на этой платформе, просто одна серверная, а другая файловая.
Я установил SQL и платформу на обычную винду, чистую и сделал всё так же, как на рабочем сервере и у меня с этим кодом всё работает на моём компе, а на рабочем сервере НЕТ.
Каждый раз пишет разные ошибки.


Теги:
 

Ошибка "Неправильный псевдоним "Т.Ссылка" <<?>> Т.Ссылка как номенклатура"

Автор Андрей БулановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 214
Последний ответ 13 Окт 2018, 21:51
от Андрей Буланов
При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5315
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7088
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5102
Последний ответ 28 Апр 2014, 15:53
от maskito
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 131
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

wise wise
58 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
52 Сообщений
alexandr_ll
46 Сообщений
alex0402
44 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
42 Сообщений
LexaK
31 Сообщений
BuhRust
29 Сообщений
andron81_81
24 Сообщений
MuI_I_Ika MuI_I_Ika
22 Сообщений

* Кто онлайн

  • Точка Гостей: 274
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal