Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 18:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вопрос про архитектуру 1с (Вкладки на форме и код к ним - где и как искать)  (Прочитано 3490 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kinderus

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-02
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 7.7 (7.70.027)
Конфигурация  ТиС (Торговля и склад) (7.70.944)
Всем привет, я не 1с программист , занимаюсь SAP R/3, но меня попросили кое в чем разобраться.
Дело вот в чем:
В 1С есть справочники в них есть контрагенты, в контрагентах (если выбрать какого-нибудь из списка) есть вкладка «Прочее» и на форме этой вкладки есть поле «Адрес электронной почты». Задача для бывалого 1с программиста наверно оч проста - мне надо выгрузить все адреса электронки в файл в столбик для каждого контрагента. Так как я не занаю ни языка ни архитектуры 1с мне это сделать сложно. Вот я и прошу помощи, быстро разобраться.
Я полез в конфигуратор там полез в «Редактировать конфигурацию»->Справочники->контрагенты, нажал на них «Редактировать» в появившемся окне нажал на «форма элемента», мне вывалилось окно с двумя вкладками «диалог» и    «модуль», ну тут вроде как у Delphi форма и код для нее,  все понятно, но вот я не  могу понять почему на форме нет вкладок, в самом 1с там на форме есть вкладка «прочие» а в конфигураторе ее на форме нет. И еще в «Редактировать конфигурацию»->Справочники->контрагенты в дереве  у этих контрагентов есть поле «ЭлПочта», я так понял это называется «Реквизит».
Мне не понятно где и как искать формы для вкладок например для формы «Контрагенты» - там несколько вкладок и как найти для них графические формы в кофигураторе мне не понятно.
Впринципе я понял как создавать формы и как кодить для них, но вот как создавать вкладки и элементы я не могу понять, а уж тем более как найти уже созданные и код к ним.
Расскажите мне плз вкратце про это все  дело, в коде я разберусь уже не первый году прогаю, но только  на других языках.
Спасибо.


Оффлайн kinderus

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-02
  • Сайт: 
  • Профессия: Ученик 1С
Оч круто, спасибо огромное, вопрос только а как выделить все в консоли ? я CTRL+A жму но что то не катит.

Оффлайн kinderus

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-04-02
  • Сайт: 
  • Профессия: Ученик 1С
вот что я сделал, немного дописал твой код

Процедура Сформировать()
    к = создатьОбъект("Справочник.Контрагенты");
   Т=СоздатьОбъект("Текст");
   
    к.ВыбратьЭлементы();
    Пока к.ПолучитьЭлемент()=1 Цикл
        Если к.ЭтоГруппа()=1 Тогда
            продолжить;
        КонецЕсли;
       
        майл = СокрЛП(к.ЭлПочта);
        Если ПустоеЗначение(майл)=0 Тогда
           // сообщить(""+СокрЛП(к.ЮрФизЛицо.ПолнНаименование)+";"+символТабуляции+майл);
         Т.ДобавитьСтроку(""+СокрЛП(к.ЮрФизЛицо.ПолнНаименование)+";"+майл);     
          сообщить(""+СокрЛП(к.ЮрФизЛицо.ПолнНаименование)+";"+майл);
        КонецЕсли;
   КонецЦикла;
   Файл="c:\"+"EmailList"+".csv";
   Т.Записать(Файл);
КонецПроцедуры


Спасибо тебе огромное )))))))


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 446
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal