Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Апр 2019, 07:41
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проведение документа по кнопке Записать а не Провести?  (Прочитано 7360 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Добрый день.

Есть документ "АктОтгрузкиОборудования" движение по регистрам проходит без проблем. Здесь все нормально.

Но мне необходимо выполнить движение по регистрам не проводя фактически документ! Тойсть по нажатию на кнопку "Записать".

Делаю так:

&НаСервере
Процедура ПослеЗаписиНаСервере(ТекущийОбъект, ПараметрыЗаписи)

Объект.Ссылка.ПолучитьОбъект().ОбработкаПроведения("Отказ", "Режим");

КонецПроцедуры


Эффекта ноль! В регистрах нечего не появляется пока не нажму "Провести". Пробовал размещать вызов этой процедуры в различных обработчиках(ПослеЗаписи, ПередЗаписью) все в пустую!

Подскажите как это осуществить?


Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Спасибо
sergejK74
но это не то...

Обресую еще раз проблемму.
У меня есть стандартная процедура "ОбработкаПроведения" в модуле документа. Эта процедура работает как и должна. Но мне необходимо чтоб она отработала при нажатии на кнопку "Записать"!

Делаю следующее в модуле формы:

НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
   
   Объект.Ссылка.ПолучитьОбъект().ОбработкаПроведения("Отказ", "Режим")
   
КонецПроцедуры


Получаю вот что:

{Документ.АктОтгрузкиОборудования.Форма.ФормаДокумента_Управляемая.Форма(56)}: Ошибка при вызове метода контекста (ПолучитьОбъект): Элемент не выбран!
   Объект.Ссылка.ПолучитьОбъект().ОбработкаПроведения(Отказ,РежимПроведенияДокумента.Неоперативный)
по причине:
Элемент не выбран!

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Спасибо sergejK74! Теперь все ок!

Я упорно хотел это сделать в модуле формы) Вcе, теперь разобрался. Спасибо!

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
А расскажите, для каких целей такое могло понадобиться? Чем не устраивало обычное проведение?
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Serega456

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 4
  • КПД: 57%
  • Регистрация: 2011-04-04
  • Сайт: help1c.by
  • Профессия: Разработчик 1С
Вот такой вариант попробуй
&НаСервере
Процедура ПриЗаписиНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
   ТекущийОбъект.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры


Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
А расскажите, для каких целей такое могло понадобиться? Чем не устраивало обычное проведение?

У нас в организации используется система статусов. Тойсть различные документы, двигают по ркгистру различные статусы в зависимости от документа/операции. А клиент на сайте, может наблюдать состояние его позиции. Так вот при записи должен двигаться статус "Подготовлен к отправке" а уже при проведении соответственно "Отправлени".

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Такие варианты, обычно, все-равно делаются при обычном проведении, но разных документов. Не лучший способ - вызывать проведение без проведения. Транзакции по заказу все-равно должны быть по утверждению тех или иных документов - соответственно, при их проведении.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5187
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 18943
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5381
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2089
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8765
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
85 Сообщений
AIFrame AIFrame
45 Сообщений
alexandr_ll
39 Сообщений
alex0402
30 Сообщений
wise wise
19 Сообщений
BuhRust
14 Сообщений
byte777
14 Сообщений
LexaK
14 Сообщений
pavl_vs
13 Сообщений
Weidermail
13 Сообщений

* Кто онлайн

  • Точка Гостей: 322
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal