Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 сен 2021, 00:53

Ошибка при вызове контекста (Записать)

Автор Sork, 16 апр 2018, 21:04

0 Пользователей и 1 гость просматривают эту тему.

Sork

добрый вечер, возникла такая проблема: попытался в Рознице выгрузить данные о продажах в FoxPro и столкнулся с такой ошибкой: http://priscree.ru/img/a301fe72e60cf1.png
как я понял,программа пытается сохранить файл заново,а не использует уже имеющийся, облазил весь инет,решения не нашел, надеюсь тут что-то подскажут.
Процедура СоздатьНастройкуОбменаНаСервере()
//Проверка текущего узла
ТекПриврежим = ПривилегированныйРежим();
УстановитьПривилегированныйРежим(Истина);
Выборка = ПланыОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат.Выбрать();
Пока Выборка.Следующий() Цикл
Если Выборка.ЭтотУзел Тогда
Если НЕ ЗначениеЗаполнено(Выборка.Код) Тогда
ЭтаБазаобъект = Выборка.ПолучитьОбъект();
ЭтаБазаобъект.Код = "FP001";
ЭтаБазаобъект.Наименование = "Эта информационная база";
ЭтаБазаобъект.ПравилаОтправкиДокументов = "АвтоматическаяСинхронизация";
ЭтаБазаобъект.ПравилаОтправкиСправочников = "АвтоматическаяСинхронизация";
ЭтаБазаобъект.РежимВыгрузкиДокументов = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
ЭтаБазаобъект.РежимВыгрузкиПриНеобходимости = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПриНеобходимости;
ЭтаБазаобъект.РежимВыгрузкиСправочников = Перечисления.РежимыВыгрузкиОбъектовОбмена.ВыгружатьПоУсловию;
ЭтаБазаобъект.Записать();
КонецЕсли;
КонецЕсли;
КонецЦикла;

новПлан = ПланыОбмена.СинхронизацияДанныхЧерезУниверсальныйФормат.СоздатьУзел();
новПлан.Наименование = "FoxPRO";
новПлан.Код = ("FP002");
новПлан.Записать();                                            // на этом месте выдает ошибку                                     
НастройкаОбменаДанными = новПлан.Ссылка;
УстановитьПривилегированныйРежим(ТекПриврежим);
КонецПроцедуры

вот сам код

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск