Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Ноя 2019, 10:29
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Автоматическое заполнение данных документа из справочника?  (Прочитано 17525 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн sawogle

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-07-24
  • Сайт: 
  • Профессия: Ученик 1С
Получать реквизиты реквизита (простите за каламбур) на клиенте - только через серверную функцию.

В ПриИзменении пишете

СтруктураДанныхКонтрагента = ПолучитьДанныеКонтрагента(Объект.Контрагент);
Телефон = СтруктураДанныхКонтрагента.Телефон;
Адрес = СтруктураДанныхКонтрагента.Адрес;

И здесь же в модуле создаете серверную функцию

&НаСервереБезКонтекста
Функция ПолучитьДанныеКонтрагента(Контрагент)
СтруктураДанных = Новый Структура("Телефон, Адрес");
ЗаполнитьЗначенияСвойств(СтруктураДанных, Контрагент);
Возврат СтруктураДанных;
КонецФункции

Здравствуйте
При этой функции у меня вылезает ошибка

Добавлено: 14 Окт 2017, 19:20

Друзья. Спасибо Вам огромное за то, что завалили меня ответами:)!

Вариант sergejK74 мне понравился. По этому я разместил в ОбщемМодуле следующий код:

Функция ПолучитьПараметрыКонтагента(Контрагент) Экспорт
   
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Контрагенты.Адрес,
        |    Контрагенты.Телефон,
| Контрагенты.ТипКонтрагента,
|    Контрагенты.ВидКонтрагента,
|    Контрагенты.VIP,
|    Контрагенты.VIPПриоритет,
|    Контрагенты.НеГудКлиент,
|    Контрагенты.СтатусНеГудКлиента,
| Контрагенты.ДополнительнаяИнформация
        |ИЗ
        |    Справочник.Контрагенты КАК Контрагенты
        |ГДЕ
        |    Контрагенты.Ссылка = &Ссылка";

    Запрос.УстановитьПараметр("Ссылка", Контрагент);

    Результат = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = Результат.Выбрать();

    СписокПараметров = Новый Структура;
   
    СписокПараметров.Вставить("Адрес");
    СписокПараметров.Вставить("Телефон");
    СписокПараметров.Вставить("ТипКонтрагента");
СписокПараметров.Вставить("ВидКонтрагента");
СписокПараметров.Вставить("VIP");
    СписокПараметров.Вставить("VIPПриоритет");
    СписокПараметров.Вставить("НеГудКлиент");
    СписокПараметров.Вставить("СтатусНеГудКлиента");
СписокПараметров.Вставить("ДополнительнаяИнформация");


Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       
    СписокПараметров.Адрес = ВыборкаДетальныеЗаписи.Адрес;
    СписокПараметров.Телефон = ВыборкаДетальныеЗаписи.Телефон;
    СписокПараметров.ТипКонтрагента = ВыборкаДетальныеЗаписи.ТипКонтрагента;
СписокПараметров.ВидКонтрагента = ВыборкаДетальныеЗаписи.ВидКонтрагента;
СписокПараметров.VIP = ВыборкаДетальныеЗаписи.VIP;
СписокПараметров.VIPПриоритет = ВыборкаДетальныеЗаписи.VIPПриоритет;
СписокПараметров.НеГудКлиент = ВыборкаДетальныеЗаписи.НеГудКлиент;
СписокПараметров.СтатусНеГудКлиента = ВыборкаДетальныеЗаписи.СтатусНеГудКлиента;
СписокПараметров.ДополнительнаяИнформация = ВыборкаДетальныеЗаписи.ДополнительнаяИнформация;
       
    КонецЕсли;

    Возврат СписокПараметров;   

КонецФункции


Ну и там где надо, в формах создал обработчики:

Процедура КонтрагентПриИзменении(Элемент)
    Парам = ПодсчетыИПодстановки.ПолучитьПараметрыКонтагента(Объект.Контрагент);
Объект.КонтактноеИнфо = Парам.Адрес +" " + "Телефон:" + Парам.Телефон;
Объект.ТипКонтрагента = Парам.ТипКонтрагента;
Объект.ВидКонтрагента = Парам.ВидКонтрагента;
Объект.НеГудКлиент = Парам.НеГудКлиент;
Объект.СтатусНеГудКлиента = Парам.СтатусНеГудКлиента;
Объект.ДопИнфо = Парам.ДополнительнаяИнформация;
Объект.VIP = Парам.VIP;
Объект.VIPПриоритет = Парам.VIPПриоритет;
КонецПроцедуры


Подобного рода создал еще пару Общих функций для других реквизитов и теперь все подстовляется где надо и не надо  :D


Всем спасибо. Вы мне очень помогли!
Еще раз здравствуйте!!!!
НЕ получается. Помогите пожалуйста Заранее Спасибо

Последний раз редактировалось: sawogle; 14 Окт 2017, 19:20. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5689
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9341
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7405
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 12620
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 8870
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
78 Сообщений
Chgdz
33 Сообщений
BuhRust
32 Сообщений
wise wise
30 Сообщений
MuI_I_Ika MuI_I_Ika
30 Сообщений
alexandr_ll
23 Сообщений
Пересвет Пересвет
21 Сообщений
LexaK
21 Сообщений
Бактыжан Килибаев Бактыжан Килибаев
20 Сообщений
The Kaban
10 Сообщений

* Кто онлайн

  • Точка Гостей: 217
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal